Ingress Nginx Integration
[infra/stack/kubernetes.git] / vars / kubernetes.yaml
index 905bb35..8a9b614 100644 (file)
@@ -45,46 +45,55 @@ installers:
 # repository. Curated apps are not listed separately either as they are
 # similar to scenarios; they are available in installer repository.
 scenarios:
+  - k8-calico-dualstack
   - k8-calico-istio
   - k8-calico-nofeature
   - k8-calico-spinnaker
+  - k8-calico-eiffel
   - k8-canal-nofeature
   - k8-cilium-nofeature
   - k8-flannel-nofeature
+  - k8-multus-dualstack
   - k8-multus-nofeature
   - k8-multus-plugins
+  - k8-eno-ovs
   - k8-weave-nofeature
 
+# NOTE (fdegir): set default deploy scenario for the stack
+deploy_scenario: "{{ lookup('env', 'DEPLOY_SCENARIO') | default('k8-multus-plugins', true) }}"
+deployment_image_version: "{{ lookup('env', 'DEPLOYMENT_IMAGE_VERSION') | default('v2', true) }}"
+
 # -------------------------------------------------------------------------------
 # Nordix: Docker version
 # -------------------------------------------------------------------------------
-# NOTE (fdegir): versions of docker as of 13.02.2020 matching to what Kubespray uses
-# Please note that docker-ce version is configured to be overrideable since some scenarios
-# require different docker versions
-docker_ce_version: "{{ lookup('env', 'DOCKER_CE_VERSION') | default('5:18.09.9~3-0~ubuntu-bionic', true) }}"
+# NOTE (fdegir): versions of docker as of 13.07.2020 matching to what Kubespray requires
+docker_ce_version: "5:19.03.12~3-0~ubuntu-bionic"
 docker_ce_cli_version: "{{ docker_ce_version }}"
 docker_registry_version: "2.7.1"
-containerd_io_version: "1.2.6-3"
+containerd_io_version: "1.2.13-2"
 
 # -------------------------------------------------------------------------------
-# Kubernetes: Kubernetes and kubectl versions
+# Kubernetes: Kubernetes kubectl and Ingress versions
 # -------------------------------------------------------------------------------
 # Kubernetes version that is supported by the pinned kubespray version
-kubernetes_version: "v1.17.0"
+kubernetes_version: "v1.19.11"
 # version of the kubectl should generally match to the version of kubernetes itself
 # but it would be good to have possibility to override it in case if someone needs it for some reason
 kubectl_version: "{{ kubernetes_version }}"
+ingress_nginx_version: "v1.1.1"
 
 # -------------------------------------------------------------------------------
 # Kubernetes: Versions of rook, ceph and their dependencies
 # -------------------------------------------------------------------------------
-rook_version: "v1.1.2"
-ceph_version: "v14.2.4-20190917"
-cephcsi_version: "v1.2.1"
-csi_node_driver_registrar_version: "v1.1.0"
-csi_attacher_version: "v1.2.0"
-csi_provisioner_version: "v1.3.0"
-csi_snapshotter_version: "v1.2.0"
+rook_version: "v1.6.0"
+busybox_version: "1.32.0"
+ceph_version: "v14.2.18-20210316"
+cephcsi_version: "v3.2.0"
+csi_node_driver_registrar_version: "v2.0.1"
+csi_resizer_version: "v1.0.0"
+csi_attacher_version: "v3.0.0"
+csi_provisioner_version: "v2.0.0"
+csi_snapshotter_version: "v3.0.0"
 
 # -------------------------------------------------------------------------------
 # Kubernetes: Versions of prometheus and its dependencies
@@ -103,10 +112,19 @@ prom_push_gateway_version: "v1.0.1"
 spinnaker_version: "1.23.2"
 spinnaker_app_version: "1.16.2"
 
+# -------------------------------------------------------------------------------
+# Kubernetes: Versions of eno and its dependencies
+# -------------------------------------------------------------------------------
+eno_version: "master"
+sriov_network_device_plugin_version: "v3.3.2"
+ovs_cni_version: "50a6e66bb84e54087cf52a9b9241f6283ad2e16f"
+whereabouts_version: "v0.4.2"
+network_resources_injector_version: "v1.2"
+
 # -------------------------------------------------------------------------------
 # Kubernetes: App versions
 # -------------------------------------------------------------------------------
-helm_version: "v2.16.1"
+helm_version: "v3.5.4"
 charts_version: "0b64349aeb537d0fd038df0e1d40ec5cf1206609"
 istio_version: "1.3.1"