Ingress Nginx Integration
[infra/stack/kubernetes.git] / vars / kubernetes.yaml
index 98bbbb4..8a9b614 100644 (file)
@@ -49,6 +49,7 @@ scenarios:
   - k8-calico-istio
   - k8-calico-nofeature
   - k8-calico-spinnaker
+  - k8-calico-eiffel
   - k8-canal-nofeature
   - k8-cilium-nofeature
   - k8-flannel-nofeature
@@ -60,6 +61,7 @@ scenarios:
 
 # NOTE (fdegir): set default deploy scenario for the stack
 deploy_scenario: "{{ lookup('env', 'DEPLOY_SCENARIO') | default('k8-multus-plugins', true) }}"
+deployment_image_version: "{{ lookup('env', 'DEPLOYMENT_IMAGE_VERSION') | default('v2', true) }}"
 
 # -------------------------------------------------------------------------------
 # Nordix: Docker version
@@ -71,13 +73,14 @@ docker_registry_version: "2.7.1"
 containerd_io_version: "1.2.13-2"
 
 # -------------------------------------------------------------------------------
-# Kubernetes: Kubernetes and kubectl versions
+# Kubernetes: Kubernetes kubectl and Ingress versions
 # -------------------------------------------------------------------------------
 # Kubernetes version that is supported by the pinned kubespray version
 kubernetes_version: "v1.19.11"
 # version of the kubectl should generally match to the version of kubernetes itself
 # but it would be good to have possibility to override it in case if someone needs it for some reason
 kubectl_version: "{{ kubernetes_version }}"
+ingress_nginx_version: "v1.1.1"
 
 # -------------------------------------------------------------------------------
 # Kubernetes: Versions of rook, ceph and their dependencies
@@ -114,7 +117,7 @@ spinnaker_app_version: "1.16.2"
 # -------------------------------------------------------------------------------
 eno_version: "master"
 sriov_network_device_plugin_version: "v3.3.2"
-ovs_cni_version: "v0.24.0"
+ovs_cni_version: "50a6e66bb84e54087cf52a9b9241f6283ad2e16f"
 whereabouts_version: "v0.4.2"
 network_resources_injector_version: "v1.2"