| #!/usr/bin/make -f |
| |
| # Uncomment this to turn on verbose mode. |
| #export DH_VERBOSE=1 |
| |
| # This is the debhelper compatibility version to use. |
| export DH_COMPAT=3 |
| |
| VERSION = $(shell dpkg-parsechangelog | grep ^Version: | cut -d ' ' -f 2) |
| ARCH = $(shell dpkg --print-architecture) |
| |
| ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS))) |
| DODEBUG = true |
| endif |
| ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS))) |
| endif |
| |
| build-arch: build-arch-stamp |
| build-arch-stamp: |
| $(MAKE) clean |
| cp ./debian/config-deb .config |
| $(MAKE) dep |
| $(MAKE) DODEBUG=$(DODEBUG) |
| install busybox busybox-deb |
| |
| $(MAKE) clean |
| cp ./debian/config-static .config |
| $(MAKE) dep |
| $(MAKE) DODEBUG=$(DODEBUG) |
| install busybox busybox-static |
| |
| $(MAKE) clean |
| cp ./debian/config-udeb .config |
| $(MAKE) dep |
| $(MAKE) DODEBUG=$(DODEBUG) |
| |
| $(MAKE) docs/BusyBox.1 |
| |
| touch build-arch-stamp |
| |
| build: build-arch |
| |
| clean: |
| dh_testdir |
| dh_testroot |
| rm -f build-arch-stamp build-indep-stamp debian/files~ |
| |
| $(MAKE) distclean |
| -rm -f busybox-deb busybox-static busybox.1 |
| |
| dh_clean |
| |
| install: build-arch |
| dh_testdir |
| dh_testroot |
| dh_clean -k |
| dh_installdirs |
| |
| install busybox-deb $(CURDIR)/debian/busybox-cvs/bin/busybox |
| install busybox-static $(CURDIR)/debian/busybox-cvs-static/bin/busybox |
| $(MAKE) PREFIX=$(CURDIR)/debian/busybox-cvs-udeb install |
| cp docs/BusyBox.1 busybox.1 |
| |
| install -m644 debian/busybox-cvs-static.override \ |
| debian/busybox-cvs-static/usr/share/lintian/overrides/busybox-cvs-static |
| |
| # Build architecture-dependent files here. |
| binary-arch: build-arch install |
| dh_testdir -a |
| dh_testroot -a |
| # dh_installdebconf -a |
| dh_installdocs -a -Nbusybox-cvs-udeb |
| # dh_installexamples -a |
| # dh_installmenu -a |
| # dh_installlogrotate -a |
| # dh_installemacsen -a |
| # dh_installpam -a |
| # dh_installmime -a |
| # dh_installinit -a |
| # dh_installcron -a |
| dh_installman -a -Nbusybox-cvs-udeb |
| # dh_installinfo -a |
| # dh_undocumented -a |
| dh_installchangelogs Changelog -a -Nbusybox-cvs-udeb |
| dh_strip -a |
| dh_link -a |
| dh_compress -a |
| dh_fixperms -a |
| # dh_makeshlibs -a |
| dh_installdeb -a |
| # dh_perl -a |
| dh_shlibdeps -a |
| dh_gencontrol -a -Nbusybox-cvs-udeb |
| dh_md5sums -a -Nbusybox-cvs-udeb |
| dh_builddeb -a -Nbusybox-cvs-udeb |
| |
| dh_gencontrol -pbusybox-cvs-udeb -- -fdebian/files~ |
| dpkg-distaddfile busybox-cvs-udeb_$(VERSION)_$(ARCH).udeb debian-installer extra |
| dh_builddeb -pbusybox-cvs-udeb --filename=busybox-cvs-udeb_$(VERSION)_$(ARCH).udeb |
| |
| binary: binary-arch |
| .PHONY: build clean binary-indep binary-arch binary install |