Eric Andersen | b108a5b | 2000-06-19 09:21:34 +0000 | [diff] [blame] | 1 | #!/usr/bin/make -f |
| 2 | |
Glenn L McGrath | 1b16bf6 | 2002-11-23 07:14:55 +0000 | [diff] [blame] | 3 | export DH_VERBOSE=1 |
| 4 | export DH_COMPAT=3 |
Eric Andersen | b108a5b | 2000-06-19 09:21:34 +0000 | [diff] [blame] | 5 | |
Glenn L McGrath | 0ff941e | 2002-11-26 09:05:15 +0000 | [diff] [blame] | 6 | # These wont actually do anything yet, need to hack Rules.mak |
Glenn L McGrath | 1b16bf6 | 2002-11-23 07:14:55 +0000 | [diff] [blame] | 7 | ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS))) |
| 8 | CFLAGS += -g |
| 9 | endif |
| 10 | ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS))) |
| 11 | INSTALL_PROGRAM += -s |
| 12 | endif |
Eric Andersen | b108a5b | 2000-06-19 09:21:34 +0000 | [diff] [blame] | 13 | |
Glenn L McGrath | 1b16bf6 | 2002-11-23 07:14:55 +0000 | [diff] [blame] | 14 | busybox-deb: |
Eric Andersen | b108a5b | 2000-06-19 09:21:34 +0000 | [diff] [blame] | 15 | dh_testdir |
| 16 | dh_testroot |
Glenn L McGrath | 1b16bf6 | 2002-11-23 07:14:55 +0000 | [diff] [blame] | 17 | $(MAKE) clean |
| 18 | cp ./debian/config-deb .config |
Glenn L McGrath | 2f79f5b | 2002-11-26 03:08:31 +0000 | [diff] [blame] | 19 | cp ./debian/Rules.mak.shared Rules.mak |
Glenn L McGrath | 1b16bf6 | 2002-11-23 07:14:55 +0000 | [diff] [blame] | 20 | $(MAKE) dep |
| 21 | $(MAKE) |
Glenn L McGrath | 0ff941e | 2002-11-26 09:05:15 +0000 | [diff] [blame] | 22 | install -D busybox ./debian/busybox-unstable/bin/busybox |
| 23 | dh_installchangelogs Changelog -pbusybox-unstable |
| 24 | dh_installdocs -pbusybox-unstable |
| 25 | dh_strip -pbusybox-unstable |
| 26 | dh_compress -pbusybox-unstable |
| 27 | dh_fixperms -pbusybox-unstable |
| 28 | dh_installdeb -pbusybox-unstable |
| 29 | dh_shlibdeps -pbusybox-unstable |
| 30 | dh_gencontrol -pbusybox-unstable |
| 31 | dh_md5sums -pbusybox-unstable |
| 32 | dh_builddeb -pbusybox-unstable |
| 33 | |
Glenn L McGrath | 1b16bf6 | 2002-11-23 07:14:55 +0000 | [diff] [blame] | 34 | busybox-udeb: |
Eric Andersen | b108a5b | 2000-06-19 09:21:34 +0000 | [diff] [blame] | 35 | dh_testdir |
| 36 | dh_testroot |
Glenn L McGrath | 1b16bf6 | 2002-11-23 07:14:55 +0000 | [diff] [blame] | 37 | $(MAKE) clean |
| 38 | cp ./debian/config-udeb .config |
Glenn L McGrath | 2f79f5b | 2002-11-26 03:08:31 +0000 | [diff] [blame] | 39 | cp ./debian/Rules.mak.shared Rules.mak |
Glenn L McGrath | 1b16bf6 | 2002-11-23 07:14:55 +0000 | [diff] [blame] | 40 | $(MAKE) dep |
| 41 | $(MAKE) |
Glenn L McGrath | 10d905c | 2002-11-27 23:24:49 +0000 | [diff] [blame] | 42 | $(MAKE) PREFIX=./debian/busybox-udeb/ install |
Glenn L McGrath | 0ff941e | 2002-11-26 09:05:15 +0000 | [diff] [blame] | 43 | dh_strip -pbusybox-unstable-udeb |
| 44 | dh_compress -pbusybox-unstable-udeb |
| 45 | dh_fixperms -pbusybox-unstable-udeb |
| 46 | dh_installdeb -pbusybox-unstable-udeb |
| 47 | dh_shlibdeps -pbusybox-unstable-udeb |
| 48 | dh_gencontrol -pbusybox-unstable-udeb |
| 49 | dh_md5sums -pbusybox-unstable-udeb |
| 50 | dh_builddeb -pbusybox-unstable-udeb |
Eric Andersen | b108a5b | 2000-06-19 09:21:34 +0000 | [diff] [blame] | 51 | |
| 52 | |
Glenn L McGrath | 1b16bf6 | 2002-11-23 07:14:55 +0000 | [diff] [blame] | 53 | busybox-static: |
Eric Andersen | e2f6e12 | 2000-12-01 19:55:04 +0000 | [diff] [blame] | 54 | dh_testdir |
| 55 | dh_testroot |
Glenn L McGrath | 1b16bf6 | 2002-11-23 07:14:55 +0000 | [diff] [blame] | 56 | $(MAKE) clean |
| 57 | cp ./debian/config-static .config |
Glenn L McGrath | 2f79f5b | 2002-11-26 03:08:31 +0000 | [diff] [blame] | 58 | cp ./debian/Rules.mak.static Rules.mak |
Glenn L McGrath | 1b16bf6 | 2002-11-23 07:14:55 +0000 | [diff] [blame] | 59 | $(MAKE) dep |
| 60 | $(MAKE) |
Glenn L McGrath | 0ff941e | 2002-11-26 09:05:15 +0000 | [diff] [blame] | 61 | install -D busybox ./debian/busybox-unstable-static/bin/busybox |
| 62 | dh_installchangelogs Changelog -pbusybox-unstable-static |
| 63 | dh_installdocs -pbusybox-unstable-static |
| 64 | dh_strip -pbusybox-unstable-static |
| 65 | dh_compress -pbusybox-unstable-static |
| 66 | dh_fixperms -pbusybox-unstable-static |
| 67 | dh_installdeb -pbusybox-unstable-static |
| 68 | dh_shlibdeps -pbusybox-unstable-static |
| 69 | dh_gencontrol -pbusybox-unstable-static |
| 70 | dh_md5sums -pbusybox-unstable-static |
| 71 | dh_builddeb -pbusybox-unstable-static |
Glenn L McGrath | 1b16bf6 | 2002-11-23 07:14:55 +0000 | [diff] [blame] | 72 | |
| 73 | binary-arch: busybox-deb busybox-udeb busybox-static |
Eric Andersen | e2f6e12 | 2000-12-01 19:55:04 +0000 | [diff] [blame] | 74 | |
Glenn L McGrath | 12371f9 | 2002-11-26 02:16:06 +0000 | [diff] [blame] | 75 | binary-indep: |
| 76 | dh_testdir |
| 77 | dh_testroot |
| 78 | $(MAKE) clean |
| 79 | $(MAKE) newdoc |
Glenn L McGrath | 0ff941e | 2002-11-26 09:05:15 +0000 | [diff] [blame] | 80 | dh_installdocs -pbusybox-unstable-doc |
| 81 | dh_installchangelogs Changelog -pbusybox-unstable-doc |
| 82 | dh_compress -pbusybox-unstable-doc |
| 83 | dh_fixperms -pbusybox-unstable-doc |
| 84 | dh_installdeb -pbusybox-unstable-doc |
| 85 | dh_gencontrol -pbusybox-unstable-doc |
| 86 | dh_md5sums -pbusybox-unstable-doc |
| 87 | dh_builddeb -pbusybox-unstable-doc |
Glenn L McGrath | 12371f9 | 2002-11-26 02:16:06 +0000 | [diff] [blame] | 88 | |
Eric Andersen | b108a5b | 2000-06-19 09:21:34 +0000 | [diff] [blame] | 89 | binary: binary-indep binary-arch |
Glenn L McGrath | 1b16bf6 | 2002-11-23 07:14:55 +0000 | [diff] [blame] | 90 | .PHONY: build clean binary-indep binary-arch binary install configure |