Eric Andersen | cc8ed39 | 1999-10-05 16:24:54 +0000 | [diff] [blame^] | 1 | Name: busybox |
| 2 | Version: 0.29alpha |
| 3 | Release: 1 |
| 4 | Group: System/Utilities |
| 5 | Summary: BusyBox is a tiny suite of Unix utilities in a multi-call binary. |
| 6 | Copyright: GPL |
| 7 | Packager : Erik Andersen <andersen@lineo.com> |
| 8 | Conflicts: fileutils grep shellutils |
| 9 | Buildroot: /tmp/%{Name}-%{Version} |
| 10 | Source: busybox-0.29a1.tar.gz |
| 11 | |
| 12 | %Description |
| 13 | BusyBox is a suite of "tiny" Unix utilities in a multi-call binary. It |
| 14 | provides a pretty complete environment that fits on a floppy or in a |
| 15 | ROM. Just add "ash" (Keith Almquists tiny Bourne shell clone) and "ae", |
| 16 | and a kernel and you have a full system. This is used on the Debian |
| 17 | install disk and in an internet router, and it makes a good environment |
| 18 | for a "rescue" disk or any small or embedded system. |
| 19 | |
| 20 | %Prep |
| 21 | %setup -q -n busybox |
| 22 | |
| 23 | %Build |
| 24 | make |
| 25 | |
| 26 | %Install |
| 27 | rm -rf $RPM_BUILD_ROOT |
| 28 | mkdir -p $RPM_BUILD_ROOT/bin |
| 29 | h=`cat busybox.links` |
| 30 | |
| 31 | for i in $h ; do |
| 32 | mkdir -p $RPM_BUILD_ROOT/`echo $i | sed -e 's/\(^.*\/\)\(.*\)/\1/g' ` |
| 33 | (cd $RPM_BUILD_ROOT/bin ; ln -s ln `echo $i | sed -e 's/\(^.*\/\)\(.*\)/\2/g' ` ); |
| 34 | done |
| 35 | rm -f $RPM_BUILD_ROOT/bin/ln |
| 36 | install -m 755 busybox $RPM_BUILD_ROOT/bin/ln |
| 37 | |
| 38 | %Clean |
| 39 | rm -rf $RPM_BUILD_ROOT |
| 40 | |
| 41 | %Files |
| 42 | %defattr(-,root,root) |
| 43 | / |