rpm: VPP-1674: exclude external headers from rpm

External libraries headers such as DPDK, libibverb, quicly, etc. should
not be packaged in vpp-dev RPM.
Only package headers from vpp/ and vom/ subdirs.

Change-Id: Ief1454bd1261c8cf4dcd3b105e28f6852439e896
Signed-off-by: Benoît Ganne <bganne@cisco.com>
diff --git a/extras/rpm/vpp.spec b/extras/rpm/vpp.spec
index 6d2732c..8b8f10e 100644
--- a/extras/rpm/vpp.spec
+++ b/extras/rpm/vpp.spec
@@ -228,7 +228,7 @@
 #
 # devel
 #
-for dir in $(find %{_mu_build_dir}/%{_vpp_install_dir}/*/include/ -maxdepth 0 -type d -print | grep -v dpdk)
+for dir in %{_mu_build_dir}/%{_vpp_install_dir}/{vom,vpp}/include/
 do
 	for subdir in $(cd ${dir} && find . -type d -print)
 	do