blob: 7046105c10b5f974cfa97c592705b82f411db8f7 [file] [log] [blame]
Ed Warnickecb9cada2015-12-08 15:45:58 -07001#!/usr/bin/make -f
2# See debhelper(7) (uncomment to enable)
3# output every command that modifies files on the build system.
4DH_VERBOSE = 1
5
6# see EXAMPLES in dpkg-buildflags(1) and read /usr/share/dpkg/*
7DPKG_EXPORT_BUILDFLAGS = 1
8include /usr/share/dpkg/default.mk
9
10# see FEATURE AREAS in dpkg-buildflags(1)
11#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
12
13# see ENVIRONMENT in dpkg-buildflags(1)
14# package maintainers to append CFLAGS
15#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
16# package maintainers to append LDFLAGS
17#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
18
19# main packaging script based on dh7 syntax
20%:
Damjan Marion2ce7f982017-01-09 20:24:50 +010021 dh $@ --with systemd,python2
Ed Warnickecb9cada2015-12-08 15:45:58 -070022
23override_dh_install:
24 dh_install --exclude .git
Damjan Mariona1bd0232016-12-19 19:08:11 +010025 ../scripts/remove-rpath .
Ed Warnickecb9cada2015-12-08 15:45:58 -070026
Damjan Marioncb58b232017-01-03 11:39:51 +010027override_dh_shlibdeps:
28 @dh_shlibdeps 2>&1 \
29 | grep -v "probably a plugin" \
30 | grep -v "similar warnings have been skipped"
31
Ed Warnickecb9cada2015-12-08 15:45:58 -070032override_dh_strip:
33 dh_strip --dbg-package=vpp-dbg