Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 1 | #!/usr/bin/make -f |
| 2 | # See debhelper(7) (uncomment to enable) |
| 3 | # output every command that modifies files on the build system. |
| 4 | DH_VERBOSE = 1 |
| 5 | |
| 6 | # see EXAMPLES in dpkg-buildflags(1) and read /usr/share/dpkg/* |
| 7 | DPKG_EXPORT_BUILDFLAGS = 1 |
| 8 | include /usr/share/dpkg/default.mk |
| 9 | |
| 10 | # see FEATURE AREAS in dpkg-buildflags(1) |
| 11 | #export DEB_BUILD_MAINT_OPTIONS = hardening=+all |
| 12 | |
| 13 | # see ENVIRONMENT in dpkg-buildflags(1) |
| 14 | # package maintainers to append CFLAGS |
| 15 | #export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic |
| 16 | # package maintainers to append LDFLAGS |
| 17 | #export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed |
| 18 | |
| 19 | # main packaging script based on dh7 syntax |
| 20 | %: |
Damjan Marion | 2ce7f98 | 2017-01-09 20:24:50 +0100 | [diff] [blame] | 21 | dh $@ --with systemd,python2 |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 22 | |
| 23 | override_dh_install: |
| 24 | dh_install --exclude .git |
Damjan Marion | a1bd023 | 2016-12-19 19:08:11 +0100 | [diff] [blame] | 25 | ../scripts/remove-rpath . |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 26 | |
Damjan Marion | cb58b23 | 2017-01-03 11:39:51 +0100 | [diff] [blame] | 27 | override_dh_shlibdeps: |
| 28 | @dh_shlibdeps 2>&1 \ |
| 29 | | grep -v "probably a plugin" \ |
| 30 | | grep -v "similar warnings have been skipped" |
| 31 | |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 32 | override_dh_strip: |
| 33 | dh_strip --dbg-package=vpp-dbg |