blob: 39be1b57e0451788fe9d2b119608cc52559aaaad [file] [log] [blame]
Ed Warnickecb9cada2015-12-08 15:45:58 -07001#!/usr/bin/make -f
2# See debhelper(7) (uncomment to enable)
3# output every command that modifies files on the build system.
4DH_VERBOSE = 1
5
6# see EXAMPLES in dpkg-buildflags(1) and read /usr/share/dpkg/*
7DPKG_EXPORT_BUILDFLAGS = 1
8include /usr/share/dpkg/default.mk
9
10# see FEATURE AREAS in dpkg-buildflags(1)
11#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
12
13# see ENVIRONMENT in dpkg-buildflags(1)
14# package maintainers to append CFLAGS
15#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
16# package maintainers to append LDFLAGS
17#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
18
Ole Troanafaa85f2017-03-20 21:38:37 +010019export PYBUILD_NAME = vpp-api-python
20export PYBUILD_DIR = ../../src/vpp-api/python
21export PYBUILD_DESTDIR_python2=debian/vpp-api-python/
22export PYBUILD_DISABLE_python2=test
23export PYBUILD_SYSTEM=distutils
24
Ed Warnickecb9cada2015-12-08 15:45:58 -070025# main packaging script based on dh7 syntax
26%:
Ole Troanafaa85f2017-03-20 21:38:37 +010027 dh $@ --with systemd,python2 --buildsystem=pybuild
Ed Warnickecb9cada2015-12-08 15:45:58 -070028
29override_dh_install:
30 dh_install --exclude .git
Damjan Mariona1bd0232016-12-19 19:08:11 +010031 ../scripts/remove-rpath .
Ed Warnickecb9cada2015-12-08 15:45:58 -070032
Damjan Marioncb58b232017-01-03 11:39:51 +010033override_dh_shlibdeps:
34 @dh_shlibdeps 2>&1 \
Gabriel Ganneaddb55b2017-11-06 14:09:06 +010035 | { grep -v -e "probably a plugin" -e "similar warnings have been skipped" || true; }
Damjan Marioncb58b232017-01-03 11:39:51 +010036
Ed Warnickecb9cada2015-12-08 15:45:58 -070037override_dh_strip:
38 dh_strip --dbg-package=vpp-dbg