Add initial meta-stx to support StarlingX build

meta-stx is a yocto compatible layer that includes
required recipes to build image for StarlingX on top
of yocto 2.7.3 (warrior).

And the following components are included:
- Fault management
- Configuration management
- Software management
- Host management
- Service management
- Ansible and puppet for provisioning

Issue-ID: INF-8
Issue-ID: INF-9
Issue-ID: INF-10
Issue-ID: INF-11
Issue-ID: INF-12
Issue-ID: INF-13
Issue-ID: INF-19
Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
Change-Id: I4e85c8232df3bf390aa247c75061a54b914bd28a
diff --git a/meta-stx/recipes-devtools/erlang/erlang_R16B03-1.bbappend b/meta-stx/recipes-devtools/erlang/erlang_R16B03-1.bbappend
new file mode 100644
index 0000000..b3d75da
--- /dev/null
+++ b/meta-stx/recipes-devtools/erlang/erlang_R16B03-1.bbappend
@@ -0,0 +1,39 @@
+#
+## Copyright (C) 2019 Wind River Systems, Inc.
+#
+#  Licensed under the Apache License, Version 2.0 (the "License");
+#  you may not use this file except in compliance with the License.
+#  You may obtain a copy of the License at
+#
+#      http://www.apache.org/licenses/LICENSE-2.0
+#
+#  Unless required by applicable law or agreed to in writing, software
+#  distributed under the License is distributed on an "AS IS" BASIS,
+#  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+#  See the License for the specific language governing permissions and
+#  limitations under the License.
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+# erlang < 20.0 is not compatibel with OpenSSL 1.1.x
+inherit openssl10
+
+SRC_URI += " \
+	file://fix-install-ownership.patch \
+	"
+
+EXTRA_OECONF = '--with-ssl=${STAGING_DIR_TARGET}/usr --without-krb5 --without-zlib'
+
+do_configure_prepend () {
+    export erl_xcomp_sysroot="${STAGING_DIR_HOST}/usr"
+    export erl_xcomp_isysroot="${STAGING_DIR_NATIVE}"
+
+    sed -i -e 's/opensslconf.h/opensslconf-64.h/' \
+        ${STAGING_INCDIR}/openssl10/openssl/rc4.h \
+        ${STAGING_INCDIR}/openssl10/openssl/rc2.h
+}
+
+do_install_append () {
+    # Fix the do_package_qa issue
+    chown -R root:root ${D}
+}