Add initial meta-stx to support StarlingX build
meta-stx is a yocto compatible layer that includes
required recipes to build image for StarlingX on top
of yocto 2.7.3 (warrior).
And the following components are included:
- Fault management
- Configuration management
- Software management
- Host management
- Service management
- Ansible and puppet for provisioning
Issue-ID: INF-8
Issue-ID: INF-9
Issue-ID: INF-10
Issue-ID: INF-11
Issue-ID: INF-12
Issue-ID: INF-13
Issue-ID: INF-19
Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
Change-Id: I4e85c8232df3bf390aa247c75061a54b914bd28a
diff --git a/meta-stx/recipes-devtools/python/python-magnumclient_git.bb b/meta-stx/recipes-devtools/python/python-magnumclient_git.bb
new file mode 100644
index 0000000..4e37b9b
--- /dev/null
+++ b/meta-stx/recipes-devtools/python/python-magnumclient_git.bb
@@ -0,0 +1,51 @@
+#
+## Copyright (C) 2019 Wind River Systems, Inc.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+DESCRIPTION = "Python client for containers service"
+HOMEPAGE = "https://github.com/openstack/python-magnumclient"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
+
+SRCREV = "37e602d160632a386c2960ec8777bfc65642a9a9"
+SRCNAME = "python-magnumclient"
+PROTOCOL = "https"
+BRANCH = "master"
+S = "${WORKDIR}/git"
+PV = "2.12.0+git${SRCPV}"
+
+SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
+
+DEPENDS += " \
+ python-pip \
+ python-pbr-native \
+ "
+
+RDEPENDS_${PN} +=" \
+ python-pbr \
+ python-babel \
+ python-stevedore \
+ python-requests \
+ python-oslo.i18n \
+ python-oslo.serialization \
+ python-oslo.utils \
+ python-os-client-config \
+ python-osc-lib \
+ python-prettytable \
+ python-cryptography \
+ python-decorator \
+ "
+
+inherit setuptools