blob: c21bfd888230c3de5a72c96b01d754982a1cc1bf [file] [log] [blame]
Jackie Huang57fdea72020-04-23 11:29:15 +08001#
2# Copyright (C) 2019 Wind River Systems, Inc.
3#
4# Licensed under the Apache License, Version 2.0 (the "License");
5# you may not use this file except in compliance with the License.
6# You may obtain a copy of the License at
7#
8# http://www.apache.org/licenses/LICENSE-2.0
9#
10# Unless required by applicable law or agreed to in writing, software
11# distributed under the License is distributed on an "AS IS" BASIS,
12# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13# See the License for the specific language governing permissions and
14# limitations under the License.
15
16# Update log with the message: adopted from upstream e1f2e1ae5f27d889e3d4bef1b23edcf8a6d804c0
17DESCRIPTION = " \
18 PrettyTable is a simple Python library designed to make it quick and easy to represent tabular data \
19 in visually appealing ASCII tables. It was inspired by the ASCII tables used in the PostgreSQL shell \
20 psql. PrettyTable allows for selection of which columns are to be printed, independent alignment of \
21 columns (left or right justified or centred) and printing of “sub-tables” by specifying a row range.\
22 "
23
24LICENSE = "BSD"
25LIC_FILES_CHKSUM = "file://COPYING;md5=3e73500ffa52de5071cff65990055282"
26
27SRC_URI[md5sum] = "0c1361104caff8b09f220748f9d69899"
28SRC_URI[sha256sum] = "a53da3b43d7a5c229b5e3ca2892ef982c46b7923b51e98f0db49956531211c4f"
29
30SRCNAME = "prettytable"
31
32SRC_URI = "https://pypi.python.org/packages/source/P/PrettyTable/${SRCNAME}-${PV}.zip"
33
34S = "${WORKDIR}/${SRCNAME}-${PV}"
35
36inherit setuptools3
37do_install_append() {
38 find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "*.txt" -o -name "PKG-INFO" -exec chmod 644 {} +
39}
40
41BBCLASSEXTEND = "native nativesdk"