Jackie Huang | 57fdea7 | 2020-04-23 11:29:15 +0800 | [diff] [blame] | 1 | # |
| 2 | ## Copyright (C) 2019 Wind River Systems, Inc. |
| 3 | # |
| 4 | # Licensed under the Apache License, Version 2.0 (the "License"); |
| 5 | # you may not use this file except in compliance with the License. |
| 6 | # You may obtain a copy of the License at |
| 7 | # |
| 8 | # http://www.apache.org/licenses/LICENSE-2.0 |
| 9 | # |
| 10 | # Unless required by applicable law or agreed to in writing, software |
| 11 | # distributed under the License is distributed on an "AS IS" BASIS, |
| 12 | # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. |
| 13 | # See the License for the specific language governing permissions and |
| 14 | # limitations under the License. |
| 15 | |
| 16 | DESCRIPTION = "Python client for containers service" |
| 17 | HOMEPAGE = "https://github.com/openstack/python-magnumclient" |
| 18 | SECTION = "devel/python" |
| 19 | LICENSE = "Apache-2.0" |
| 20 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314" |
| 21 | |
| 22 | SRCREV = "37e602d160632a386c2960ec8777bfc65642a9a9" |
| 23 | SRCNAME = "python-magnumclient" |
| 24 | PROTOCOL = "https" |
| 25 | BRANCH = "master" |
| 26 | S = "${WORKDIR}/git" |
| 27 | PV = "2.12.0+git${SRCPV}" |
| 28 | |
| 29 | SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}" |
| 30 | |
| 31 | DEPENDS += " \ |
| 32 | python-pip \ |
| 33 | python-pbr-native \ |
| 34 | " |
| 35 | |
| 36 | RDEPENDS_${PN} +=" \ |
| 37 | python-pbr \ |
| 38 | python-babel \ |
| 39 | python-stevedore \ |
| 40 | python-requests \ |
| 41 | python-oslo.i18n \ |
| 42 | python-oslo.serialization \ |
| 43 | python-oslo.utils \ |
| 44 | python-os-client-config \ |
| 45 | python-osc-lib \ |
| 46 | python-prettytable \ |
| 47 | python-cryptography \ |
| 48 | python-decorator \ |
| 49 | " |
| 50 | |
| 51 | inherit setuptools |