blob: 69fd13fa68483bc61f1c7073e40479711d2d5f21 [file] [log] [blame]
Jackie Huang57fdea72020-04-23 11:29:15 +08001#
2## Copyright (C) 2019 Wind River Systems, Inc.
3#
4# Licensed under the Apache License, Version 2.0 (the "License");
5# you may not use this file except in compliance with the License.
6# You may obtain a copy of the License at
7#
8# http://www.apache.org/licenses/LICENSE-2.0
9#
10# Unless required by applicable law or agreed to in writing, software
11# distributed under the License is distributed on an "AS IS" BASIS,
12# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13# See the License for the specific language governing permissions and
14# limitations under the License.
15
16DESCRIPTION = "Oslo policy library"
17HOMEPAGE = "https://github.com/openstack/oslo.policy"
18SECTION = "devel/python"
19LICENSE = "Apache-2.0"
20LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
21
22SRCREV = "b9fd10e2612f26c93d49c168a0408aba6d20e5bf"
23SRCNAME = "oslo.policy"
24PROTOCOL = "https"
25BRANCH = "stable/train"
26S = "${WORKDIR}/git"
27PV = "1.43.1+git${SRCPV}"
28
29SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
30
31inherit setuptools
32
33DEPENDS += " \
34 python-pip \
35 python-pbr-native \
36 "
37
38RDEPENDS_${PN} += " \
39 python-oslo.config \
40 python-oslo.i18n \
41 python-oslo.serialization \
42 python-oslo.utils \
43 python-six \
44 python-pyyaml \
45 python-requests \
46 "