Add synchronous SDL readiness waiting API
Add a new synchronous API function 'SyncStorage::waitReady()', which
can be used to wait SDL service readiness for the given namespace.
Function can be used to validate SDL service readiness for example
after application container start-up before any other
SDL operations (set, get, remove) are tried to do.
Also timeout value can be given to 'SyncStorage::waitReady()' function
to define expiration time for the case when readiness validation hangs
too long.
Issue-ID: RIC-226
Signed-off-by: Timo Tietavainen <timo.tietavainen@nokia.com>
Change-Id: Ic334cf04fa6c80f04a3c3e06b01fbf1ff7e940fd
diff --git a/debian/changelog.in b/debian/changelog.in
index 45e9059..16fe8b8 100644
--- a/debian/changelog.in
+++ b/debian/changelog.in
@@ -1,3 +1,9 @@
+sdl (1.4.0-1) UNRELEASED; urgency=low
+
+ * Add synchronous readiness check API
+
+ -- Timo Tietavainen <timo.tietavainen@nokia.com> Wed, 11 Aug 2021 08:02:59 +0300
+
sdl (1.3.0-1) UNRELEASED; urgency=low
* Definable timeout for DB backend readiness in synchronous SDL API