blob: e658683cf056e6c4a1d08cbae468da9b18e9e264 [file] [log] [blame]
Simon Kelleyc72daea2012-01-05 21:33:27 +00001#!/usr/bin/make -f
2# debian/rules file - for dnsmasq.
3# Copyright 2001-2011 by Simon Kelley
4# Based on the sample in the debian hello package which carries the following:
5# Copyright 1994,1995 by Ian Jackson.
6# I hereby give you perpetual unlimited permission to copy,
7# modify and relicense this file, provided that you do not remove
8# my name from the file itself. (I assert my moral right of
9# paternity under the Copyright, Designs and Patents Act 1988.)
10# This file may have to be extensively modified
11
12package=dnsmasq-base
13
Simon Kelley97c83bb2012-05-28 18:21:59 +010014CFLAGS = $(shell export DEB_BUILD_OPTIONS=$(DEB_BUILD_OPTIONS); dpkg-buildflags --get CFLAGS)
15CFLAGS += $(shell dpkg-buildflags --get CPPFLAGS)
16CFLAGS += -Wall -W
17
18LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
Simon Kelleyc72daea2012-01-05 21:33:27 +000019
20COPTS =
Simon Kelley97c83bb2012-05-28 18:21:59 +010021
Simon Kelleyc72daea2012-01-05 21:33:27 +000022TARGET = install-i18n
23
24DEB_BUILD_ARCH_OS := $(shell dpkg-architecture -qDEB_BUILD_ARCH_OS)
25
Simon Kelley62779782012-02-10 21:19:25 +000026ifeq (,$(filter nodbus,$(DEB_BUILD_OPTIONS)))
Simon Kelleyc72daea2012-01-05 21:33:27 +000027 COPTS += -DHAVE_DBUS
28endif
29
Simon Kelley62779782012-02-10 21:19:25 +000030ifeq (,$(filter noconntrack,$(DEB_BUILD_OPTIONS)))
Simon Kelleyc72daea2012-01-05 21:33:27 +000031ifeq ($(DEB_BUILD_ARCH_OS),linux)
32 COPTS += -DHAVE_CONNTRACK
33endif
34endif
35
Simon Kelley3ddad242013-03-21 17:56:06 +000036ifneq (,$(filter noipset,$(DEB_BUILD_OPTIONS)))
37 COPTS += -DNO_IPSET
Simon Kelley3b323bd2013-02-22 21:55:29 +000038endif
39
Simon Kelley96c38792012-02-16 20:07:17 +000040ifneq (,$(filter nodhcp6,$(DEB_BUILD_OPTIONS)))
41 COPTS += -DNO_DHCP6
Simon Kelley127ea402012-02-11 22:14:52 +000042endif
43
Simon Kelley62779782012-02-10 21:19:25 +000044ifneq (,$(filter noipv6,$(DEB_BUILD_OPTIONS)))
Simon Kelleyc72daea2012-01-05 21:33:27 +000045 COPTS += -DNO_IPV6
46endif
47
Simon Kelley62779782012-02-10 21:19:25 +000048ifneq (,$(filter notftp,$(DEB_BUILD_OPTIONS)))
Simon Kelleyc72daea2012-01-05 21:33:27 +000049 COPTS += -DNO_TFTP
50endif
51
Simon Kelley62779782012-02-10 21:19:25 +000052ifneq (,$(filter nodhcp,$(DEB_BUILD_OPTIONS)))
Simon Kelleyc72daea2012-01-05 21:33:27 +000053 COPTS += -DNO_DHCP
54endif
55
Simon Kelley62779782012-02-10 21:19:25 +000056ifneq (,$(filter noscript,$(DEB_BUILD_OPTIONS)))
Simon Kelleyc72daea2012-01-05 21:33:27 +000057 COPTS += -DNO_SCRIPT
58endif
59
Simon Kelley62779782012-02-10 21:19:25 +000060ifneq (,$(filter nortc,$(DEB_BUILD_OPTIONS)))
Simon Kelleyc72daea2012-01-05 21:33:27 +000061 COPTS += -DHAVE_BROKEN_RTC
62endif
63
Simon Kelley62779782012-02-10 21:19:25 +000064ifneq (,$(filter noi18n,$(DEB_BUILD_OPTIONS)))
Simon Kelleyc72daea2012-01-05 21:33:27 +000065 TARGET = install
Simon Kelley62779782012-02-10 21:19:25 +000066 ifeq (,$(filter noidn, $(DEB_BUILD_OPTIONS)))
Simon Kelleyc72daea2012-01-05 21:33:27 +000067 COPTS += -DHAVE_IDN
68 endif
69endif
70
Simon Kelley62779782012-02-10 21:19:25 +000071ifneq (,$(filter uselua,$(DEB_BUILD_OPTIONS)))
72 COPTS += -DHAVE_LUASCRIPT
73endif
74
Simon Kelleyc72daea2012-01-05 21:33:27 +000075clean:
76 $(checkdir)
77 rm -rf debian/daemon debian/base debian/utils debian/*~ debian/files debian/substvars debian/utils-substvars
78 make clean
79 make -C contrib/wrt clean
80
81binary-indep: checkroot
82 $(checkdir)
83 rm -rf debian/daemon
84 install -m 755 \
85 -d debian/daemon/DEBIAN \
86 -d debian/daemon/usr/share/doc \
87 -d debian/daemon/etc/init.d \
88 -d debian/daemon/etc/dnsmasq.d \
89 -d debian/daemon/etc/resolvconf/update.d \
90 -d debian/daemon/usr/lib/resolvconf/dpkg-event.d \
91 -d debian/daemon/etc/default \
Simon Kelleyc72daea2012-01-05 21:33:27 +000092 -d debian/daemon/lib/systemd/system \
93 -d debian/daemon/etc/insserv.conf.d
94 install -m 644 debian/conffiles debian/daemon/DEBIAN
95 install -m 755 debian/postinst debian/postrm debian/prerm debian/daemon/DEBIAN
96 install -m 755 debian/init debian/daemon/etc/init.d/dnsmasq
97 install -m 755 debian/resolvconf debian/daemon/etc/resolvconf/update.d/dnsmasq
98 install -m 755 debian/resolvconf-package debian/daemon/usr/lib/resolvconf/dpkg-event.d/dnsmasq
99 install -m 644 debian/default debian/daemon/etc/default/dnsmasq
100 install -m 644 dnsmasq.conf.example debian/daemon/etc/dnsmasq.conf
101 install -m 644 debian/readme.dnsmasq.d debian/daemon/etc/dnsmasq.d/README
Simon Kelleyc72daea2012-01-05 21:33:27 +0000102 install -m 644 debian/systemd.service debian/daemon/lib/systemd/system/dnsmasq.service
103 install -m 644 debian/insserv debian/daemon/etc/insserv.conf.d/dnsmasq
104 ln -s $(package) debian/daemon/usr/share/doc/dnsmasq
105 cd debian/daemon && find . -type f ! -regex '.*DEBIAN/.*' -printf '%P\0' | xargs -r0 md5sum > DEBIAN/md5sums
106 dpkg-gencontrol -pdnsmasq -Pdebian/daemon
107 chown -R root.root debian/daemon
108 chmod -R g-ws debian/daemon
109 dpkg --build debian/daemon ..
110
111binary-arch: checkroot
112 $(checkdir)
113 rm -rf debian/base
114 install -m 755 \
115 -d debian/base/DEBIAN \
Simon Kelley4ba9b382012-07-29 17:07:48 +0100116 -d debian/base/etc/dbus-1/system.d \
Simon Kelleyc72daea2012-01-05 21:33:27 +0000117 -d debian/base/usr/share/doc/$(package) \
118 -d debian/base/usr/share/doc/$(package)/examples \
119 -d debian/base/var/run \
120 -d debian/base/var/lib/misc
Simon Kelley43c271b2012-06-07 10:02:53 +0100121 make $(TARGET) PREFIX=/usr DESTDIR=`pwd`/debian/base CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" COPTS="$(COPTS)" CC=gcc
Simon Kelleyc72daea2012-01-05 21:33:27 +0000122ifeq (,$(findstring nodocs,$(DEB_BUILD_OPTIONS)))
123 install -m 644 doc.html debian/base/usr/share/doc/$(package)/.
124 install -m 644 setup.html debian/base/usr/share/doc/$(package)/.
125 install -m 644 dnsmasq.conf.example debian/base/usr/share/doc/$(package)/examples/.
126 install -m 644 FAQ debian/base/usr/share/doc/$(package)/.
127 gzip -9 debian/base/usr/share/doc/$(package)/FAQ
128 install -m 644 CHANGELOG debian/base/usr/share/doc/$(package)/changelog
129 gzip -9 debian/base/usr/share/doc/$(package)/changelog
130 install -m 644 CHANGELOG.archive debian/base/usr/share/doc/$(package)/changelog.archive
131 gzip -9 debian/base/usr/share/doc/$(package)/changelog.archive
132 install -m 644 dbus/DBus-interface debian/base/usr/share/doc/$(package)/.
133 gzip -9 debian/base/usr/share/doc/$(package)/DBus-interface
134endif
Simon Kelley4ba9b382012-07-29 17:07:48 +0100135 install -m 644 debian/dnsmasq-base.conffiles debian/base/DEBIAN/conffiles
Simon Kelleybc54ae32012-08-28 21:26:56 +0100136 install -m 755 debian/dnsmasq-base.postinst debian/base/DEBIAN/postinst
137 install -m 755 debian/dnsmasq-base.postrm debian/base/DEBIAN/postrm
Simon Kelleyc72daea2012-01-05 21:33:27 +0000138 install -m 644 debian/changelog debian/base/usr/share/doc/$(package)/changelog.Debian
139 gzip -9 debian/base/usr/share/doc/$(package)/changelog.Debian
140 install -m 644 debian/readme debian/base/usr/share/doc/$(package)/README.Debian
141 install -m 644 debian/copyright debian/base/usr/share/doc/$(package)/copyright
Simon Kelley4ba9b382012-07-29 17:07:48 +0100142 install -m 644 debian/dbus.conf debian/base/etc/dbus-1/system.d/dnsmasq.conf
Simon Kelleyc72daea2012-01-05 21:33:27 +0000143 gzip -9 debian/base/usr/share/man/man8/dnsmasq.8
144 for f in debian/base/usr/share/man/*; do \
145 if [ -f $$f/man8/dnsmasq.8 ]; then \
146 gzip -9 $$f/man8/dnsmasq.8 ; \
147 fi \
148 done
149ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
150 strip -R .note -R .comment debian/base/usr/sbin/dnsmasq
151endif
152 cd debian/base && find . -type f ! -regex '.*DEBIAN/.*' -printf '%P\0' | xargs -r0 md5sum > DEBIAN/md5sums
153 dpkg-shlibdeps debian/base/usr/sbin/dnsmasq
154 dpkg-gencontrol -pdnsmasq-base -Pdebian/base
155 chown -R root.root debian/base
156 chmod -R g-ws debian/base
157 dpkg --build debian/base ..
158
159ifeq ($(DEB_BUILD_ARCH_OS),linux)
160 rm -rf debian/utils
161 install -m 755 -d debian/utils/DEBIAN \
162 -d debian/utils/usr/share/man/man1 \
163 -d debian/utils/usr/bin \
164 -d debian/utils/usr/share/doc/dnsmasq-utils
Simon Kelley43c271b2012-06-07 10:02:53 +0100165 make -C contrib/wrt PREFIX=/usr DESTDIR=`pwd`/debian/utils CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" COPTS="$(COPTS)" CC=gcc
Simon Kelleyc72daea2012-01-05 21:33:27 +0000166 install -m 755 contrib/wrt/dhcp_release debian/utils/usr/bin/dhcp_release
167 install -m 644 contrib/wrt/dhcp_release.1 debian/utils/usr/share/man/man1/dhcp_release.1
168 gzip -9 debian/utils/usr/share/man/man1/dhcp_release.1
169 install -m 755 contrib/wrt/dhcp_lease_time debian/utils/usr/bin/dhcp_lease_time
170 install -m 644 contrib/wrt/dhcp_lease_time.1 debian/utils/usr/share/man/man1/dhcp_lease_time.1
171 install -m 644 debian/copyright debian/utils/usr/share/doc/dnsmasq-utils/copyright
172 install -m 644 debian/changelog debian/utils/usr/share/doc/dnsmasq-utils/changelog.Debian
173 gzip -9 debian/utils/usr/share/doc/dnsmasq-utils/changelog.Debian
174 gzip -9 debian/utils/usr/share/man/man1/dhcp_lease_time.1
175ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
176 strip -R .note -R .comment debian/utils/usr/bin/dhcp_release
177 strip -R .note -R .comment debian/utils/usr/bin/dhcp_lease_time
178endif
179 cd debian/utils && find . -type f ! -regex '.*DEBIAN/.*' -printf '%P\0' | xargs -r0 md5sum > DEBIAN/md5sums
180 dpkg-shlibdeps -Tdebian/utils-substvars debian/utils/usr/bin/dhcp_release debian/utils/usr/bin/dhcp_lease_time
181 dpkg-gencontrol -Tdebian/utils-substvars -pdnsmasq-utils -Pdebian/utils
182 chown -R root.root debian/utils
183 chmod -R g-ws debian/utils
184 dpkg --build debian/utils ..
185endif
186
187define checkdir
188 test -f Makefile -a -f debian/rules
189endef
190
191# Below here is fairly generic really
192
193binary: binary-arch binary-indep
Simon Kelley760169f2012-03-09 14:27:49 +0000194
Simon Kelleyc72daea2012-01-05 21:33:27 +0000195build:
Simon Kelley760169f2012-03-09 14:27:49 +0000196build-arch:
197build-indep:
Simon Kelleyc72daea2012-01-05 21:33:27 +0000198
199checkroot:
200 test root = "`whoami`"
201
202.PHONY: binary binary-arch binary-indep clean checkroot
203
204