blob: 8d634a35eeb1ed7fe5ed30c62deb974d62f6b78f [file] [log] [blame]
Simon Kelleyc72daea2012-01-05 21:33:27 +00001#!/usr/bin/make -f
2# debian/rules file - for dnsmasq.
Simon Kelley2a8710a2020-01-05 16:40:06 +00003# Copyright 2001-2020 by Simon Kelley
Simon Kelleyc72daea2012-01-05 21:33:27 +00004# Based on the sample in the debian hello package which carries the following:
5# Copyright 1994,1995 by Ian Jackson.
6# I hereby give you perpetual unlimited permission to copy,
7# modify and relicense this file, provided that you do not remove
8# my name from the file itself. (I assert my moral right of
9# paternity under the Copyright, Designs and Patents Act 1988.)
10# This file may have to be extensively modified
11
12package=dnsmasq-base
13
Simon Kelleya24c31e2017-04-16 22:45:53 +010014dpkg_buildflags := DEB_BUILD_MAINT_OPTIONS="hardening=+all,+pie,+bindnow" dpkg-buildflags
Simon Ruderich91f4a5e2014-05-20 20:27:31 +010015
16CFLAGS = $(shell $(dpkg_buildflags) --get CFLAGS)
17CFLAGS += $(shell $(dpkg_buildflags) --get CPPFLAGS)
Simon Kelley97c83bb2012-05-28 18:21:59 +010018CFLAGS += -Wall -W
19
Simon Ruderich91f4a5e2014-05-20 20:27:31 +010020LDFLAGS = $(shell $(dpkg_buildflags) --get LDFLAGS)
Simon Kelleyc72daea2012-01-05 21:33:27 +000021
Simon Kelley8f6213c2014-01-28 11:16:49 +000022DEB_COPTS = $(COPTS)
Simon Kelley97c83bb2012-05-28 18:21:59 +010023
Simon Kelleyc72daea2012-01-05 21:33:27 +000024TARGET = install-i18n
25
Simon Kelley6ac3bc02014-10-03 08:48:11 +010026DEB_HOST_ARCH_OS := $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
Simon Kelleyc6af3a32016-08-31 22:38:48 +010027DEB_HOST_GNU_TYPE := $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
28DEB_BUILD_GNU_TYPE := $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
Simon Kelley24e92072015-06-04 22:32:43 +010029BUILD_DATE := $(shell dpkg-parsechangelog --show-field Date)
Simon Kelleyc72daea2012-01-05 21:33:27 +000030
Simon Kelleyc6af3a32016-08-31 22:38:48 +010031ifeq ($(origin CC),default)
32 CC = $(DEB_HOST_GNU_TYPE)-gcc
33endif
34
35# Support non-cross-builds on systems without gnu-triplet-binaries for pkg-config.
36ifeq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
37 PKG_CONFIG=pkg-config
38else
39 PKG_CONFIG=$(DEB_HOST_GNU_TYPE)-pkg-config
40endif
41
Simon Kelley02ed24d2013-09-09 18:06:45 +010042# Force package version based on git tags.
43ifneq (,$(filter gitversion,$(DEB_BUILD_OPTIONS)))
Simon Kelley1d1c7952013-10-02 14:52:23 +010044 PACKAGE_VERSION = $(shell bld/get-version `pwd` | sed 's/test/~&/; s/[a-z]/~&/; s/-/./g; s/$$/-1/; s/^/-v/';)
Simon Kelley02ed24d2013-09-09 18:06:45 +010045endif
46
Simon Kelley62779782012-02-10 21:19:25 +000047ifeq (,$(filter nodbus,$(DEB_BUILD_OPTIONS)))
Simon Kelley8f6213c2014-01-28 11:16:49 +000048 DEB_COPTS += -DHAVE_DBUS
Simon Kelleyc72daea2012-01-05 21:33:27 +000049endif
50
Simon Kelley43cdf1c2017-05-21 22:12:44 +010051ifeq (,$(filter noidn, $(DEB_BUILD_OPTIONS)))
Simon Kelley5a913342019-08-23 22:31:30 +010052 DEB_COPTS += -DHAVE_LIBIDN2
Simon Kelley43cdf1c2017-05-21 22:12:44 +010053endif
54
Simon Kelley62779782012-02-10 21:19:25 +000055ifeq (,$(filter noconntrack,$(DEB_BUILD_OPTIONS)))
Simon Kelley6ac3bc02014-10-03 08:48:11 +010056ifeq ($(DEB_HOST_ARCH_OS),linux)
Simon Kelley8f6213c2014-01-28 11:16:49 +000057 DEB_COPTS += -DHAVE_CONNTRACK
Simon Kelleyc72daea2012-01-05 21:33:27 +000058endif
59endif
60
Simon Kelley3ddad242013-03-21 17:56:06 +000061ifneq (,$(filter noipset,$(DEB_BUILD_OPTIONS)))
Simon Kelley8f6213c2014-01-28 11:16:49 +000062 DEB_COPTS += -DNO_IPSET
Simon Kelley3b323bd2013-02-22 21:55:29 +000063endif
64
Simon Kelley96c38792012-02-16 20:07:17 +000065ifneq (,$(filter nodhcp6,$(DEB_BUILD_OPTIONS)))
Simon Kelley8f6213c2014-01-28 11:16:49 +000066 DEB_COPTS += -DNO_DHCP6
Simon Kelley127ea402012-02-11 22:14:52 +000067endif
68
Simon Kelley62779782012-02-10 21:19:25 +000069ifneq (,$(filter noipv6,$(DEB_BUILD_OPTIONS)))
Simon Kelley8f6213c2014-01-28 11:16:49 +000070 DEB_COPTS += -DNO_IPV6
Simon Kelleyc72daea2012-01-05 21:33:27 +000071endif
72
Simon Kelley62779782012-02-10 21:19:25 +000073ifneq (,$(filter notftp,$(DEB_BUILD_OPTIONS)))
Simon Kelley8f6213c2014-01-28 11:16:49 +000074 DEB_COPTS += -DNO_TFTP
Simon Kelleyc72daea2012-01-05 21:33:27 +000075endif
76
Simon Kelley62779782012-02-10 21:19:25 +000077ifneq (,$(filter nodhcp,$(DEB_BUILD_OPTIONS)))
Simon Kelley8f6213c2014-01-28 11:16:49 +000078 DEB_COPTS += -DNO_DHCP
Simon Kelleyc72daea2012-01-05 21:33:27 +000079endif
80
Simon Kelley62779782012-02-10 21:19:25 +000081ifneq (,$(filter noscript,$(DEB_BUILD_OPTIONS)))
Simon Kelley8f6213c2014-01-28 11:16:49 +000082 DEB_COPTS += -DNO_SCRIPT
Simon Kelleyc72daea2012-01-05 21:33:27 +000083endif
84
Simon Kelley62779782012-02-10 21:19:25 +000085ifneq (,$(filter nortc,$(DEB_BUILD_OPTIONS)))
Simon Kelley8f6213c2014-01-28 11:16:49 +000086 DEB_COPTS += -DHAVE_BROKEN_RTC
Simon Kelleyc72daea2012-01-05 21:33:27 +000087endif
88
Simon Kelley62779782012-02-10 21:19:25 +000089ifneq (,$(filter noi18n,$(DEB_BUILD_OPTIONS)))
Simon Kelleyc72daea2012-01-05 21:33:27 +000090 TARGET = install
Simon Kelleyc72daea2012-01-05 21:33:27 +000091endif
92
Simon Kelley62779782012-02-10 21:19:25 +000093ifneq (,$(filter uselua,$(DEB_BUILD_OPTIONS)))
Simon Kelley8f6213c2014-01-28 11:16:49 +000094 DEB_COPTS += -DHAVE_LUASCRIPT
Simon Kelley62779782012-02-10 21:19:25 +000095endif
96
Simon Kelley160f6502014-02-04 16:49:41 +000097ifeq (,$(filter nodnssec,$(DEB_BUILD_OPTIONS)))
Simon Kelley8f6213c2014-01-28 11:16:49 +000098 DEB_COPTS += -DHAVE_DNSSEC
Simon Kelley00ec6932014-01-28 11:08:57 +000099endif
100
Simon Kelley00fe2f42020-04-19 21:59:13 +0100101ifeq ($(DEB_HOST_ARCH_OS),kfreebsd)
Simon Kelley6ac3bc02014-10-03 08:48:11 +0100102 # For strlcpy in FreeBSD
Simon Kelley00fe2f42020-04-19 21:59:13 +0100103 LIBS += $(shell ${PKG_CONFIG} --libs libbsd-overlay)
104 CFLAGS += $(shell ${PKG_CONFIG} --cflags libbsd-overlay)
Simon Kelley6ac3bc02014-10-03 08:48:11 +0100105endif
106
Simon Kelley30e4a942018-02-16 19:56:56 +0000107define build_tree
108 rm -rf $1
Simon Kelleyc72daea2012-01-05 21:33:27 +0000109 install -m 755 \
Simon Kelley30e4a942018-02-16 19:56:56 +0000110 -d $1/DEBIAN \
111 -d $1/etc/dbus-1/system.d \
112 -d $1/usr/share/doc/$(package) \
113 -d $1/usr/share/doc/$(package)/examples \
114 -d $1/usr/share/$(package) \
115 -d $1/var/lib/misc
Simon Kelleyc72daea2012-01-05 21:33:27 +0000116
Simon Kelley30e4a942018-02-16 19:56:56 +0000117endef
118
119define add_docs
Simon Kelley933878f2014-09-09 14:28:01 +0100120# Need to remove paypal links in Debian Package for policy reasons.
Simon Kelley30e4a942018-02-16 19:56:56 +0000121 sed -e /\<H2\>Donations/Q -e /icon.png/d doc.html -e /favicon.ico/d >$1/usr/share/doc/$(package)/doc.html
122 echo "</BODY>" >>$1/usr/share/doc/$(package)/doc.html
123 install -m 644 setup.html $1/usr/share/doc/$(package)/.
124 install -m 644 dnsmasq.conf.example $1/usr/share/doc/$(package)/examples/.
125 install -m 644 FAQ $1/usr/share/doc/$(package)/.
126 gzip -9n $1/usr/share/doc/$(package)/FAQ
127 install -m 644 CHANGELOG $1/usr/share/doc/$(package)/changelog
128 gzip -9n $1/usr/share/doc/$(package)/changelog
129 install -m 644 CHANGELOG.archive $1/usr/share/doc/$(package)/changelog.archive
130 gzip -9n $1/usr/share/doc/$(package)/changelog.archive
131 install -m 644 dbus/DBus-interface $1/usr/share/doc/$(package)/.
132 gzip -9n $1/usr/share/doc/$(package)/DBus-interface
Simon Kelley343b7b42019-04-08 16:50:13 +0100133 install -m 644 debian/systemd_howto $1/usr/share/doc/$(package)/.
134 gzip -9n $1/usr/share/doc/$(package)/systemd_howto
Simon Kelley30e4a942018-02-16 19:56:56 +0000135 gzip -9n $1/usr/share/man/man8/dnsmasq.8
136 for f in $1/usr/share/man/*; do \
Simon Kelleyc72daea2012-01-05 21:33:27 +0000137 if [ -f $$f/man8/dnsmasq.8 ]; then \
Chris Lambb467a452015-02-09 11:52:30 +0000138 gzip -9n $$f/man8/dnsmasq.8 ; \
Simon Kelleyc72daea2012-01-05 21:33:27 +0000139 fi \
140 done
Simon Kelley30e4a942018-02-16 19:56:56 +0000141endef
142
143define add_files
144 install -m 644 trust-anchors.conf $1/usr/share/$(package)/.
145 install -m 644 debian/dnsmasq-base.conffiles $1/DEBIAN/conffiles
146 install -m 755 debian/dnsmasq-base.postinst $1/DEBIAN/postinst
147 install -m 755 debian/dnsmasq-base.postrm $1/DEBIAN/postrm
148 install -m 644 debian/changelog $1/usr/share/doc/$(package)/changelog.Debian
149 gzip -9n $1/usr/share/doc/$(package)/changelog.Debian
150 install -m 644 debian/readme $1/usr/share/doc/$(package)/README.Debian
151 install -m 644 debian/copyright $1/usr/share/doc/$(package)/copyright
152 install -m 644 debian/dbus.conf $1/etc/dbus-1/system.d/dnsmasq.conf
153endef
154
155clean:
156 $(checkdir)
157 make BUILDDIR=debian/build/no-lua clean
158 make BUILDDIR=debian/build/lua clean
159 make -C contrib/lease-tools clean
160 rm -rf debian/build debian/trees debian/*~ debian/files debian/substvars debian/utils-substvars
161
162binary-indep: checkroot
163 $(checkdir)
164 rm -rf debian/trees/daemon
165 install -m 755 \
166 -d debian/trees/daemon/DEBIAN \
Simon Kelley343b7b42019-04-08 16:50:13 +0100167 -d debian/trees/daemon/usr/share/doc/dnsmasq \
Simon Kelley30e4a942018-02-16 19:56:56 +0000168 -d debian/trees/daemon/etc/init.d \
169 -d debian/trees/daemon/etc/dnsmasq.d \
170 -d debian/trees/daemon/etc/resolvconf/update.d \
171 -d debian/trees/daemon/usr/lib/resolvconf/dpkg-event.d \
172 -d debian/trees/daemon/usr/share/dnsmasq \
Simon Kelleyec2067d2020-04-12 16:09:19 +0100173 -d debian/trees/daemon/usr/share/doc/dnsmasq \
Simon Kelley30e4a942018-02-16 19:56:56 +0000174 -d debian/trees/daemon/etc/default \
175 -d debian/trees/daemon/lib/systemd/system \
Simon Kelley118011f2018-09-17 23:15:37 +0100176 -d debian/trees/daemon/usr/lib/tmpfiles.d \
Simon Kelley30e4a942018-02-16 19:56:56 +0000177 -d debian/trees/daemon/etc/insserv.conf.d
178 install -m 644 debian/conffiles debian/trees/daemon/DEBIAN
179 install -m 755 debian/postinst debian/postrm debian/prerm debian/trees/daemon/DEBIAN
Simon Kelley837e8f42020-06-26 22:13:27 +0100180 if ! dpkg-vendor --derives-from Ubuntu; then \
181 rm -f debian/dnsmasq.postinst.debhelper debian/dnsmasq.postrm.debhelper; \
182 dh_runit -pdnsmasq -Pdebian/trees/daemon; \
183 cat debian/dnsmasq.postinst.debhelper >> debian/trees/daemon/DEBIAN/postinst; \
184 cat debian/dnsmasq.postrm.debhelper >> debian/trees/daemon/DEBIAN/postrm; \
185 cd debian/trees/daemon && find etc/sv -type f -printf '/%p\n' >>DEBIAN/conffiles; \
186 fi
Simon Kelley30e4a942018-02-16 19:56:56 +0000187 install -m 755 debian/init debian/trees/daemon/etc/init.d/dnsmasq
188 install -m 755 debian/resolvconf debian/trees/daemon/etc/resolvconf/update.d/dnsmasq
189 install -m 755 debian/resolvconf-package debian/trees/daemon/usr/lib/resolvconf/dpkg-event.d/dnsmasq
190 install -m 644 debian/installed-marker debian/trees/daemon/usr/share/dnsmasq
191 install -m 644 debian/default debian/trees/daemon/etc/default/dnsmasq
192 install -m 644 dnsmasq.conf.example debian/trees/daemon/etc/dnsmasq.conf
193 install -m 644 debian/readme.dnsmasq.d debian/trees/daemon/etc/dnsmasq.d/README
194 install -m 644 debian/systemd.service debian/trees/daemon/lib/systemd/system/dnsmasq.service
Simon Kelley343b7b42019-04-08 16:50:13 +0100195 install -m 644 debian/systemd@.service debian/trees/daemon/lib/systemd/system/dnsmasq@.service
Simon Kelley118011f2018-09-17 23:15:37 +0100196 install -m 644 debian/tmpfiles.conf debian/trees/daemon/usr/lib/tmpfiles.d/dnsmasq.conf
Simon Kelley30e4a942018-02-16 19:56:56 +0000197 install -m 644 debian/insserv debian/trees/daemon/etc/insserv.conf.d/dnsmasq
Simon Kelleyec2067d2020-04-12 16:09:19 +0100198 install -m 644 debian/copyright debian/trees/daemon/usr/share/doc/dnsmasq/copyright
199 install -m 644 debian/changelog debian/trees/daemon/usr/share/doc/dnsmasq/changelog.Debian
200 gzip -9n debian/trees/daemon/usr/share/doc/dnsmasq/changelog.Debian
Simon Kelley30e4a942018-02-16 19:56:56 +0000201 cd debian/trees/daemon && find . -type f ! -regex '.*DEBIAN/.*' -printf '%P\0' | LC_ALL=C sort -z | xargs -r0 md5sum > DEBIAN/md5sums
Simon Kelley92025a42020-02-29 22:56:38 +0000202 dpkg-gencontrol $(PACKAGE_VERSION) -Tdebian/dnsmasq.substvars -pdnsmasq -Pdebian/trees/daemon
Simon Kelley30e4a942018-02-16 19:56:56 +0000203 find debian/trees/daemon -depth -newermt '$(BUILD_DATE)' -print0 | xargs -0r touch --no-dereference --date='$(BUILD_DATE)'
204 chown -R root.root debian/trees/daemon
205 chmod -R g-ws debian/trees/daemon
206 dpkg --build debian/trees/daemon ..
207
208binary-arch: checkroot
209 $(call build_tree,debian/trees/base)
Simon Kelley00fe2f42020-04-19 21:59:13 +0100210 make $(TARGET) BUILDDIR=debian/build/no-lua PREFIX=/usr DESTDIR=`pwd`/debian/trees/base CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" COPTS="$(DEB_COPTS)" CC=$(CC) PKG_CONFIG=$(PKG_CONFIG) LIBS="$(LIBS)"
Simon Kelley5d514f22019-03-01 16:52:02 +0000211ifeq (,$(findstring nodoc,$(DEB_BUILD_OPTIONS)))
Simon Kelley30e4a942018-02-16 19:56:56 +0000212 $(call add_docs,debian/trees/base)
213else
214 rm -rf debian/trees/base/usr/share/man
Simon Kelleyc72daea2012-01-05 21:33:27 +0000215endif
Simon Kelley30e4a942018-02-16 19:56:56 +0000216 $(call add_files,debian/trees/base)
217ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
218 $(DEB_HOST_GNU_TYPE)-strip -R .note -R .comment debian/trees/base/usr/sbin/dnsmasq
219endif
220 cd debian/trees/base && find . -type f ! -regex '.*DEBIAN/.*' -printf '%P\0' | LC_ALL=C sort -z | xargs -r0 md5sum > DEBIAN/md5sums
221 dpkg-shlibdeps --warnings=1 debian/trees/base/usr/sbin/dnsmasq
222 dpkg-gencontrol $(PACKAGE_VERSION) -pdnsmasq-base -Pdebian/trees/base
223 find debian/trees/base -depth -newermt '$(BUILD_DATE)' -print0 | xargs -0r touch --no-dereference --date='$(BUILD_DATE)'
224 chown -R root.root debian/trees/base
225 chmod -R g-ws debian/trees/base
226 dpkg --build debian/trees/base ..
227
228 $(call build_tree,debian/trees/lua-base)
Simon Kelley00fe2f42020-04-19 21:59:13 +0100229 make $(TARGET) BUILDDIR=debian/build/lua PREFIX=/usr DESTDIR=`pwd`/debian/trees/lua-base CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" COPTS="-DHAVE_LUASCRIPT $(DEB_COPTS)" CC=$(CC) PKG_CONFIG=$(PKG_CONFIG) LIBS="$(LIBS)"
Simon Kelley5d514f22019-03-01 16:52:02 +0000230ifeq (,$(findstring nodoc,$(DEB_BUILD_OPTIONS)))
Simon Kelley30e4a942018-02-16 19:56:56 +0000231 $(call add_docs,debian/trees/lua-base)
232else
233 rm -rf debian/trees/lua-base/usr/share/man
234endif
235 $(call add_files,debian/trees/lua-base)
Simon Kelley9a7be472018-03-23 20:43:53 +0000236 install -m 755 -d debian/trees/lua-base/usr/share/lintian/overrides
237 install -m 644 debian/lintian-override debian/trees/lua-base/usr/share/lintian/overrides/dnsmasq-base-lua
Simon Kelley30e4a942018-02-16 19:56:56 +0000238ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
239 $(DEB_HOST_GNU_TYPE)-strip -R .note -R .comment debian/trees/lua-base/usr/sbin/dnsmasq
240endif
Simon Kelley26e27d02018-03-18 17:29:12 +0000241 ln -s $(package) debian/trees/lua-base/usr/share/doc/dnsmasq-base-lua
Simon Kelley30e4a942018-02-16 19:56:56 +0000242 cd debian/trees/lua-base && find . -type f ! -regex '.*DEBIAN/.*' -printf '%P\0' | LC_ALL=C sort -z | xargs -r0 md5sum > DEBIAN/md5sums
243 dpkg-shlibdeps --warnings=1 debian/trees/lua-base/usr/sbin/dnsmasq
244 dpkg-gencontrol $(PACKAGE_VERSION) -pdnsmasq-base-lua -Pdebian/trees/lua-base
245 find debian/trees/lua-base -depth -newermt '$(BUILD_DATE)' -print0 | xargs -0r touch --no-dereference --date='$(BUILD_DATE)'
246 chown -R root.root debian/trees/lua-base
247 chmod -R g-ws debian/trees/lua-base
248 dpkg --build debian/trees/lua-base ..
249
Simon Kelleyc72daea2012-01-05 21:33:27 +0000250
Simon Kelley6ac3bc02014-10-03 08:48:11 +0100251ifeq ($(DEB_HOST_ARCH_OS),linux)
Simon Kelley30e4a942018-02-16 19:56:56 +0000252 rm -rf debian/trees/utils
253 install -m 755 -d debian/trees/utils/DEBIAN \
254 -d debian/trees/utils/usr/bin \
255 -d debian/trees/utils/usr/share/doc/dnsmasq-utils
Simon Kelley5d514f22019-03-01 16:52:02 +0000256ifeq (,$(findstring nodoc,$(DEB_BUILD_OPTIONS)))
Simon Kelley30e4a942018-02-16 19:56:56 +0000257 install -m 755 -d debian/trees/utils/usr/share/man/man1
258endif
Simon Kelley00fe2f42020-04-19 21:59:13 +0100259 make -C contrib/lease-tools PREFIX=/usr DESTDIR=`pwd`/debian/trees/utils CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" COPTS="$(DEB_COPTS)" CC=$(CC) PKG_CONFIG=$(PKG_CONFIG) LIBS="$(LIBS)"
Simon Kelley30e4a942018-02-16 19:56:56 +0000260 install -m 755 contrib/lease-tools/dhcp_release debian/trees/utils/usr/bin/dhcp_release
261 install -m 755 contrib/lease-tools/dhcp_release6 debian/trees/utils/usr/bin/dhcp_release6
262 install -m 755 contrib/lease-tools/dhcp_lease_time debian/trees/utils/usr/bin/dhcp_lease_time
Simon Kelley5d514f22019-03-01 16:52:02 +0000263ifeq (,$(findstring nodoc,$(DEB_BUILD_OPTIONS)))
Simon Kelley30e4a942018-02-16 19:56:56 +0000264 install -m 644 contrib/lease-tools/dhcp_release.1 debian/trees/utils/usr/share/man/man1/dhcp_release.1
265 gzip -9n debian/trees/utils/usr/share/man/man1/dhcp_release.1
266 install -m 644 contrib/lease-tools/dhcp_release6.1 debian/trees/utils/usr/share/man/man1/dhcp_release6.1
267 gzip -9n debian/trees/utils/usr/share/man/man1/dhcp_release6.1
268 install -m 644 contrib/lease-tools/dhcp_lease_time.1 debian/trees/utils/usr/share/man/man1/dhcp_lease_time.1
269 gzip -9n debian/trees/utils/usr/share/man/man1/dhcp_lease_time.1
270endif
271 install -m 644 debian/copyright debian/trees/utils/usr/share/doc/dnsmasq-utils/copyright
272 install -m 644 debian/changelog debian/trees/utils/usr/share/doc/dnsmasq-utils/changelog.Debian
273 gzip -9n debian/trees/utils/usr/share/doc/dnsmasq-utils/changelog.Debian
Simon Kelleyc72daea2012-01-05 21:33:27 +0000274ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
Simon Kelley30e4a942018-02-16 19:56:56 +0000275 $(DEB_HOST_GNU_TYPE)-strip -R .note -R .comment debian/trees/utils/usr/bin/dhcp_release
276 $(DEB_HOST_GNU_TYPE)-strip -R .note -R .comment debian/trees/utils/usr/bin/dhcp_release6
277 $(DEB_HOST_GNU_TYPE)-strip -R .note -R .comment debian/trees/utils/usr/bin/dhcp_lease_time
Simon Kelleyc72daea2012-01-05 21:33:27 +0000278endif
Simon Kelley30e4a942018-02-16 19:56:56 +0000279 cd debian/trees/utils && find . -type f ! -regex '.*DEBIAN/.*' -printf '%P\0' | LC_ALL=C sort -z | xargs -r0 md5sum > DEBIAN/md5sums
280 dpkg-shlibdeps -Tdebian/utils-substvars debian/trees/utils/usr/bin/dhcp_release debian/trees/utils/usr/bin/dhcp_release6 debian/trees/utils/usr/bin/dhcp_lease_time
281 dpkg-gencontrol $(PACKAGE_VERSION) -Tdebian/utils-substvars -pdnsmasq-utils -Pdebian/trees/utils
282 find debian/trees/utils -depth -newermt '$(BUILD_DATE)' -print0 | xargs -0r touch --no-dereference --date='$(BUILD_DATE)'
283 chown -R root.root debian/trees/utils
284 chmod -R g-ws debian/trees/utils
285 dpkg --build debian/trees/utils ..
Simon Kelleyc72daea2012-01-05 21:33:27 +0000286endif
287
288define checkdir
289 test -f Makefile -a -f debian/rules
290endef
291
292# Below here is fairly generic really
293
294binary: binary-arch binary-indep
Simon Kelley760169f2012-03-09 14:27:49 +0000295
Simon Kelleyc72daea2012-01-05 21:33:27 +0000296build:
Simon Kelley760169f2012-03-09 14:27:49 +0000297build-arch:
298build-indep:
Simon Kelleyc72daea2012-01-05 21:33:27 +0000299
300checkroot:
301 test root = "`whoami`"
302
303.PHONY: binary binary-arch binary-indep clean checkroot
304
305