Simon Kelley | 9e03894 | 2008-05-30 20:06:34 +0100 | [diff] [blame] | 1 | From: David Connelly <dconnelly@gmail.com> |
| 2 | Date: Mon, Apr 7, 2008 at 3:31 AM |
| 3 | Subject: Solaris 10 service manifest |
| 4 | To: dnsmasq-discuss@lists.thekelleys.org.uk |
| 5 | |
| 6 | |
| 7 | I've found dnsmasq much easier to set up on my home server running Solaris |
| 8 | 10 than the stock dhcp/dns server, which is probably overkill anyway for my |
| 9 | simple home network needs. Since Solaris now uses SMF (Service Management |
| 10 | Facility) to manage services I thought I'd create a simple service manifest |
| 11 | for the dnsmasq service. The manifest currently assumes that dnsmasq has |
| 12 | been installed in '/usr/local/sbin/dnsmasq' and the configuration file in |
| 13 | '/usr/local/etc/dnsmasq.conf', so you may have to adjust these paths for |
| 14 | your local installation. Here are the steps I followed to install and enable |
| 15 | the dnsmasq service: |
| 16 | # svccfg import dnsmasq.xml |
| 17 | # svcadm enable dnsmasq |
| 18 | |
| 19 | To confirm that the service is enabled and online: |
| 20 | |
| 21 | # svcs -l dnsmasq |
| 22 | |
| 23 | I've just started learning about SMF so if anyone has any |
| 24 | corrections/feedback they are more than welcome. |
| 25 | |
| 26 | Thanks, |
| 27 | David |
| 28 | |