Bump kubernetes to v1.18.5 97/5397/5
authorFatih Degirmenci <fatih.degirmenci@est.tech>
Mon, 13 Jul 2020 15:18:29 +0000 (15:18 +0000)
committerFatih Degirmenci <fatih.degirmenci@est.tech>
Wed, 15 Jul 2020 07:16:29 +0000 (07:16 +0000)
The container image, flannel_cni, is removed in upstream Kubespray
download role so we remove it as well.

Depends-On: Ie8be93ba62dc90229f54bd618c982aeaf4bdaafb
Change-Id: I7bc9f42fd5bb6a29d4dd16d9e56228dde58fd498

playbooks/roles/package/defaults/main.yaml
vars/kubernetes.yaml

index 136ae2b..b519494 100644 (file)
@@ -52,7 +52,6 @@ k8s_misc_images:
   - dnsautoscaler
   - etcd
   - flannel
-  - flannel_cni
   - helm
   - metrics_server
   - multus
index 75bd857..fed310c 100644 (file)
@@ -61,19 +61,17 @@ deploy_scenario: "{{ lookup('env', 'DEPLOY_SCENARIO') | default('k8-multus-plugi
 # -------------------------------------------------------------------------------
 # Nordix: Docker version
 # -------------------------------------------------------------------------------
-# NOTE (fdegir): versions of docker as of 13.02.2020 matching to what Kubespray uses
-# Please note that docker-ce version is configured to be overrideable since some scenarios
-# require different docker versions
-docker_ce_version: "{{ lookup('env', 'DOCKER_CE_VERSION') | default('5:18.09.9~3-0~ubuntu-bionic', true) }}"
+# NOTE (fdegir): versions of docker as of 13.07.2020 matching to what Kubespray requires
+docker_ce_version: "5:19.03.12~3-0~ubuntu-bionic"
 docker_ce_cli_version: "{{ docker_ce_version }}"
 docker_registry_version: "2.7.1"
-containerd_io_version: "1.2.6-3"
+containerd_io_version: "1.2.13-2"
 
 # -------------------------------------------------------------------------------
 # Kubernetes: Kubernetes and kubectl versions
 # -------------------------------------------------------------------------------
 # Kubernetes version that is supported by the pinned kubespray version
-kubernetes_version: "v1.17.0"
+kubernetes_version: "v1.18.5"
 # version of the kubectl should generally match to the version of kubernetes itself
 # but it would be good to have possibility to override it in case if someone needs it for some reason
 kubectl_version: "{{ kubernetes_version }}"