| #!/usr/bin/make -f |
| |
| export DH_VERBOSE=1 |
| export DH_COMPAT=3 |
| |
| ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS))) |
| CFLAGS += -g |
| endif |
| ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS))) |
| INSTALL_PROGRAM += -s |
| endif |
| |
| binary-indep: |
| |
| busybox-deb: |
| dh_testdir |
| dh_testroot |
| $(MAKE) clean |
| cp ./debian/config-deb .config |
| $(MAKE) dep |
| $(MAKE) |
| install -D busybox ./debian/busybox/bin/busybox |
| dh_installchangelogs Changelog -pbusybox |
| dh_strip -pbusybox |
| dh_compress -pbusybox |
| dh_fixperms -pbusybox |
| dh_installdeb -pbusybox |
| dh_shlibdeps -pbusybox |
| dh_gencontrol -pbusybox |
| dh_md5sums -pbusybox |
| dh_builddeb -pbusybox |
| |
| busybox-udeb: |
| dh_testdir |
| dh_testroot |
| $(MAKE) clean |
| cp ./debian/config-udeb .config |
| $(MAKE) dep |
| $(MAKE) |
| install -D busybox ./debian/busybox-udeb/bin/busybox |
| dh_installchangelogs Changelog -pbusybox-udeb |
| dh_strip -pbusybox-udeb |
| dh_compress -pbusybox-udeb |
| dh_fixperms -pbusybox-udeb |
| dh_installdeb -pbusybox-udeb |
| dh_shlibdeps -pbusybox-udeb |
| dh_gencontrol -pbusybox-udeb |
| dh_md5sums -pbusybox-udeb |
| dh_builddeb -pbusybox-udeb |
| |
| |
| busybox-static: |
| dh_testdir |
| dh_testroot |
| $(MAKE) clean |
| cp ./debian/config-static .config |
| $(MAKE) dep |
| $(MAKE) |
| install -D busybox ./debian/busybox-static/bin/busybox |
| dh_installchangelogs Changelog -pbusybox-static |
| dh_strip -pbusybox-static |
| dh_compress -pbusybox-static |
| dh_fixperms -pbusybox-static |
| dh_installdeb -pbusybox-static |
| dh_shlibdeps -pbusybox-static |
| dh_gencontrol -pbusybox-static |
| dh_md5sums -pbusybox-static |
| dh_builddeb -pbusybox-static |
| |
| binary-arch: busybox-deb busybox-udeb busybox-static |
| |
| binary: binary-indep binary-arch |
| .PHONY: build clean binary-indep binary-arch binary install configure |