blob: f44cdc7a43a066186f1c7b3cd5f3cac0fc6087b9 [file] [log] [blame]
Eric Andersencc8ed391999-10-05 16:24:54 +00001Name: busybox
Eric Andersen2f6c04f1999-11-01 23:59:44 +00002Version: 0.32
Eric Andersencc8ed391999-10-05 16:24:54 +00003Release: 1
4Group: System/Utilities
5Summary: BusyBox is a tiny suite of Unix utilities in a multi-call binary.
6Copyright: GPL
7Packager : Erik Andersen <andersen@lineo.com>
8Conflicts: fileutils grep shellutils
9Buildroot: /tmp/%{Name}-%{Version}
Eric Andersen2f6c04f1999-11-01 23:59:44 +000010Source: busybox-0.32.tar.gz
Eric Andersencc8ed391999-10-05 16:24:54 +000011
12%Description
13BusyBox is a suite of "tiny" Unix utilities in a multi-call binary. It
Eric Andersena7093171999-10-23 05:42:08 +000014provides a pretty complete POSIX environment in a very small package.
15Just add a kernel, "ash" (Keith Almquists tiny Bourne shell clone), and
16an editor such as "elvis-tiny" or "ae", and you have a full system. This
17is makes an excellent environment for a "rescue" disk or any small or
18embedded system.
Eric Andersencc8ed391999-10-05 16:24:54 +000019
20%Prep
21%setup -q -n busybox
22
23%Build
24make
25
26%Install
27rm -rf $RPM_BUILD_ROOT
28mkdir -p $RPM_BUILD_ROOT/bin
29h=`cat busybox.links`
30
31for i in $h ; do
32 mkdir -p $RPM_BUILD_ROOT/`echo $i | sed -e 's/\(^.*\/\)\(.*\)/\1/g' `
33 (cd $RPM_BUILD_ROOT/bin ; ln -s ln `echo $i | sed -e 's/\(^.*\/\)\(.*\)/\2/g' ` );
34done
Eric Andersen219d6f51999-11-02 19:43:01 +000035rm -f $RPM_BUILD_ROOT/bin/busybox
36install -m 755 busybox $RPM_BUILD_ROOT/bin/busybox
Eric Andersencc8ed391999-10-05 16:24:54 +000037
38%Clean
39rm -rf $RPM_BUILD_ROOT
40
41%Files
42%defattr(-,root,root)
43/