Thomas F Herbert | 20a29c7 | 2016-10-13 18:36:50 -0400 | [diff] [blame] | 1 | %define _mu_build_dir %{_mu_build_root_dir} |
| 2 | %define _vpp_install_dir %{_install_dir} |
| 3 | %define _vpp_build_dir build-tool-native |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 4 | %define _unitdir /lib/systemd/system |
| 5 | %define _topdir %(pwd) |
| 6 | %define _builddir %{_topdir} |
| 7 | %define _version %(../scripts/version rpm-version) |
| 8 | %define _release %(../scripts/version rpm-release) |
| 9 | |
Ole Troan | 57c3d66 | 2016-09-12 22:00:32 +0200 | [diff] [blame] | 10 | # Failsafe backport of Python2-macros for RHEL <= 6 |
| 11 | %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")} |
| 12 | %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")} |
| 13 | %{!?python_version: %global python_version %(%{__python} -c "import sys; sys.stdout.write(sys.version[:3])")} |
| 14 | %{!?__python2: %global __python2 %{__python}} |
| 15 | %{!?python2_sitelib: %global python2_sitelib %{python_sitelib}} |
| 16 | %{!?python2_sitearch: %global python2_sitearch %{python_sitearch}} |
| 17 | %{!?python2_version: %global python2_version %{python_version}} |
| 18 | |
| 19 | %{!?python2_minor_version: %define python2_minor_version %(%{__python} -c "import sys ; print sys.version[2:3]")} |
| 20 | |
Peter Ginchev | dfa9c5b | 2016-10-11 15:34:24 +0300 | [diff] [blame] | 21 | %{?systemd_requires} |
| 22 | |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 23 | Name: vpp |
| 24 | Summary: Vector Packet Processing |
| 25 | License: MIT |
| 26 | Version: %{_version} |
| 27 | Release: %{_release} |
Padraig | b21b676 | 2016-09-21 14:59:02 +0100 | [diff] [blame] | 28 | Requires: vpp-lib = %{_version}-%{_release}, net-tools, pciutils, python |
Damjan Marion | a1bd023 | 2016-12-19 19:08:11 +0100 | [diff] [blame] | 29 | BuildRequires: systemd, chrpath |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 30 | |
Thomas F Herbert | 20a29c7 | 2016-10-13 18:36:50 -0400 | [diff] [blame] | 31 | Source: %{name}-%{_version}-%{_release}.tar.gz |
| 32 | |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 33 | %description |
Damjan Marion | 08ff7e0 | 2016-01-20 13:45:36 +0100 | [diff] [blame] | 34 | This package provides VPP executables: vpp, vpp_api_test, vpp_json_test |
| 35 | vpp - the vector packet engine |
| 36 | vpp_api_test - vector packet engine API test tool |
| 37 | vpp_json_test - vector packet engine JSON test tool |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 38 | |
| 39 | %package lib |
| 40 | Summary: VPP libraries |
| 41 | Group: System Environment/Libraries |
| 42 | |
| 43 | %description lib |
| 44 | This package contains the VPP shared libraries, including: |
| 45 | vppinfra - foundation library supporting vectors, hashes, bitmaps, pools, and string formatting. |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 46 | svm - vm library |
| 47 | vlib - vector processing library |
| 48 | vlib-api - binary API library |
| 49 | vnet - network stack library |
| 50 | |
| 51 | %package devel |
| 52 | Summary: VPP header files, static libraries |
| 53 | Group: Development/Libraries |
| 54 | Requires: vpp-lib |
| 55 | |
| 56 | %description devel |
Thomas F Herbert | 3977a21 | 2016-10-01 18:09:33 -0400 | [diff] [blame] | 57 | This package contains the header files for VPP. |
| 58 | Install this package if you want to write a |
| 59 | program for compilation and linking with vpp lib. |
| 60 | vlib |
| 61 | vlibmemory |
| 62 | vnet - devices, classify, dhcp, ethernet flow, gre, ip, etc. |
| 63 | vpp-api |
| 64 | vppinfra |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 65 | |
Ed Warnicke | f5a1436 | 2016-09-12 20:40:24 +0000 | [diff] [blame] | 66 | %package plugins |
| 67 | Summary: Vector Packet Processing--runtime plugins |
| 68 | Group: System Environment/Libraries |
| 69 | Requires: vpp = %{_version}-%{_release} |
| 70 | %description plugins |
| 71 | This package contains VPP plugins |
| 72 | |
Damjan Marion | cb034b9 | 2016-12-28 18:38:59 +0100 | [diff] [blame] | 73 | %package api-lua |
| 74 | Summary: VPP api lua bindings |
| 75 | Group: Development/Libraries |
| 76 | Requires: vpp = %{_version}-%{_release}, vpp-lib = %{_version}-%{_release} |
| 77 | |
| 78 | %description api-lua |
| 79 | This package contains the lua bindings for the vpp api |
| 80 | |
| 81 | %package api-java |
| 82 | Summary: VPP api java bindings |
| 83 | Group: Development/Libraries |
| 84 | Requires: vpp = %{_version}-%{_release}, vpp-lib = %{_version}-%{_release} |
| 85 | |
| 86 | %description api-java |
| 87 | This package contains the java bindings for the vpp api |
| 88 | |
| 89 | %package api-python |
Ole Troan | 57c3d66 | 2016-09-12 22:00:32 +0200 | [diff] [blame] | 90 | Summary: VPP api python bindings |
| 91 | Group: Development/Libraries |
Gabriel Ganne | 3290566 | 2016-12-06 19:12:49 +0100 | [diff] [blame] | 92 | Requires: vpp = %{_version}-%{_release}, vpp-lib = %{_version}-%{_release}, python-setuptools |
Ole Troan | 57c3d66 | 2016-09-12 22:00:32 +0200 | [diff] [blame] | 93 | |
Damjan Marion | cb034b9 | 2016-12-28 18:38:59 +0100 | [diff] [blame] | 94 | %description api-python |
Ole Troan | 57c3d66 | 2016-09-12 22:00:32 +0200 | [diff] [blame] | 95 | This package contains the python bindings for the vpp api |
| 96 | |
Thomas F Herbert | 20a29c7 | 2016-10-13 18:36:50 -0400 | [diff] [blame] | 97 | %prep |
| 98 | %setup -q -n %{name}-%{_version} |
| 99 | |
Ed Warnicke | ec6290a | 2016-06-08 17:15:08 -0500 | [diff] [blame] | 100 | %pre |
| 101 | # Add the vpp group |
Ed Warnicke | b10427e | 2016-06-08 19:49:40 -0500 | [diff] [blame] | 102 | groupadd -f -r vpp |
Ed Warnicke | ec6290a | 2016-06-08 17:15:08 -0500 | [diff] [blame] | 103 | |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 104 | %install |
| 105 | # |
| 106 | # binaries |
| 107 | # |
| 108 | mkdir -p -m755 %{buildroot}%{_bindir} |
| 109 | mkdir -p -m755 %{buildroot}%{_unitdir} |
Gabriel Ganne | 714968b | 2017-01-26 15:42:39 +0100 | [diff] [blame] | 110 | install -p -m 755 %{_mu_build_dir}/%{_vpp_install_dir}/vpp/bin/* %{buildroot}%{_bindir} |
Ole Troan | f14e3bf | 2016-12-01 21:49:03 +0100 | [diff] [blame] | 111 | |
Damjan Marion | 7cd468a | 2016-12-19 23:05:39 +0100 | [diff] [blame] | 112 | # api |
Ole Troan | f14e3bf | 2016-12-01 21:49:03 +0100 | [diff] [blame] | 113 | mkdir -p -m755 %{buildroot}/usr/share/vpp/api |
Ole Troan | f14e3bf | 2016-12-01 21:49:03 +0100 | [diff] [blame] | 114 | |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 115 | # |
| 116 | # configs |
| 117 | # |
| 118 | mkdir -p -m755 %{buildroot}/etc/vpp |
Miroslav Miklus | 8e08e74 | 2016-10-11 13:35:26 +0200 | [diff] [blame] | 119 | mkdir -p -m755 %{buildroot}/etc/sysctl.d |
Thomas F Herbert | 20a29c7 | 2016-10-13 18:36:50 -0400 | [diff] [blame] | 120 | install -p -m 644 %{_mu_build_dir}/rpm/vpp.service %{buildroot}%{_unitdir} |
Damjan Marion | d0f673e | 2017-01-31 17:29:33 +0100 | [diff] [blame] | 121 | install -p -m 644 %{_mu_build_dir}/../src/vpp/conf/startup.conf %{buildroot}/etc/vpp/startup.conf |
Damjan Marion | 7cd468a | 2016-12-19 23:05:39 +0100 | [diff] [blame] | 122 | install -p -m 644 %{_mu_build_dir}/../src/vpp/conf/80-vpp.conf %{buildroot}/etc/sysctl.d |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 123 | # |
| 124 | # libraries |
| 125 | # |
| 126 | mkdir -p -m755 %{buildroot}%{_libdir} |
Padraig Connolly | 69915cb | 2017-01-10 17:10:39 +0000 | [diff] [blame] | 127 | mkdir -p -m755 %{buildroot}/etc/bash_completion.d |
| 128 | mkdir -p -m755 %{buildroot}/usr/share/vpp |
Thomas F Herbert | 20a29c7 | 2016-10-13 18:36:50 -0400 | [diff] [blame] | 129 | for file in $(find %{_mu_build_dir}/%{_vpp_install_dir}/*/lib* -type f -name '*.so.*.*.*' -print ) |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 130 | do |
| 131 | install -p -m 755 $file %{buildroot}%{_libdir} |
| 132 | done |
| 133 | for file in $(cd %{buildroot}%{_libdir} && find . -type f -print | sed -e 's/^\.\///') |
| 134 | do |
| 135 | # make lib symlinks |
| 136 | ( cd %{buildroot}%{_libdir} && |
| 137 | ln -fs $file $(echo $file | sed -e 's/\(\.so\.[0-9]\+\).*/\1/') ) |
Ed Warnicke | f5a0e73 | 2016-09-07 17:12:52 +0000 | [diff] [blame] | 138 | ( cd %{buildroot}%{_libdir} && |
| 139 | ln -fs $file $(echo $file | sed -e 's/\(\.so\)\.[0-9]\+.*/\1/') ) |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 140 | done |
Damjan Marion | 7cd468a | 2016-12-19 23:05:39 +0100 | [diff] [blame] | 141 | for file in $(find %{_mu_build_dir}/%{_vpp_install_dir}/vpp/share/vpp/api -type f -name '*.api.json' -print ) |
Ole Troan | f14e3bf | 2016-12-01 21:49:03 +0100 | [diff] [blame] | 142 | do |
| 143 | install -p -m 644 $file %{buildroot}/usr/share/vpp/api |
| 144 | done |
Padraig Connolly | 69915cb | 2017-01-10 17:10:39 +0000 | [diff] [blame] | 145 | install -p -m 644 %{_mu_build_dir}/../src/scripts/vppctl_completion %{buildroot}/etc/bash_completion.d |
| 146 | install -p -m 644 %{_mu_build_dir}/../src/scripts/vppctl-cmd-list %{buildroot}/usr/share/vpp |
Ed Warnicke | 406ab9d | 2016-08-31 18:48:47 -0700 | [diff] [blame] | 147 | |
Damjan Marion | cb034b9 | 2016-12-28 18:38:59 +0100 | [diff] [blame] | 148 | # Lua bindings |
| 149 | mkdir -p -m755 %{buildroot}/usr/share/doc/vpp/examples/lua/examples/cli |
| 150 | mkdir -p -m755 %{buildroot}/usr/share/doc/vpp/examples/lua/examples/lute |
| 151 | for file in $(cd %{_mu_build_dir}/%{_vpp_install_dir}/../../src/vpp-api/lua && git ls-files .) |
| 152 | do |
| 153 | install -p -m 644 %{_mu_build_dir}/%{_vpp_install_dir}/../../src/vpp-api/lua/$file \ |
| 154 | %{buildroot}/usr/share/doc/vpp/examples/lua/$file |
| 155 | done |
| 156 | |
| 157 | # Java bindings |
| 158 | mkdir -p -m755 %{buildroot}/usr/share/java |
| 159 | for file in $(find %{_mu_build_dir}/%{_vpp_install_dir}/vpp/share/java -type f -name '*.jar' -print ) |
| 160 | do |
| 161 | install -p -m 644 $file %{buildroot}/usr/share/java |
| 162 | done |
| 163 | |
Ole Troan | 57c3d66 | 2016-09-12 22:00:32 +0200 | [diff] [blame] | 164 | # Python bindings |
Gabriel Ganne | 3290566 | 2016-12-06 19:12:49 +0100 | [diff] [blame] | 165 | mkdir -p -m755 %{buildroot}%{python2_sitelib} |
| 166 | install -p -m 666 %{_mu_build_dir}/%{_vpp_install_dir}/*/lib/python2.7/site-packages/vpp_papi-*.egg %{buildroot}%{python2_sitelib} |
Ole Troan | 57c3d66 | 2016-09-12 22:00:32 +0200 | [diff] [blame] | 167 | |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 168 | # |
| 169 | # devel |
| 170 | # |
Thomas F Herbert | 20a29c7 | 2016-10-13 18:36:50 -0400 | [diff] [blame] | 171 | for dir in $(find %{_mu_build_dir}/%{_vpp_install_dir}/*/include/ -maxdepth 0 -type d -print | grep -v dpdk) |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 172 | do |
| 173 | for subdir in $(cd ${dir} && find . -type d -print) |
| 174 | do |
| 175 | mkdir -p -m755 %{buildroot}/usr/include/${subdir} |
| 176 | done |
| 177 | for file in $(cd ${dir} && find . -type f -print) |
| 178 | do |
| 179 | install -p -m 644 $dir/$file %{buildroot}%{_includedir}/$file |
| 180 | done |
| 181 | done |
Ed Warnicke | 406ab9d | 2016-08-31 18:48:47 -0700 | [diff] [blame] | 182 | |
| 183 | mkdir -p -m755 %{buildroot}%{python2_sitelib}/jvppgen |
Damjan Marion | cb034b9 | 2016-12-28 18:38:59 +0100 | [diff] [blame] | 184 | install -p -m755 %{_mu_build_dir}/../src/vpp-api/java/jvpp/gen/jvpp_gen.py %{buildroot}/usr/bin |
| 185 | for i in $(ls %{_mu_build_dir}/../src/vpp-api/java/jvpp/gen/jvppgen/*.py); do |
Ed Warnicke | 406ab9d | 2016-08-31 18:48:47 -0700 | [diff] [blame] | 186 | install -p -m666 ${i} %{buildroot}%{python2_sitelib}/jvppgen |
| 187 | done; |
| 188 | |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 189 | # sample plugin |
| 190 | mkdir -p -m755 %{buildroot}/usr/share/doc/vpp/examples/sample-plugin/sample |
Damjan Marion | cb034b9 | 2016-12-28 18:38:59 +0100 | [diff] [blame] | 191 | for file in $(cd %{_mu_build_dir}/%{_vpp_install_dir}/../../src/examples/sample-plugin && git ls-files .) |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 192 | do |
Damjan Marion | cb034b9 | 2016-12-28 18:38:59 +0100 | [diff] [blame] | 193 | install -p -m 644 %{_mu_build_dir}/%{_vpp_install_dir}/../../src/examples/sample-plugin/$file \ |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 194 | %{buildroot}/usr/share/doc/vpp/examples/sample-plugin/$file |
| 195 | done |
| 196 | |
Ed Warnicke | f5a1436 | 2016-09-12 20:40:24 +0000 | [diff] [blame] | 197 | |
| 198 | # |
| 199 | # vpp-plugins |
| 200 | # |
Ed Warnicke | e7637e7 | 2016-09-14 16:58:33 -0700 | [diff] [blame] | 201 | mkdir -p -m755 %{buildroot}/usr/lib/vpp_plugins |
| 202 | mkdir -p -m755 %{buildroot}/usr/lib/vpp_api_test_plugins |
Damjan Marion | 7cd468a | 2016-12-19 23:05:39 +0100 | [diff] [blame] | 203 | for file in $(cd %{_mu_build_dir}/%{_vpp_install_dir}/vpp/lib64/vpp_plugins && find -type f -print) |
| 204 | do |
| 205 | install -p -m 644 %{_mu_build_dir}/%{_vpp_install_dir}/vpp/lib64/vpp_plugins/$file \ |
| 206 | %{buildroot}/usr/lib/vpp_plugins/$file |
| 207 | done |
| 208 | |
Damjan Marion | 7cd468a | 2016-12-19 23:05:39 +0100 | [diff] [blame] | 209 | for file in $(cd %{_mu_build_dir}/%{_vpp_install_dir}/vpp/lib64/vpp_api_test_plugins && find -type f -print) |
| 210 | do |
| 211 | install -p -m 644 %{_mu_build_dir}/%{_vpp_install_dir}/vpp/lib64/vpp_api_test_plugins/$file \ |
| 212 | %{buildroot}/usr/lib/vpp_api_test_plugins/$file |
| 213 | done |
| 214 | |
Ole Troan | f14e3bf | 2016-12-01 21:49:03 +0100 | [diff] [blame] | 215 | for file in $(find %{_mu_build_dir}/%{_vpp_install_dir}/plugins -type f -name '*.api.json' -print ) |
| 216 | do |
| 217 | install -p -m 644 $file %{buildroot}/usr/share/vpp/api |
| 218 | done |
| 219 | |
Damjan Marion | a1bd023 | 2016-12-19 19:08:11 +0100 | [diff] [blame] | 220 | # |
| 221 | # remove RPATH from ELF binaries |
| 222 | # |
| 223 | %{_mu_build_dir}/scripts/remove-rpath %{buildroot} |
| 224 | |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 225 | %post |
| 226 | sysctl --system |
| 227 | %systemd_post vpp.service |
| 228 | |
Damjan Marion | cb034b9 | 2016-12-28 18:38:59 +0100 | [diff] [blame] | 229 | %post api-python |
Gabriel Ganne | 3290566 | 2016-12-06 19:12:49 +0100 | [diff] [blame] | 230 | easy_install -z %{python2_sitelib}/vpp_papi-*.egg |
| 231 | |
Peter Ginchev | dfa9c5b | 2016-10-11 15:34:24 +0300 | [diff] [blame] | 232 | %preun |
| 233 | %systemd_preun vpp.service |
| 234 | |
Damjan Marion | cb034b9 | 2016-12-28 18:38:59 +0100 | [diff] [blame] | 235 | %preun api-python |
Gabriel Ganne | 3290566 | 2016-12-06 19:12:49 +0100 | [diff] [blame] | 236 | easy_install -mxNq vpp_papi |
| 237 | |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 238 | %postun |
Peter Ginchev | dfa9c5b | 2016-10-11 15:34:24 +0300 | [diff] [blame] | 239 | %systemd_postun |
| 240 | |
| 241 | # Unbind user-mode PCI drivers |
| 242 | removed= |
| 243 | pci_dirs=`find /sys/bus/pci/drivers -type d -name igb_uio -o -name uio_pci_generic -o -name vfio-pci` |
| 244 | for d in $pci_dirs; do |
| 245 | for f in ${d}/*; do |
| 246 | [ -e "${f}/config" ] || continue |
Radu Nicolau | 02767e9 | 2017-02-23 14:28:49 +0000 | [diff] [blame^] | 247 | echo ${f##*/} > ${d}/unbind |
Peter Ginchev | dfa9c5b | 2016-10-11 15:34:24 +0300 | [diff] [blame] | 248 | basename `dirname ${f}` | xargs echo -n "Removing driver"; echo " for PCI ID" `basename ${f}` |
| 249 | removed=y |
| 250 | done |
| 251 | done |
| 252 | if [ -n "${removed}" ]; then |
| 253 | echo "There are changes in PCI drivers, rescaning" |
| 254 | echo 1 > /sys/bus/pci/rescan |
| 255 | else |
| 256 | echo "There weren't PCI devices binded" |
| 257 | fi |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 258 | |
| 259 | %files |
| 260 | %defattr(-,bin,bin) |
| 261 | %{_unitdir}/vpp.service |
Damjan Marion | 08ff7e0 | 2016-01-20 13:45:36 +0100 | [diff] [blame] | 262 | /usr/bin/vpp* |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 263 | /usr/bin/svm* |
Dave Barach | 0e5e3c3 | 2016-01-25 08:28:22 -0500 | [diff] [blame] | 264 | /usr/bin/elftool |
Miroslav Miklus | 8e08e74 | 2016-10-11 13:35:26 +0200 | [diff] [blame] | 265 | %config /etc/sysctl.d/80-vpp.conf |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 266 | %config /etc/vpp/startup.conf |
Ole Troan | f14e3bf | 2016-12-01 21:49:03 +0100 | [diff] [blame] | 267 | /usr/share/vpp/api/* |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 268 | |
| 269 | %files lib |
| 270 | %defattr(-,bin,bin) |
Ed Warnicke | f5a1436 | 2016-09-12 20:40:24 +0000 | [diff] [blame] | 271 | %exclude %{_libdir}/vpp_plugins |
| 272 | %exclude %{_libdir}/vpp_api_test_plugins |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 273 | %{_libdir}/* |
Ole Troan | f14e3bf | 2016-12-01 21:49:03 +0100 | [diff] [blame] | 274 | /usr/share/vpp/api/* |
Padraig Connolly | 69915cb | 2017-01-10 17:10:39 +0000 | [diff] [blame] | 275 | /etc/bash_completion.d/vppctl_completion |
| 276 | /usr/share/vpp/vppctl-cmd-list |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 277 | |
Damjan Marion | cb034b9 | 2016-12-28 18:38:59 +0100 | [diff] [blame] | 278 | %files api-lua |
Gabriel Ganne | f3854e9 | 2017-01-17 10:00:54 +0100 | [diff] [blame] | 279 | %defattr(644,root,root,644) |
Damjan Marion | cb034b9 | 2016-12-28 18:38:59 +0100 | [diff] [blame] | 280 | /usr/share/doc/vpp/examples/lua |
| 281 | |
| 282 | %files api-java |
| 283 | %defattr(644,root,root) |
| 284 | /usr/share/java/* |
| 285 | |
| 286 | %files api-python |
Ole Troan | 57c3d66 | 2016-09-12 22:00:32 +0200 | [diff] [blame] | 287 | %defattr(644,root,root) |
Gabriel Ganne | 3290566 | 2016-12-06 19:12:49 +0100 | [diff] [blame] | 288 | %{python2_sitelib}/vpp_papi-*.egg |
Ole Troan | 57c3d66 | 2016-09-12 22:00:32 +0200 | [diff] [blame] | 289 | |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 290 | %files devel |
| 291 | %defattr(-,bin,bin) |
| 292 | /usr/bin/vppapigen |
Ed Warnicke | 406ab9d | 2016-08-31 18:48:47 -0700 | [diff] [blame] | 293 | /usr/bin/jvpp_gen.py |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 294 | %{_includedir}/* |
Ed Warnicke | 406ab9d | 2016-08-31 18:48:47 -0700 | [diff] [blame] | 295 | %{python2_sitelib}/jvppgen/* |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 296 | /usr/share/doc/vpp/examples/sample-plugin |
Ed Warnicke | 406ab9d | 2016-08-31 18:48:47 -0700 | [diff] [blame] | 297 | |
Ed Warnicke | f5a1436 | 2016-09-12 20:40:24 +0000 | [diff] [blame] | 298 | %files plugins |
| 299 | %defattr(-,bin,bin) |
Ed Warnicke | e7637e7 | 2016-09-14 16:58:33 -0700 | [diff] [blame] | 300 | /usr/lib/vpp_plugins/* |
| 301 | /usr/lib/vpp_api_test_plugins/* |
Ole Troan | f14e3bf | 2016-12-01 21:49:03 +0100 | [diff] [blame] | 302 | /usr/share/vpp/api/* |