Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 1 | #!/usr/bin/make -f |
| 2 | # See debhelper(7) (uncomment to enable) |
| 3 | # output every command that modifies files on the build system. |
| 4 | DH_VERBOSE = 1 |
| 5 | |
| 6 | # see EXAMPLES in dpkg-buildflags(1) and read /usr/share/dpkg/* |
| 7 | DPKG_EXPORT_BUILDFLAGS = 1 |
| 8 | include /usr/share/dpkg/default.mk |
| 9 | |
| 10 | # see FEATURE AREAS in dpkg-buildflags(1) |
| 11 | #export DEB_BUILD_MAINT_OPTIONS = hardening=+all |
| 12 | |
| 13 | # see ENVIRONMENT in dpkg-buildflags(1) |
| 14 | # package maintainers to append CFLAGS |
| 15 | #export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic |
| 16 | # package maintainers to append LDFLAGS |
| 17 | #export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed |
| 18 | |
| 19 | # main packaging script based on dh7 syntax |
| 20 | %: |
Srivatsa Sangli | 0777915 | 2016-04-15 13:59:00 -0700 | [diff] [blame] | 21 | dh $@ --with dkms --with systemd |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 22 | |
| 23 | override_dh_install: |
| 24 | dh_install --exclude .git |
| 25 | |
| 26 | override_dh_strip: |
| 27 | dh_strip --dbg-package=vpp-dbg |
| 28 | |
| 29 | override_dh_dkms: |
| 30 | dh_dkms -pvpp-dpdk-dkms |