Sachin | 693b702 | 2016-06-18 15:28:08 +0530 | [diff] [blame^] | 1 | %define _vpp_install_dir ../%{_install_dir} |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 2 | %define _vpp_build_dir ../build-tool-native |
| 3 | %define _unitdir /lib/systemd/system |
| 4 | %define _topdir %(pwd) |
| 5 | %define _builddir %{_topdir} |
| 6 | %define _version %(../scripts/version rpm-version) |
| 7 | %define _release %(../scripts/version rpm-release) |
| 8 | |
| 9 | Name: vpp |
| 10 | Summary: Vector Packet Processing |
| 11 | License: MIT |
| 12 | Version: %{_version} |
| 13 | Release: %{_release} |
| 14 | Requires: vpp-lib = %{_version}-%{_release}, net-tools, pciutils |
| 15 | |
| 16 | %description |
Damjan Marion | 08ff7e0 | 2016-01-20 13:45:36 +0100 | [diff] [blame] | 17 | This package provides VPP executables: vpp, vpp_api_test, vpp_json_test |
| 18 | vpp - the vector packet engine |
| 19 | vpp_api_test - vector packet engine API test tool |
| 20 | vpp_json_test - vector packet engine JSON test tool |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 21 | |
| 22 | %package lib |
| 23 | Summary: VPP libraries |
| 24 | Group: System Environment/Libraries |
| 25 | |
| 26 | %description lib |
| 27 | This package contains the VPP shared libraries, including: |
| 28 | vppinfra - foundation library supporting vectors, hashes, bitmaps, pools, and string formatting. |
| 29 | dpdk - Intel DPDK library |
| 30 | svm - vm library |
| 31 | vlib - vector processing library |
| 32 | vlib-api - binary API library |
| 33 | vnet - network stack library |
| 34 | |
| 35 | %package devel |
| 36 | Summary: VPP header files, static libraries |
| 37 | Group: Development/Libraries |
| 38 | Requires: vpp-lib |
| 39 | |
| 40 | %description devel |
| 41 | This package contains the header files and static libraries for |
| 42 | vppinfra. Install this package if you want to write or compile a |
| 43 | program that needs vpp. |
| 44 | Do we need to list those header files or just leave it blank ? |
| 45 | dynamic vectors (vec.c), dynamic bitmaps (bitmap.h), allocation heap of |
| 46 | objects (heap.c), allocation pool(pool.h), dynamic hash tables (hash.c), memory |
| 47 | allocator (mheap.c), extendable printf-like interface built on top of vectors |
| 48 | (format.c), formats for data structures (std-formats.c), and support for clock |
| 49 | time-based function calls (timer.c). |
| 50 | TODO: reference and describe only the .h files |
| 51 | |
Ed Warnicke | ec6290a | 2016-06-08 17:15:08 -0500 | [diff] [blame] | 52 | %pre |
| 53 | # Add the vpp group |
Ed Warnicke | b10427e | 2016-06-08 19:49:40 -0500 | [diff] [blame] | 54 | groupadd -f -r vpp |
Ed Warnicke | ec6290a | 2016-06-08 17:15:08 -0500 | [diff] [blame] | 55 | |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 56 | %install |
| 57 | # |
| 58 | # binaries |
| 59 | # |
| 60 | mkdir -p -m755 %{buildroot}%{_bindir} |
| 61 | mkdir -p -m755 %{buildroot}%{_unitdir} |
| 62 | install -p -m 755 %{_vpp_install_dir}/*/bin/* %{buildroot}%{_bindir} |
| 63 | install -p -m 755 %{_vpp_build_dir}/vppapigen/vppapigen %{buildroot}%{_bindir} |
| 64 | # |
| 65 | # configs |
| 66 | # |
| 67 | mkdir -p -m755 %{buildroot}/etc/vpp |
| 68 | mkdir -p -m755 %{buildroot}/etc/sysctl.d |
| 69 | install -p -m 644 vpp.service %{buildroot}%{_unitdir} |
Ed Warnicke | 40c6639 | 2016-06-08 14:41:40 -0500 | [diff] [blame] | 70 | install -p -m 644 ../../vpp/conf/startup.uiopcigeneric.conf %{buildroot}/etc/vpp/startup.conf |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 71 | install -p -m 644 ../../vpp/conf/80-vpp.conf %{buildroot}/etc/sysctl.d |
| 72 | # |
| 73 | # libraries |
| 74 | # |
| 75 | mkdir -p -m755 %{buildroot}%{_libdir} |
| 76 | for file in $(find %{_vpp_install_dir}/*/lib* -type f -name '*.so.*.*.*' -print ) |
| 77 | do |
| 78 | install -p -m 755 $file %{buildroot}%{_libdir} |
| 79 | done |
| 80 | for file in $(cd %{buildroot}%{_libdir} && find . -type f -print | sed -e 's/^\.\///') |
| 81 | do |
| 82 | # make lib symlinks |
| 83 | ( cd %{buildroot}%{_libdir} && |
| 84 | ln -fs $file $(echo $file | sed -e 's/\(\.so\.[0-9]\+\).*/\1/') ) |
| 85 | done |
| 86 | # |
| 87 | # devel |
| 88 | # |
| 89 | for dir in $(find %{_vpp_install_dir}/*/include/ -maxdepth 0 -type d -print | grep -v dpdk) |
| 90 | do |
| 91 | for subdir in $(cd ${dir} && find . -type d -print) |
| 92 | do |
| 93 | mkdir -p -m755 %{buildroot}/usr/include/${subdir} |
| 94 | done |
| 95 | for file in $(cd ${dir} && find . -type f -print) |
| 96 | do |
| 97 | install -p -m 644 $dir/$file %{buildroot}%{_includedir}/$file |
| 98 | done |
| 99 | done |
| 100 | # sample plugin |
| 101 | mkdir -p -m755 %{buildroot}/usr/share/doc/vpp/examples/sample-plugin/sample |
| 102 | for file in $(cd %{_vpp_install_dir}/../../sample-plugin && find -type f -print) |
| 103 | do |
| 104 | install -p -m 644 %{_vpp_install_dir}/../../sample-plugin/$file \ |
| 105 | %{buildroot}/usr/share/doc/vpp/examples/sample-plugin/$file |
| 106 | done |
| 107 | |
| 108 | %post |
| 109 | sysctl --system |
| 110 | %systemd_post vpp.service |
| 111 | |
| 112 | %postun |
| 113 | %systemd_postun_with_restart vpp.service |
| 114 | |
| 115 | %files |
| 116 | %defattr(-,bin,bin) |
| 117 | %{_unitdir}/vpp.service |
Damjan Marion | 08ff7e0 | 2016-01-20 13:45:36 +0100 | [diff] [blame] | 118 | /usr/bin/vpp* |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 119 | /usr/bin/svm* |
Dave Barach | 0e5e3c3 | 2016-01-25 08:28:22 -0500 | [diff] [blame] | 120 | /usr/bin/elftool |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 121 | %config /etc/sysctl.d/80-vpp.conf |
| 122 | %config /etc/vpp/startup.conf |
| 123 | |
| 124 | %files lib |
| 125 | %defattr(-,bin,bin) |
| 126 | %{_libdir}/* |
| 127 | |
| 128 | %files devel |
| 129 | %defattr(-,bin,bin) |
| 130 | /usr/bin/vppapigen |
| 131 | %{_includedir}/* |
| 132 | /usr/share/doc/vpp/examples/sample-plugin |