Thomas F Herbert | 4b0ac82 | 2017-08-29 16:07:51 -0400 | [diff] [blame] | 1 | %bcond_without aesni |
Renato Botelho do Couto | e266ea3 | 2017-11-30 15:41:22 -0600 | [diff] [blame] | 2 | %{!?_topdir:%define _topdir %(pwd)} |
Thomas F Herbert | 20a29c7 | 2016-10-13 18:36:50 -0400 | [diff] [blame] | 3 | %define _vpp_build_dir build-tool-native |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 4 | %define _unitdir /lib/systemd/system |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 5 | %define _builddir %{_topdir} |
Thomas F Herbert | b42b77b | 2018-04-06 15:13:41 -0400 | [diff] [blame] | 6 | %define _mu_build_dir %{_topdir}/%{name}-%{_version}/build-root |
Igor Mikhailov (imichail) | c442e61 | 2017-05-18 19:46:17 -0700 | [diff] [blame] | 7 | %define _vpp_tag %{getenv:TAG} |
| 8 | %if "%{_vpp_tag}" == "" |
| 9 | %define _vpp_tag vpp |
| 10 | %endif |
| 11 | %define _vpp_install_dir install-%{_vpp_tag}-native |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 12 | |
Peter Ginchev | dfa9c5b | 2016-10-11 15:34:24 +0300 | [diff] [blame] | 13 | %{?systemd_requires} |
| 14 | |
Billy McFall | 28cf3b7 | 2018-01-15 17:54:52 -0500 | [diff] [blame] | 15 | |
| 16 | # SELinux Related definitions |
| 17 | %global selinuxtype targeted |
| 18 | %global moduletype services |
| 19 | %global modulenames vpp-custom |
| 20 | |
| 21 | # Usage: _format var format |
| 22 | # Expand 'modulenames' into various formats as needed |
| 23 | # Format must contain '$x' somewhere to do anything useful |
| 24 | %global _format() export %1=""; for x in %{modulenames}; do %1+=%2; %1+=" "; done; |
| 25 | |
| 26 | # Relabel files |
| 27 | %global relabel_files() \ # ADD files in *.fc file |
| 28 | |
| 29 | # Version of distribution SELinux policy package |
| 30 | %global selinux_policyver 3.13.1-128.6.fc22 |
| 31 | |
| 32 | |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 33 | Name: vpp |
| 34 | Summary: Vector Packet Processing |
Billy McFall | f6e3ad0 | 2017-07-05 09:33:30 -0400 | [diff] [blame] | 35 | License: ASL 2.0 |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 36 | Version: %{_version} |
| 37 | Release: %{_release} |
Damjan Marion | a1bd023 | 2016-12-19 19:08:11 +0100 | [diff] [blame] | 38 | BuildRequires: systemd, chrpath |
Thomas F Herbert | e412891 | 2017-10-09 15:03:55 -0400 | [diff] [blame] | 39 | BuildRequires: check, check-devel |
Thomas F Herbert | 6eb6163 | 2018-11-27 15:57:30 -0500 | [diff] [blame] | 40 | %if 0%{?fedora} |
Ian Wells | 13cef0c | 2019-08-09 17:27:19 -0700 | [diff] [blame] | 41 | Requires: vpp-lib = %{_version}-%{_release}, vpp-selinux-policy = %{_version}-%{_release}, net-tools, pciutils |
Thomas F Herbert | ca3d38a | 2019-04-22 17:35:03 -0400 | [diff] [blame] | 42 | Requires: compat-openssl10 |
Florin Coras | 66d6146 | 2022-04-18 09:29:59 -0700 | [diff] [blame] | 43 | Requires: libffi-devel |
Thomas F Herbert | 6673178 | 2018-03-05 17:21:56 -0500 | [diff] [blame] | 44 | BuildRequires: subunit, subunit-devel |
Thomas F Herbert | 440751b | 2017-09-11 08:58:23 -0400 | [diff] [blame] | 45 | BuildRequires: compat-openssl10-devel |
Ian Wells | 13cef0c | 2019-08-09 17:27:19 -0700 | [diff] [blame] | 46 | BuildRequires: python, python-devel, python-virtualenv, python-ply |
| 47 | BuildRequires: python3, python36-devel, python3-virtualenv |
Thomas F Herbert | 6eb6163 | 2018-11-27 15:57:30 -0500 | [diff] [blame] | 48 | BuildRequires: cmake |
Thomas F Herbert | bd8e242 | 2017-08-03 11:04:24 -0400 | [diff] [blame] | 49 | %else |
Renato Botelho do Couto | c025329 | 2019-11-07 06:10:34 -0600 | [diff] [blame] | 50 | %if 0%{rhel} >= 7 |
Thomas F Herbert | ca3d38a | 2019-04-22 17:35:03 -0400 | [diff] [blame] | 51 | Requires: vpp-lib = %{_version}-%{_release}, vpp-selinux-policy = %{_version}-%{_release}, net-tools, pciutils, python36 |
Florin Coras | 66d6146 | 2022-04-18 09:29:59 -0700 | [diff] [blame] | 52 | Requires: libffi-devel |
Thomas F Herbert | ca3d38a | 2019-04-22 17:35:03 -0400 | [diff] [blame] | 53 | BuildRequires: epel-release |
Thomas F Herbert | 440751b | 2017-09-11 08:58:23 -0400 | [diff] [blame] | 54 | BuildREquires: openssl-devel |
Thomas F Herbert | ca3d38a | 2019-04-22 17:35:03 -0400 | [diff] [blame] | 55 | BuildRequires: python36-devel |
Renato Botelho do Couto | c025329 | 2019-11-07 06:10:34 -0600 | [diff] [blame] | 56 | %if 0%{rhel} == 7 |
Damjan Marion | 162330f | 2020-04-29 21:28:15 +0200 | [diff] [blame] | 57 | BuildRequires: devtoolset-9-toolchain |
Thomas F Herbert | 6eb6163 | 2018-11-27 15:57:30 -0500 | [diff] [blame] | 58 | BuildRequires: cmake3 |
Renato Botelho do Couto | c025329 | 2019-11-07 06:10:34 -0600 | [diff] [blame] | 59 | BuildRequires: glibc-static, yum-utils |
| 60 | %else |
| 61 | BuildRequires: cmake |
| 62 | BuildRequires: dnf-utils |
| 63 | %endif |
Thomas F Herbert | bd8e242 | 2017-08-03 11:04:24 -0400 | [diff] [blame] | 64 | %endif |
| 65 | %endif |
Thomas F Herbert | 440751b | 2017-09-11 08:58:23 -0400 | [diff] [blame] | 66 | BuildRequires: libffi-devel |
Renato Botelho do Couto | c025329 | 2019-11-07 06:10:34 -0600 | [diff] [blame] | 67 | BuildRequires: redhat-lsb |
Thomas F Herbert | bd8e242 | 2017-08-03 11:04:24 -0400 | [diff] [blame] | 68 | BuildRequires: apr-devel |
Thomas F Herbert | bd8e242 | 2017-08-03 11:04:24 -0400 | [diff] [blame] | 69 | BuildRequires: numactl-devel |
| 70 | BuildRequires: autoconf automake libtool byacc bison flex |
Billy McFall | 28cf3b7 | 2018-01-15 17:54:52 -0500 | [diff] [blame] | 71 | BuildRequires: selinux-policy selinux-policy-devel |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 72 | |
Thomas F Herbert | b60f496 | 2017-07-19 19:17:15 -0400 | [diff] [blame] | 73 | Source: %{name}-%{_version}-%{_release}.tar.xz |
| 74 | # Source: vpp-latest.tar.xz |
Thomas F Herbert | 20a29c7 | 2016-10-13 18:36:50 -0400 | [diff] [blame] | 75 | |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 76 | %description |
Damjan Marion | 08ff7e0 | 2016-01-20 13:45:36 +0100 | [diff] [blame] | 77 | This package provides VPP executables: vpp, vpp_api_test, vpp_json_test |
| 78 | vpp - the vector packet engine |
| 79 | vpp_api_test - vector packet engine API test tool |
| 80 | vpp_json_test - vector packet engine JSON test tool |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 81 | |
| 82 | %package lib |
| 83 | Summary: VPP libraries |
| 84 | Group: System Environment/Libraries |
Billy McFall | 28cf3b7 | 2018-01-15 17:54:52 -0500 | [diff] [blame] | 85 | Requires: vpp-selinux-policy = %{_version}-%{_release} |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 86 | |
| 87 | %description lib |
| 88 | This package contains the VPP shared libraries, including: |
| 89 | vppinfra - foundation library supporting vectors, hashes, bitmaps, pools, and string formatting. |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 90 | svm - vm library |
| 91 | vlib - vector processing library |
| 92 | vlib-api - binary API library |
| 93 | vnet - network stack library |
| 94 | |
| 95 | %package devel |
| 96 | Summary: VPP header files, static libraries |
| 97 | Group: Development/Libraries |
| 98 | Requires: vpp-lib |
| 99 | |
| 100 | %description devel |
Thomas F Herbert | 3977a21 | 2016-10-01 18:09:33 -0400 | [diff] [blame] | 101 | This package contains the header files for VPP. |
| 102 | Install this package if you want to write a |
| 103 | program for compilation and linking with vpp lib. |
| 104 | vlib |
| 105 | vlibmemory |
| 106 | vnet - devices, classify, dhcp, ethernet flow, gre, ip, etc. |
| 107 | vpp-api |
| 108 | vppinfra |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 109 | |
Ed Warnicke | f5a1436 | 2016-09-12 20:40:24 +0000 | [diff] [blame] | 110 | %package plugins |
| 111 | Summary: Vector Packet Processing--runtime plugins |
| 112 | Group: System Environment/Libraries |
Gabriel Ganne | bf246df | 2018-01-18 11:00:17 +0100 | [diff] [blame] | 113 | Requires: vpp = %{_version}-%{_release} numactl-libs |
Ed Warnicke | f5a1436 | 2016-09-12 20:40:24 +0000 | [diff] [blame] | 114 | %description plugins |
| 115 | This package contains VPP plugins |
| 116 | |
Damjan Marion | cb034b9 | 2016-12-28 18:38:59 +0100 | [diff] [blame] | 117 | %package api-lua |
| 118 | Summary: VPP api lua bindings |
| 119 | Group: Development/Libraries |
| 120 | Requires: vpp = %{_version}-%{_release}, vpp-lib = %{_version}-%{_release} |
| 121 | |
| 122 | %description api-lua |
| 123 | This package contains the lua bindings for the vpp api |
| 124 | |
Ian Wells | 13cef0c | 2019-08-09 17:27:19 -0700 | [diff] [blame] | 125 | %package api-python3 |
| 126 | Summary: VPP api python3 bindings |
| 127 | Group: Development/Libraries |
| 128 | Requires: vpp = %{_version}-%{_release}, vpp-lib = %{_version}-%{_release}, libffi-devel |
Yichen Wang | 466872f | 2020-06-30 23:14:23 -0700 | [diff] [blame] | 129 | Requires: python3-setuptools |
Ian Wells | 13cef0c | 2019-08-09 17:27:19 -0700 | [diff] [blame] | 130 | |
| 131 | %description api-python3 |
| 132 | This package contains the python3 bindings for the vpp api |
| 133 | |
Billy McFall | 28cf3b7 | 2018-01-15 17:54:52 -0500 | [diff] [blame] | 134 | %package selinux-policy |
| 135 | Summary: VPP Security-Enhanced Linux (SELinux) policy |
| 136 | Group: System Environment/Base |
Renato Botelho do Couto | 1d94ab5 | 2020-03-06 13:42:22 -0600 | [diff] [blame] | 137 | Requires(post): selinux-policy-base >= %{selinux_policyver}, selinux-policy-targeted >= %{selinux_policyver}, policycoreutils, libselinux-utils |
| 138 | %if 0%{rhel} < 8 |
| 139 | Requires(post): policycoreutils-python |
| 140 | %else |
| 141 | Requires(post): python3-policycoreutils |
| 142 | %endif |
Billy McFall | 28cf3b7 | 2018-01-15 17:54:52 -0500 | [diff] [blame] | 143 | |
| 144 | %description selinux-policy |
| 145 | This package contains a tailored VPP SELinux policy |
| 146 | |
Thomas F Herbert | 20a29c7 | 2016-10-13 18:36:50 -0400 | [diff] [blame] | 147 | %prep |
Dave Wallace | 27b50fe | 2020-09-16 21:04:24 +0000 | [diff] [blame] | 148 | %setup -q -c -T -n %{name}-%{_version} |
| 149 | cd .. |
| 150 | unxz --stdout ./SOURCES/%{name}-%{_version}-%{_release}.tar.xz | tar --extract --touch |
| 151 | cd - |
Thomas F Herbert | 20a29c7 | 2016-10-13 18:36:50 -0400 | [diff] [blame] | 152 | |
Ed Warnicke | ec6290a | 2016-06-08 17:15:08 -0500 | [diff] [blame] | 153 | %pre |
| 154 | # Add the vpp group |
Ed Warnicke | b10427e | 2016-06-08 19:49:40 -0500 | [diff] [blame] | 155 | groupadd -f -r vpp |
Ed Warnicke | ec6290a | 2016-06-08 17:15:08 -0500 | [diff] [blame] | 156 | |
Ole Troan | c60f557 | 2017-03-17 09:54:51 +0100 | [diff] [blame] | 157 | %build |
Renato Botelho do Couto | c025329 | 2019-11-07 06:10:34 -0600 | [diff] [blame] | 158 | %if 0%{rhel} < 8 |
Damjan Marion | 162330f | 2020-04-29 21:28:15 +0200 | [diff] [blame] | 159 | . /opt/rh/devtoolset-9/enable |
Thomas F Herbert | 6eb6163 | 2018-11-27 15:57:30 -0500 | [diff] [blame] | 160 | %endif |
Thomas F Herbert | 4b0ac82 | 2017-08-29 16:07:51 -0400 | [diff] [blame] | 161 | %if %{with aesni} |
Dave Wallace | 27b50fe | 2020-09-16 21:04:24 +0000 | [diff] [blame] | 162 | make install-dep |
Thomas F Herbert | 4b0ac82 | 2017-08-29 16:07:51 -0400 | [diff] [blame] | 163 | make -C build-root PLATFORM=vpp TAG=%{_vpp_tag} install-packages |
| 164 | %else |
| 165 | make bootstrap AESNI=n |
| 166 | make -C build-root PLATFORM=vpp AESNI=n TAG=%{_vpp_tag} install-packages |
| 167 | %endif |
Thomas F Herbert | ca3d38a | 2019-04-22 17:35:03 -0400 | [diff] [blame] | 168 | cd %{_mu_build_dir}/../src/vpp-api/python && %py3_build |
Billy McFall | 28cf3b7 | 2018-01-15 17:54:52 -0500 | [diff] [blame] | 169 | cd %{_mu_build_dir}/../extras/selinux && make -f %{_datadir}/selinux/devel/Makefile |
Ole Troan | c60f557 | 2017-03-17 09:54:51 +0100 | [diff] [blame] | 170 | |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 171 | %install |
| 172 | # |
| 173 | # binaries |
| 174 | # |
| 175 | mkdir -p -m755 %{buildroot}%{_bindir} |
| 176 | mkdir -p -m755 %{buildroot}%{_unitdir} |
Gabriel Ganne | 714968b | 2017-01-26 15:42:39 +0100 | [diff] [blame] | 177 | install -p -m 755 %{_mu_build_dir}/%{_vpp_install_dir}/vpp/bin/* %{buildroot}%{_bindir} |
Ole Troan | f14e3bf | 2016-12-01 21:49:03 +0100 | [diff] [blame] | 178 | |
Damjan Marion | 7cd468a | 2016-12-19 23:05:39 +0100 | [diff] [blame] | 179 | # api |
Ole Troan | f14e3bf | 2016-12-01 21:49:03 +0100 | [diff] [blame] | 180 | mkdir -p -m755 %{buildroot}/usr/share/vpp/api |
Ole Troan | f14e3bf | 2016-12-01 21:49:03 +0100 | [diff] [blame] | 181 | |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 182 | # |
| 183 | # configs |
| 184 | # |
| 185 | mkdir -p -m755 %{buildroot}/etc/vpp |
Miroslav Miklus | 8e08e74 | 2016-10-11 13:35:26 +0200 | [diff] [blame] | 186 | mkdir -p -m755 %{buildroot}/etc/sysctl.d |
Thomas F Herbert | 5b75b6b | 2017-07-23 17:21:46 -0400 | [diff] [blame] | 187 | install -p -m 644 %{_mu_build_dir}/../extras/rpm/vpp.service %{buildroot}%{_unitdir} |
Damjan Marion | d0f673e | 2017-01-31 17:29:33 +0100 | [diff] [blame] | 188 | install -p -m 644 %{_mu_build_dir}/../src/vpp/conf/startup.conf %{buildroot}/etc/vpp/startup.conf |
Damjan Marion | 7cd468a | 2016-12-19 23:05:39 +0100 | [diff] [blame] | 189 | install -p -m 644 %{_mu_build_dir}/../src/vpp/conf/80-vpp.conf %{buildroot}/etc/sysctl.d |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 190 | # |
| 191 | # libraries |
| 192 | # |
| 193 | mkdir -p -m755 %{buildroot}%{_libdir} |
Padraig Connolly | 69915cb | 2017-01-10 17:10:39 +0000 | [diff] [blame] | 194 | mkdir -p -m755 %{buildroot}/etc/bash_completion.d |
| 195 | mkdir -p -m755 %{buildroot}/usr/share/vpp |
Matthew Smith | d790c7e | 2018-09-06 10:59:49 -0500 | [diff] [blame] | 196 | for file in $(find %{_mu_build_dir}/%{_vpp_install_dir}/*/lib* -type f -name '*.so.*.*' -print ) |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 197 | do |
| 198 | install -p -m 755 $file %{buildroot}%{_libdir} |
| 199 | done |
| 200 | for file in $(cd %{buildroot}%{_libdir} && find . -type f -print | sed -e 's/^\.\///') |
| 201 | do |
| 202 | # make lib symlinks |
| 203 | ( cd %{buildroot}%{_libdir} && |
| 204 | ln -fs $file $(echo $file | sed -e 's/\(\.so\.[0-9]\+\).*/\1/') ) |
Ed Warnicke | f5a0e73 | 2016-09-07 17:12:52 +0000 | [diff] [blame] | 205 | ( cd %{buildroot}%{_libdir} && |
| 206 | ln -fs $file $(echo $file | sed -e 's/\(\.so\)\.[0-9]\+.*/\1/') ) |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 207 | done |
Damjan Marion | 7cd468a | 2016-12-19 23:05:39 +0100 | [diff] [blame] | 208 | for file in $(find %{_mu_build_dir}/%{_vpp_install_dir}/vpp/share/vpp/api -type f -name '*.api.json' -print ) |
Ole Troan | f14e3bf | 2016-12-01 21:49:03 +0100 | [diff] [blame] | 209 | do |
| 210 | install -p -m 644 $file %{buildroot}/usr/share/vpp/api |
| 211 | done |
Ed Warnicke | 406ab9d | 2016-08-31 18:48:47 -0700 | [diff] [blame] | 212 | |
Damjan Marion | cb034b9 | 2016-12-28 18:38:59 +0100 | [diff] [blame] | 213 | # Lua bindings |
| 214 | mkdir -p -m755 %{buildroot}/usr/share/doc/vpp/examples/lua/examples/cli |
| 215 | mkdir -p -m755 %{buildroot}/usr/share/doc/vpp/examples/lua/examples/lute |
Thomas F Herbert | bd8e242 | 2017-08-03 11:04:24 -0400 | [diff] [blame] | 216 | # for file in $(cd %{_mu_build_dir}/%{_vpp_install_dir}/../../src/vpp-api/lua && git ls-files .) |
| 217 | for file in $(cd %{_mu_build_dir}/%{_vpp_install_dir}/../../src/vpp-api/lua && find . -type f -regex '.*/*.[luteamd]' -print | sed -e 's/^\.\///') |
Damjan Marion | cb034b9 | 2016-12-28 18:38:59 +0100 | [diff] [blame] | 218 | do |
Thomas F Herbert | bd8e242 | 2017-08-03 11:04:24 -0400 | [diff] [blame] | 219 | ( cd %{_mu_build_dir}/%{_vpp_install_dir}/../../src/vpp-api/lua && install -p -m 644 $file \ |
| 220 | %{buildroot}/usr/share/doc/vpp/examples/lua/$file ) |
Damjan Marion | cb034b9 | 2016-12-28 18:38:59 +0100 | [diff] [blame] | 221 | done |
| 222 | |
Ole Troan | 57c3d66 | 2016-09-12 22:00:32 +0200 | [diff] [blame] | 223 | # Python bindings |
Thomas F Herbert | ca3d38a | 2019-04-22 17:35:03 -0400 | [diff] [blame] | 224 | cd %{_mu_build_dir}/../src/vpp-api/python && %py3_install |
Ole Troan | 57c3d66 | 2016-09-12 22:00:32 +0200 | [diff] [blame] | 225 | |
Billy McFall | 28cf3b7 | 2018-01-15 17:54:52 -0500 | [diff] [blame] | 226 | # SELinux Policy |
| 227 | # Install SELinux interfaces |
| 228 | %_format INTERFACES %{_mu_build_dir}/../extras/selinux/$x.if |
| 229 | install -d %{buildroot}%{_datadir}/selinux/devel/include/%{moduletype} |
| 230 | install -p -m 644 $INTERFACES \ |
| 231 | %{buildroot}%{_datadir}/selinux/devel/include/%{moduletype} |
| 232 | |
| 233 | # Install policy modules |
| 234 | %_format MODULES %{_mu_build_dir}/../extras/selinux/$x.pp |
| 235 | install -d %{buildroot}%{_datadir}/selinux/packages |
| 236 | install -m 0644 $MODULES \ |
| 237 | %{buildroot}%{_datadir}/selinux/packages |
| 238 | |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 239 | # |
| 240 | # devel |
| 241 | # |
Damjan Marion | 8c1afb5 | 2020-10-16 15:28:47 +0200 | [diff] [blame] | 242 | for dir in %{_mu_build_dir}/%{_vpp_install_dir}/vpp/include/ |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 243 | do |
| 244 | for subdir in $(cd ${dir} && find . -type d -print) |
| 245 | do |
| 246 | mkdir -p -m755 %{buildroot}/usr/include/${subdir} |
| 247 | done |
| 248 | for file in $(cd ${dir} && find . -type f -print) |
| 249 | do |
| 250 | install -p -m 644 $dir/$file %{buildroot}%{_includedir}/$file |
| 251 | done |
| 252 | done |
Ed Warnicke | 406ab9d | 2016-08-31 18:48:47 -0700 | [diff] [blame] | 253 | |
Paul Vinciguerra | 9ce6a21 | 2018-09-12 13:40:13 -0700 | [diff] [blame] | 254 | install -p -m 644 %{_mu_build_dir}/../src/tools/vppapigen/vppapigen_c.py %{buildroot}/usr/share/vpp |
| 255 | install -p -m 644 %{_mu_build_dir}/../src/tools/vppapigen/vppapigen_json.py %{buildroot}/usr/share/vpp |
Jon Loeliger | 190282c | 2018-01-31 09:45:11 -0600 | [diff] [blame] | 256 | |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 257 | # sample plugin |
| 258 | mkdir -p -m755 %{buildroot}/usr/share/doc/vpp/examples/sample-plugin/sample |
Thomas F Herbert | bd8e242 | 2017-08-03 11:04:24 -0400 | [diff] [blame] | 259 | #for file in $(cd %{_mu_build_dir}/%{_vpp_install_dir}/../../src/examples/sample-plugin && git ls-files .) |
| 260 | for file in $(cd %{_mu_build_dir}/%{_vpp_install_dir}/../../src/examples/sample-plugin && find . -type f -regex '.*/*.[acdhimp]' -print | sed -e 's/^\.\///') |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 261 | do |
Thomas F Herbert | bd8e242 | 2017-08-03 11:04:24 -0400 | [diff] [blame] | 262 | ( cd %{_mu_build_dir}/%{_vpp_install_dir}/../../src/examples/sample-plugin && install -p -m 644 $file \ |
| 263 | %{buildroot}/usr/share/doc/vpp/examples/sample-plugin/$file ) |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 264 | done |
| 265 | |
Billy McFall | 28cf3b7 | 2018-01-15 17:54:52 -0500 | [diff] [blame] | 266 | # vppctl sockfile directory |
| 267 | mkdir -p -m755 %{buildroot}%{_localstatedir}/run/vpp |
| 268 | # vpp.log directory |
| 269 | mkdir -p -m755 %{buildroot}%{_localstatedir}/log/vpp |
Ed Warnicke | f5a1436 | 2016-09-12 20:40:24 +0000 | [diff] [blame] | 270 | |
| 271 | # |
| 272 | # vpp-plugins |
Damjan Marion | 79dcbc7 | 2018-09-12 14:01:10 +0200 | [diff] [blame] | 273 | # |
Ed Warnicke | e7637e7 | 2016-09-14 16:58:33 -0700 | [diff] [blame] | 274 | mkdir -p -m755 %{buildroot}/usr/lib/vpp_plugins |
| 275 | mkdir -p -m755 %{buildroot}/usr/lib/vpp_api_test_plugins |
Tianyu Li | fa6e7aa | 2021-09-28 13:00:16 +0800 | [diff] [blame] | 276 | for file in $(cd %{_mu_build_dir}/%{_vpp_install_dir}/vpp/%{_lib}/vpp_plugins && find -type f -print) |
Damjan Marion | 7cd468a | 2016-12-19 23:05:39 +0100 | [diff] [blame] | 277 | do |
Tianyu Li | fa6e7aa | 2021-09-28 13:00:16 +0800 | [diff] [blame] | 278 | install -p -m 755 %{_mu_build_dir}/%{_vpp_install_dir}/vpp/%{_lib}/vpp_plugins/$file \ |
Damjan Marion | 7cd468a | 2016-12-19 23:05:39 +0100 | [diff] [blame] | 279 | %{buildroot}/usr/lib/vpp_plugins/$file |
| 280 | done |
| 281 | |
Tianyu Li | fa6e7aa | 2021-09-28 13:00:16 +0800 | [diff] [blame] | 282 | for file in $(cd %{_mu_build_dir}/%{_vpp_install_dir}/vpp/%{_lib}/vpp_api_test_plugins && find -type f -print) |
Damjan Marion | 7cd468a | 2016-12-19 23:05:39 +0100 | [diff] [blame] | 283 | do |
Tianyu Li | fa6e7aa | 2021-09-28 13:00:16 +0800 | [diff] [blame] | 284 | install -p -m 755 %{_mu_build_dir}/%{_vpp_install_dir}/vpp/%{_lib}/vpp_api_test_plugins/$file \ |
Damjan Marion | 7cd468a | 2016-12-19 23:05:39 +0100 | [diff] [blame] | 285 | %{buildroot}/usr/lib/vpp_api_test_plugins/$file |
| 286 | done |
| 287 | |
Mohsin Kazmi | 7b2017d | 2018-09-26 10:49:41 +0200 | [diff] [blame] | 288 | for file in $(find %{_mu_build_dir}/%{_vpp_install_dir}/vpp/share/vpp/api/plugins -type f -name '*.api.json' -print ) |
Ole Troan | f14e3bf | 2016-12-01 21:49:03 +0100 | [diff] [blame] | 289 | do |
Matthew Smith | 4ed0039 | 2019-03-05 09:28:48 -0600 | [diff] [blame] | 290 | install -p -m 755 $file %{buildroot}/usr/share/vpp/api |
Ole Troan | f14e3bf | 2016-12-01 21:49:03 +0100 | [diff] [blame] | 291 | done |
| 292 | |
Damjan Marion | a1bd023 | 2016-12-19 19:08:11 +0100 | [diff] [blame] | 293 | # |
| 294 | # remove RPATH from ELF binaries |
| 295 | # |
| 296 | %{_mu_build_dir}/scripts/remove-rpath %{buildroot} |
| 297 | |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 298 | %post |
Kristina Nevolnikova | 8ae1873 | 2017-06-21 14:20:42 +0200 | [diff] [blame] | 299 | if [ $1 -eq 1 ] ; then |
| 300 | sysctl --system |
| 301 | fi |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 302 | %systemd_post vpp.service |
| 303 | |
Peter Ginchev | dfa9c5b | 2016-10-11 15:34:24 +0300 | [diff] [blame] | 304 | %preun |
| 305 | %systemd_preun vpp.service |
| 306 | |
Billy McFall | 28cf3b7 | 2018-01-15 17:54:52 -0500 | [diff] [blame] | 307 | %post selinux-policy |
| 308 | %_format MODULES %{_datadir}/selinux/packages/$x.pp |
Billy McFall | 28cf3b7 | 2018-01-15 17:54:52 -0500 | [diff] [blame] | 309 | if %{_sbindir}/selinuxenabled ; then |
Matthew Smith | 7c172cb | 2018-02-22 21:12:11 -0600 | [diff] [blame] | 310 | %{_sbindir}/semodule -n -X 400 -s %{selinuxtype} -i $MODULES |
Billy McFall | 28cf3b7 | 2018-01-15 17:54:52 -0500 | [diff] [blame] | 311 | %{_sbindir}/load_policy |
| 312 | %relabel_files |
| 313 | fi |
| 314 | |
| 315 | |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 316 | %postun |
Peter Ginchev | dfa9c5b | 2016-10-11 15:34:24 +0300 | [diff] [blame] | 317 | %systemd_postun |
Kristina Nevolnikova | 8ae1873 | 2017-06-21 14:20:42 +0200 | [diff] [blame] | 318 | if [ $1 -eq 0 ] ; then |
| 319 | echo "Uninstalling, unbind user-mode PCI drivers" |
| 320 | # Unbind user-mode PCI drivers |
| 321 | removed= |
| 322 | pci_dirs=`find /sys/bus/pci/drivers -type d -name igb_uio -o -name uio_pci_generic -o -name vfio-pci` |
| 323 | for d in $pci_dirs; do |
| 324 | for f in ${d}/*; do |
| 325 | [ -e "${f}/config" ] || continue |
| 326 | echo ${f##*/} > ${d}/unbind |
| 327 | basename `dirname ${f}` | xargs echo -n "Removing driver"; echo " for PCI ID" `basename ${f}` |
| 328 | removed=y |
| 329 | done |
Peter Ginchev | dfa9c5b | 2016-10-11 15:34:24 +0300 | [diff] [blame] | 330 | done |
Kristina Nevolnikova | 8ae1873 | 2017-06-21 14:20:42 +0200 | [diff] [blame] | 331 | if [ -n "${removed}" ]; then |
| 332 | echo "There are changes in PCI drivers, rescaning" |
| 333 | echo 1 > /sys/bus/pci/rescan |
| 334 | else |
| 335 | echo "There weren't PCI devices binded" |
| 336 | fi |
Peter Ginchev | dfa9c5b | 2016-10-11 15:34:24 +0300 | [diff] [blame] | 337 | else |
Kristina Nevolnikova | 8ae1873 | 2017-06-21 14:20:42 +0200 | [diff] [blame] | 338 | echo "Upgrading package, dont' unbind interfaces" |
Peter Ginchev | dfa9c5b | 2016-10-11 15:34:24 +0300 | [diff] [blame] | 339 | fi |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 340 | |
Billy McFall | 28cf3b7 | 2018-01-15 17:54:52 -0500 | [diff] [blame] | 341 | %postun selinux-policy |
| 342 | if [ $1 -eq 0 ]; then |
| 343 | %{_sbindir}/semodule -n -r %{modulenames} |
| 344 | if %{_sbindir}/selinuxenabled ; then |
| 345 | %{_sbindir}/load_policy |
| 346 | %relabel_files |
| 347 | fi |
| 348 | fi |
| 349 | |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 350 | %files |
| 351 | %defattr(-,bin,bin) |
| 352 | %{_unitdir}/vpp.service |
Matthew Smith | 48a13f3 | 2021-08-19 15:47:06 -0500 | [diff] [blame] | 353 | /usr/bin/vat2 |
Damjan Marion | 08ff7e0 | 2016-01-20 13:45:36 +0100 | [diff] [blame] | 354 | /usr/bin/vpp* |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 355 | /usr/bin/svm* |
Billy McFall | ce41a5c | 2017-09-08 20:11:58 +0000 | [diff] [blame] | 356 | %config(noreplace) /etc/sysctl.d/80-vpp.conf |
| 357 | %config(noreplace) /etc/vpp/startup.conf |
Ole Troan | f14e3bf | 2016-12-01 21:49:03 +0100 | [diff] [blame] | 358 | /usr/share/vpp/api/* |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 359 | |
Billy McFall | 28cf3b7 | 2018-01-15 17:54:52 -0500 | [diff] [blame] | 360 | %defattr(-,root,vpp) |
| 361 | %{_localstatedir}/run/vpp* |
| 362 | |
| 363 | %defattr(-,root,root) |
| 364 | %{_localstatedir}/log/vpp* |
| 365 | |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 366 | %files lib |
| 367 | %defattr(-,bin,bin) |
Igor Mikhailov (imichail) | 3b854a5 | 2018-05-18 20:08:26 -0700 | [diff] [blame] | 368 | %global __requires_exclude_from %{_libdir}/librte_pmd_mlx[45]_glue\\.so.*$ |
Ed Warnicke | f5a1436 | 2016-09-12 20:40:24 +0000 | [diff] [blame] | 369 | %exclude %{_libdir}/vpp_plugins |
| 370 | %exclude %{_libdir}/vpp_api_test_plugins |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 371 | %{_libdir}/* |
Ole Troan | f14e3bf | 2016-12-01 21:49:03 +0100 | [diff] [blame] | 372 | /usr/share/vpp/api/* |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 373 | |
Damjan Marion | cb034b9 | 2016-12-28 18:38:59 +0100 | [diff] [blame] | 374 | %files api-lua |
Gabriel Ganne | f3854e9 | 2017-01-17 10:00:54 +0100 | [diff] [blame] | 375 | %defattr(644,root,root,644) |
Damjan Marion | cb034b9 | 2016-12-28 18:38:59 +0100 | [diff] [blame] | 376 | /usr/share/doc/vpp/examples/lua |
| 377 | |
Ian Wells | 13cef0c | 2019-08-09 17:27:19 -0700 | [diff] [blame] | 378 | %files api-python3 |
| 379 | %defattr(644,root,root,755) |
Thomas F Herbert | ca3d38a | 2019-04-22 17:35:03 -0400 | [diff] [blame] | 380 | %{python3_sitelib}/vpp_* |
Ole Troan | 57c3d66 | 2016-09-12 22:00:32 +0200 | [diff] [blame] | 381 | |
Billy McFall | 28cf3b7 | 2018-01-15 17:54:52 -0500 | [diff] [blame] | 382 | %files selinux-policy |
| 383 | %defattr(-,root,root,0755) |
| 384 | %attr(0644,root,root) %{_datadir}/selinux/packages/*.pp |
| 385 | %attr(0644,root,root) %{_datadir}/selinux/devel/include/%{moduletype}/*.if |
| 386 | |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 387 | %files devel |
| 388 | %defattr(-,bin,bin) |
| 389 | /usr/bin/vppapigen |
Oliver Giles | dc20371 | 2019-12-05 23:37:36 +0200 | [diff] [blame] | 390 | /usr/bin/vapi_c_gen.py |
| 391 | /usr/bin/vapi_cpp_gen.py |
| 392 | /usr/bin/vapi_json_parser.py |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 393 | %{_includedir}/* |
| 394 | /usr/share/doc/vpp/examples/sample-plugin |
Ole Troan | 9d42087 | 2017-10-12 13:06:35 +0200 | [diff] [blame] | 395 | /usr/share/vpp |
Ed Warnicke | 406ab9d | 2016-08-31 18:48:47 -0700 | [diff] [blame] | 396 | |
Ed Warnicke | f5a1436 | 2016-09-12 20:40:24 +0000 | [diff] [blame] | 397 | %files plugins |
| 398 | %defattr(-,bin,bin) |
Ed Warnicke | e7637e7 | 2016-09-14 16:58:33 -0700 | [diff] [blame] | 399 | /usr/lib/vpp_plugins/* |
| 400 | /usr/lib/vpp_api_test_plugins/* |
Ole Troan | f14e3bf | 2016-12-01 21:49:03 +0100 | [diff] [blame] | 401 | /usr/share/vpp/api/* |