blob: 91beb27ea7d268366b87044597297c3356087de0 [file] [log] [blame]
#
## Copyright (C) 2019 Wind River Systems, Inc.
#
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
# You may obtain a copy of the License at
#
# http://www.apache.org/licenses/LICENSE-2.0
#
# Unless required by applicable law or agreed to in writing, software
# distributed under the License is distributed on an "AS IS" BASIS,
# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
# See the License for the specific language governing permissions and
# limitations under the License.
DESCRIPTION = "CLI and python client library for OpenStack Neutron"
HOMEPAGE = "https://launchpad.net/neutron"
SECTION = "devel/python"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
SRCREV = "680b417111dbbda9e318700286c4efd9055f1af3"
SRCNAME = "python-neutronclient"
BRANCH = "stable/train"
PROTOCOL = "https"
PV = "6.12.0+git${SRCPV}"
S = "${WORKDIR}/git"
SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
inherit setuptools monitor rmargparse
DEPENDS += " \
python-pip \
python-pbr-native\
"
# Satisfy setup.py 'setup_requires'
DEPENDS += " \
python-pbr-native \
"
RDEPENDS_${PN} += " \
python-pbr \
python-cliff \
python-debtcollector \
python-iso8601 \
python-netaddr \
python-osc-lib \
python-oslo.i18n \
python-oslo.serialization \
python-oslo.utils \
python-os-client-config \
python-keystoneauth1 \
python-keystoneclient \
python-requests \
python-simplejson \
python-six \
python-babel \
"
PACKAGECONFIG ?= "bash-completion"
PACKAGECONFIG[bash-completion] = ",,bash-completion,bash-completion ${BPN}-bash-completion"
do_install_append() {
install -d ${D}/${sysconfdir}/bash_completion.d
install -m 664 ${S}/tools/neutron.bash_completion ${D}/${sysconfdir}/bash_completion.d
}
PACKAGES =+ "${BPN}-bash-completion"
FILES_${BPN}-bash-completion = "${sysconfdir}/bash_completion.d/*"
MONITOR_CHECKS_${PN} += "\
neutron-api-check.sh \
"