| # |
| ## Copyright (C) 2019 Wind River Systems, Inc. |
| # |
| # Licensed under the Apache License, Version 2.0 (the "License"); |
| # you may not use this file except in compliance with the License. |
| # You may obtain a copy of the License at |
| # |
| # http://www.apache.org/licenses/LICENSE-2.0 |
| # |
| # Unless required by applicable law or agreed to in writing, software |
| # distributed under the License is distributed on an "AS IS" BASIS, |
| # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. |
| # See the License for the specific language governing permissions and |
| # limitations under the License. |
| |
| DESCRIPTION = "Command Line Interface Formulation Framework" |
| HOMEPAGE = "https://github.com/dreamhost/cliff" |
| SECTION = "devel/python" |
| LICENSE = "Apache-2.0" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| |
| SRC_URI[md5sum] = "4c5d43d98970c79b091e25676cce2b10" |
| SRC_URI[sha256sum] = "b47387a344898ccb28ca7f386f017ade9eb66dc1713e5c642a0bc09ec606cc67" |
| |
| inherit setuptools pypi |
| |
| DEPENDS += "\ |
| python-pbr \ |
| " |
| |
| # Satisfy setup.py 'setup_requires' |
| DEPENDS += " \ |
| python-pbr-native \ |
| " |
| |
| RDEPENDS_${PN} += "python-prettytable \ |
| python-cmd2 \ |
| python-pbr \ |
| python-pyparsing \ |
| python-prettytable \ |
| python-six \ |
| python-stevedore \ |
| python-unicodecsv \ |
| python-pyyaml \ |
| " |
| |
| CLEANBROKEN = "1" |