| # |
| # Copyright (C) 2019 Wind River Systems, Inc. |
| # |
| # Licensed under the Apache License, Version 2.0 (the "License"); |
| # you may not use this file except in compliance with the License. |
| # You may obtain a copy of the License at |
| # |
| # http://www.apache.org/licenses/LICENSE-2.0 |
| # |
| # Unless required by applicable law or agreed to in writing, software |
| # distributed under the License is distributed on an "AS IS" BASIS, |
| # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. |
| # See the License for the specific language governing permissions and |
| # limitations under the License. |
| |
| do_install_append() { |
| install -d ${D}/${sysconfdir}/bash_completion.d |
| install -m 755 ${S}/extras/django_bash_completion ${D}/${sysconfdir}/bash_completion.d |
| } |
| |
| PACKAGES =+ "${PN}-bash-completion" |
| |
| FILES_${PN}-bash-completion = "${sysconfdir}/bash_completion.d/*" |