| # |
| ## Copyright (C) 2019 Wind River Systems, Inc. |
| # |
| # Licensed under the Apache License, Version 2.0 (the "License"); |
| # you may not use this file except in compliance with the License. |
| # You may obtain a copy of the License at |
| # |
| # http://www.apache.org/licenses/LICENSE-2.0 |
| # |
| # Unless required by applicable law or agreed to in writing, software |
| # distributed under the License is distributed on an "AS IS" BASIS, |
| # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. |
| # See the License for the specific language governing permissions and |
| # limitations under the License. |
| |
| DESCRIPTION = "Oslo Context Library" |
| HOMEPAGE = "https://launchpad.net/oslo" |
| SECTION = "devel/python" |
| LICENSE = "Apache-2.0" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2" |
| |
| SRCREV = "76a07f9022f0fa967707c9f6cb5a4a24aac6b3ef" |
| SRCNAME = "oslo.context" |
| PROTOCOL = "https" |
| BRANCH = "stable/stein" |
| S = "${WORKDIR}/git" |
| PV = "2.22.1+git${SRCPV}" |
| |
| SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}" |
| |
| inherit setuptools |
| |
| DEPENDS += " \ |
| python-pip \ |
| python-pbr-native \ |
| " |
| |
| # Satisfy setup.py 'setup_requires' |
| DEPENDS += " \ |
| python-pbr-native \ |
| " |
| |
| # RDEPENDS_default: |
| RDEPENDS_${PN} += " \ |
| bash \ |
| python-pbr \ |
| python-debtcollector \ |
| python-positional \ |
| " |