blob: 665a359887f8bcaa8b3c2ccba9a4b813d5a5b2b1 [file] [log] [blame]
Jackie Huang57fdea72020-04-23 11:29:15 +08001#
2## Copyright (C) 2019 Wind River Systems, Inc.
3#
4# Licensed under the Apache License, Version 2.0 (the "License");
5# you may not use this file except in compliance with the License.
6# You may obtain a copy of the License at
7#
8# http://www.apache.org/licenses/LICENSE-2.0
9#
10# Unless required by applicable law or agreed to in writing, software
11# distributed under the License is distributed on an "AS IS" BASIS,
12# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13# See the License for the specific language governing permissions and
14# limitations under the License.
15
16DESCRIPTION = "Oslo db library"
17HOMEPAGE = "http://launchpad.net/oslo"
18SECTION = "devel/python"
19LICENSE = "Apache-2.0"
20LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
21
22SRCREV = "4de33ebd504a2c3dbddc2492bdb96ae7bca77d66"
23SRCNAME = "oslo.db"
24PROTOCOL = "https"
25BRANCH = "stable/stein"
26S = "${WORKDIR}/git"
27PV = "4.27.0+git${SRCPV}"
28
29SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
30
31inherit setuptools
32
33DEPENDS += " \
34 python-pip \
35 python-pbr-native \
36 "
37
38RDEPENDS_${PN} += " \
39 python-oslo.config \
40 python-oslo.i18n \
41 python-oslo.serialization \
42 python-oslo.utils \
43 python-six \
44 python-alembic \
45 python-sqlalchemy \
46 python-sqlalchemy-migrate \
47 python-stevedore \
48 python-pbr \
49 python-debtcollector \
50 "