blob: f71a190708425efeafa12dd2236ef9c0aa3942f2 [file] [log] [blame]
Jackie Huang57fdea72020-04-23 11:29:15 +08001#
2## Copyright (C) 2019 Wind River Systems, Inc.
3#
4# Licensed under the Apache License, Version 2.0 (the "License");
5# you may not use this file except in compliance with the License.
6# You may obtain a copy of the License at
7#
8# http://www.apache.org/licenses/LICENSE-2.0
9#
10# Unless required by applicable law or agreed to in writing, software
11# distributed under the License is distributed on an "AS IS" BASIS,
12# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13# See the License for the specific language governing permissions and
14# limitations under the License.
15
16DESCRIPTION = "Oslo versionedobjects library"
17HOMEPAGE = "https://wiki.openstack.org/wiki/Oslo"
18SECTION = "devel/python"
19LICENSE = "Apache-2.0"
20LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
21
22SRCREV = "c95f0c876840e36f37acb14d5eec5238d85e7dce"
23SRCNAME = "oslo.versionedobjects"
24PROTOCOL = "https"
25BRANCH = "stable/queens"
26S = "${WORKDIR}/git"
27PV = "1.31.2+git${SRCPV}"
28
29SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
30
31inherit setuptools
32
33DEPENDS += " \
34 python-pip \
35 python-pbr-native \
36 "
37
38RDEPENDS_${PN} += " \
39 python-six \
40 python-oslo.concurrency \
41 python-oslo.config \
42 python-oslo.context \
43 python-oslo.messaging \
44 python-oslo.serialization \
45 python-oslo.utils \
46 python-oslo.log \
47 python-oslo.i18n \
48 python-webob \
49 python-iso8601 \
50 python-netaddr \
51 "