blob: de2431992dc5f374cd66883487bd042c017c639f [file] [log] [blame]
Jackie Huang57fdea72020-04-23 11:29:15 +08001#
2## Copyright (C) 2019 Wind River Systems, Inc.
3#
4# Licensed under the Apache License, Version 2.0 (the "License");
5# you may not use this file except in compliance with the License.
6# You may obtain a copy of the License at
7#
8# http://www.apache.org/licenses/LICENSE-2.0
9#
10# Unless required by applicable law or agreed to in writing, software
11# distributed under the License is distributed on an "AS IS" BASIS,
12# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13# See the License for the specific language governing permissions and
14# limitations under the License.
15
16DESCRIPTION = "CLI and python client library for OpenStack Sahara"
17HOMEPAGE = "https://launchpad.net/sahara"
18SECTION = "devel/python"
19LICENSE = "Apache-2.0"
20LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
21
22DEPENDS += " \
23 python-pip \
24 python-pbr \
25 "
26
27# Satisfy setup.py 'setup_requires'
28DEPENDS += " \
29 python-pbr-native \
30"
31
32RDEPENDS_${PN} += " \
33 python-pbr \
34 "
35
36SRCNAME = "saharaclient"
37
38SRC_URI = "git://github.com/openstack/python-saharaclient.git;branch=master"
39
40PV = "2.3.0+git${SRCPV}"
41SRCREV = "3107b452467537f4eef3d9ecfb5e35d110d19662"
42S = "${WORKDIR}/git"
43
44inherit setuptools
45