blob: ec5a963c348bbb74770ca03ce96135fdb263e583 [file] [log] [blame]
Jackie Huang57fdea72020-04-23 11:29:15 +08001#
2# Copyright (C) 2019 Wind River Systems, Inc.
3#
4# Licensed under the Apache License, Version 2.0 (the "License");
5# you may not use this file except in compliance with the License.
6# You may obtain a copy of the License at
7#
8# http://www.apache.org/licenses/LICENSE-2.0
9#
10# Unless required by applicable law or agreed to in writing, software
11# distributed under the License is distributed on an "AS IS" BASIS,
12# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13# See the License for the specific language governing permissions and
14# limitations under the License.
15
16DESCRIPTION = "MailTools is a set of Perl modules related to mail applications"
17HOMEPAGE = "http://search.cpan.org/dist/MailTools/"
18SECTION = "libs"
19LICENSE = "Artistic-1.0 | GPL-1.0+"
20LIC_FILES_CHKSUM = "file://lib/Mail/Mailer.pod;beginline=144;md5=93c9027e72612b3555f857c4fc17b953"
21DEPENDS = " \
22 libtest-pod-perl-native \
23 libtimedate-perl-native \
24 "
25RDEPENDS_${PN} += " \
26 libtest-pod-perl \
27 libtimedate-perl \
28 perl-module-io-handle \
29 perl-module-net-smtp \
30 perl-module-test-more \
31 "
32BBCLASSEXTEND = "native"
33
34SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/MailTools-${PV}.tar.gz"
35SRC_URI[md5sum] = "972468ab5207b90398d77bed4ffc361d"
36SRC_URI[sha256sum] = "dfee9e770257371112f20d978e637759e81bc4f19e97b083585c71ecab37b527"
37
38S = "${WORKDIR}/MailTools-${PV}"
39
40inherit cpan
41