blob: ca70c301813a4a0a88c6593e2f10ee58032e7a23 [file] [log] [blame]
Jackie Huang3de4de22020-09-10 23:46:29 +08001#
2# Copyright (C) 2019 Wind River Systems, Inc.
3#
4# Licensed under the Apache License, Version 2.0 (the "License");
5# you may not use this file except in compliance with the License.
6# You may obtain a copy of the License at
7#
8# http://www.apache.org/licenses/LICENSE-2.0
9#
10# Unless required by applicable law or agreed to in writing, software
11# distributed under the License is distributed on an "AS IS" BASIS,
12# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13# See the License for the specific language governing permissions and
14# limitations under the License.
15#
16
17SUMMARY = " CherryPy is a pythonic, object-oriented HTTP framework"
18DESCRIPTION = "\
19It allows building web applications in much the same way one would build any \
20other object-oriented program. This design results in less and more readable \
21code being developed faster. It's all just properties and methods. \
22It is now more than ten years old and has proven fast and very stable. \
23It is being used in production by many sites, from the simplest to the most \
24demanding. \
25"
26
27HOMEPAGE = "https://www.cherrypy.org/"
28AUTHOR = "CherryPy Team"
29
30LICENSE = "BSD"
31LIC_FILES_CHKSUM = "file://cherrypy/LICENSE.txt;md5=c187ff3653a0878075713adef2c545c3"
32
33SRC_URI = "https://pypi.python.org/packages/source/C/CherryPy/CherryPy-${PV}.tar.gz"
34SRC_URI[md5sum] = "c1b1e9577f65f9bb88bfd1b15b93b911"
35SRC_URI[sha256sum] = "dc5a88562795c2ee462dac5b37aba1cf4f34f3e27281ec11049227039308b691"
36
37S = "${WORKDIR}/CherryPy-${PV}"
38
39inherit setuptools
40
41FILES_${PN} += "\
42 ${datadir}/cherrypy \
43"