Jackie Huang | 57fdea7 | 2020-04-23 11:29:15 +0800 | [diff] [blame] | 1 | # |
| 2 | ## Copyright (C) 2019 Wind River Systems, Inc. |
| 3 | # |
| 4 | # Licensed under the Apache License, Version 2.0 (the "License"); |
| 5 | # you may not use this file except in compliance with the License. |
| 6 | # You may obtain a copy of the License at |
| 7 | # |
| 8 | # http://www.apache.org/licenses/LICENSE-2.0 |
| 9 | # |
| 10 | # Unless required by applicable law or agreed to in writing, software |
| 11 | # distributed under the License is distributed on an "AS IS" BASIS, |
| 12 | # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. |
| 13 | # See the License for the specific language governing permissions and |
| 14 | # limitations under the License. |
| 15 | |
| 16 | DESCRIPTION = "Kubernetes python client" |
| 17 | HOMEPAGE = "https://pypi.org/project/kubernetes/8.0.0" |
| 18 | SECTION = "devel/python" |
| 19 | LICENSE = "Apache-2.0" |
| 20 | LIC_FILES_CHKSUM = "file://LICENSE;md5=ad09685d909e7a9f763d2bb62d4bd6fb" |
| 21 | |
| 22 | SRC_URI[md5sum] = "c1d6d0ac57a8a49c5fd383a39ee9ab4b" |
| 23 | SRC_URI[sha256sum] = "54f8e7bb1dd9a55cf416dff76a63c4ae441764280942d9913f2243676f29d02c" |
| 24 | |
| 25 | inherit setuptools pypi |
| 26 | |
| 27 | RDEPENDS_${PN}_append = " \ |
| 28 | ${PYTHON_PN}-adal \ |
| 29 | ${PYTHON_PN}-google-auth \ |
| 30 | ${PYTHON_PN}-requests-oauthlib \ |
| 31 | " |