blob: 75588bef805625b2ecb871c08ff9f87c0177eb41 [file] [log] [blame]
Jackie Huang57fdea72020-04-23 11:29:15 +08001#
2# Copyright (C) 2019 Wind River Systems, Inc.
3#
4# Licensed under the Apache License, Version 2.0 (the "License");
5# you may not use this file except in compliance with the License.
6# You may obtain a copy of the License at
7#
8# http://www.apache.org/licenses/LICENSE-2.0
9#
10# Unless required by applicable law or agreed to in writing, software
11# distributed under the License is distributed on an "AS IS" BASIS,
12# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13# See the License for the specific language governing permissions and
14# limitations under the License.
15
16DESCRIPTION = "The Python perf module is a toolkit to write, run and analyze benchmarks."
17
18LICENSE = "MIT"
19LIC_FILES_CHKSUM = "file://COPYING;md5=78bc2e6e87c8c61272937b879e6dc2f8"
20
21SRCREV = "7febee0242ce8fd01f56bce2ec72ec536a41caed"
22PROTOCOL = "https"
23BRANCH = "master"
24S = "${WORKDIR}/git"
25
26SRC_URI = "git://github.com/vstinner/pyperf.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
27
28
29# DEPENDS += " python python-pbr-native"
30DEPENDS += " python"
31inherit setuptools distutils pkgconfig