blob: f90f508cd48773125ee347f06062153d0161ecf8 [file] [log] [blame]
Jackie Huang57fdea72020-04-23 11:29:15 +08001#
2## Copyright (C) 2019 Wind River Systems, Inc.
3#
4# Licensed under the Apache License, Version 2.0 (the "License");
5# you may not use this file except in compliance with the License.
6# You may obtain a copy of the License at
7#
8# http://www.apache.org/licenses/LICENSE-2.0
9#
10# Unless required by applicable law or agreed to in writing, software
11# distributed under the License is distributed on an "AS IS" BASIS,
12# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13# See the License for the specific language governing permissions and
14# limitations under the License.
15
16DESCRIPTION = "Client side API implementation of the Redfish RESTful API for Data Center Hardware Management."
17HOMEPAGE = "https://github.com/DMTF/Redfishtool"
18SECTION = "devel/python"
19LICENSE = "BSD-3-Clause"
20LIC_FILES_CHKSUM = "file://LICENSE.md;md5=cee7a7694b5bf14bc9d3e0fbe78a64af"
21
22
23SRCREV = "2bdcd905e1ad227f40809ec298804d5401047612"
24SRCNAME = "Redfishtool"
25BRANCH = "master"
26PROTOCOL = "https"
27PV = "1.1.0+git${SRCPV}"
28S = "${WORKDIR}/git"
29
30SRC_URI = "git://github.com/DMTF/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
31
32inherit setuptools3
33
34RDEPENDS_${PN} += " \
35 python3-requests \
36"
37
38do_install_append() {
39 :
40}
41
42FILES_${PN} += " \
43 "