blob: 0c08e6ddddda8661895883e91766648c6ea2befc [file] [log] [blame]
Jackie Huang57fdea72020-04-23 11:29:15 +08001#
2# Copyright (C) 2019 Wind River Systems, Inc.
3#
4# Licensed under the Apache License, Version 2.0 (the "License");
5# you may not use this file except in compliance with the License.
6# You may obtain a copy of the License at
7#
8# http://www.apache.org/licenses/LICENSE-2.0
9#
10# Unless required by applicable law or agreed to in writing, software
11# distributed under the License is distributed on an "AS IS" BASIS,
12# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13# See the License for the specific language governing permissions and
14# limitations under the License.
15
16SUMMARY = " Web Services Made Easy (WSME)"
17DESCRIPTION = "\
18 Web Services Made Easy (WSME) simplifies the writing of REST web services by providing simple yet \
19 powerful typing, removing the need to directly manipulate the request and the response objects. \
20 "
21
22
23LICENSE = "MIT"
24LIC_FILES_CHKSUM = "file://LICENSE;md5=5a9126e7f56a0cf3247050de7f10d0f4"
25
26SRCREV = "f36a607124355007d3a830ebe7e53efda777c58a"
27PROTOCOL = "https"
28BRANCH = "master"
29S = "${WORKDIR}/git/"
30
31SRC_URI = "git://opendev.org/x/wsme.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
32
33
34DEPENDS += " python3 python3-pbr-native"
35inherit distutils3