Jackie Huang | 57fdea7 | 2020-04-23 11:29:15 +0800 | [diff] [blame] | 1 | # |
| 2 | ## Copyright (C) 2019 Wind River Systems, Inc. |
| 3 | # |
| 4 | # Licensed under the Apache License, Version 2.0 (the "License"); |
| 5 | # you may not use this file except in compliance with the License. |
| 6 | # You may obtain a copy of the License at |
| 7 | # |
| 8 | # http://www.apache.org/licenses/LICENSE-2.0 |
| 9 | # |
| 10 | # Unless required by applicable law or agreed to in writing, software |
| 11 | # distributed under the License is distributed on an "AS IS" BASIS, |
| 12 | # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. |
| 13 | # See the License for the specific language governing permissions and |
| 14 | # limitations under the License. |
| 15 | |
| 16 | # This class is intended to include workarounds and finetuning of the rootfs |
| 17 | # Most of the stuff in here needs to go else where. |
| 18 | |
| 19 | ROOTFS_POSTPROCESS_COMMAND_append = " stx_postprocess_rootfs;" |
| 20 | # ETHDEV = "enp0s5" |
| 21 | |
| 22 | stx_postprocess_rootfs() { |
| 23 | |
| 24 | # Issue: #83 /dev/root does not exist |
| 25 | # This workaround is to be removed once initramfs is added |
| 26 | |
| 27 | cat > ${IMAGE_ROOTFS}/etc/udev/rules.d/99-dev-root-symlink.rules << \EOF |
| 28 | KERNEL=="sda3", SYMLINK+="root" |
| 29 | EOF |
| 30 | } |