Jackie Huang | 57fdea7 | 2020-04-23 11:29:15 +0800 | [diff] [blame] | 1 | # |
| 2 | # Copyright (C) 2019 Wind River Systems, Inc. |
| 3 | # |
| 4 | # Licensed under the Apache License, Version 2.0 (the "License"); |
| 5 | # you may not use this file except in compliance with the License. |
| 6 | # You may obtain a copy of the License at |
| 7 | # |
| 8 | # http://www.apache.org/licenses/LICENSE-2.0 |
| 9 | # |
| 10 | # Unless required by applicable law or agreed to in writing, software |
| 11 | # distributed under the License is distributed on an "AS IS" BASIS, |
| 12 | # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. |
| 13 | # See the License for the specific language governing permissions and |
| 14 | # limitations under the License. |
| 15 | |
| 16 | DESCRIPTION = "Perl extensions for IPv6" |
| 17 | HOMEPAGE = "https://metacpan.org/release/Socket6" |
| 18 | SECTION = "libs" |
| 19 | LICENSE = "BSD" |
| 20 | LIC_FILES_CHKSUM = "file://README;beginline=31;md5=ad207d410de6d8ca6b4655469baa1ab4" |
| 21 | |
| 22 | BBCLASSEXTEND = "native" |
| 23 | |
| 24 | CFLAGS += "-D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE" |
| 25 | BUILD_CFLAGS += "-D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE" |
| 26 | |
| 27 | SRC_URI = "http://search.cpan.org/CPAN/authors/id/U/UM/UMEMOTO/Socket6-${PV}.tar.gz;name=socket6-perl-${PV}" |
| 28 | SRC_URI[socket6-perl-0.23.md5sum] = "2c02adb13c449d48d232bb704ddbd492" |
| 29 | SRC_URI[socket6-perl-0.23.sha256sum] = "eda753f0197e8c3c8d4ab20a634561ce84011fa51aa5ff40d4dbcb326ace0833" |
| 30 | |
| 31 | S = "${WORKDIR}/Socket6-${PV}" |
| 32 | |
| 33 | do_configure_prepend () { |
| 34 | mkdir -p m4 |
| 35 | autoreconf -Wcross --verbose --install --force || oefatal "autoreconf execution failed." |
| 36 | sed -i 's:\./configure\(.[^-]\):./configure --build=${BUILD_SYS} --host=${HOST_SYS} --target=${TARGET_SYS} --prefix=${prefix} --exec_prefix=${exec_prefix} --bindir=${bindir} --sbindir=${sbindir} --libexecdir=${libexecdir} --datadir=${datadir} --sysconfdir=${sysconfdir} --sharedstatedir=${sharedstatedir} --localstatedir=${localstatedir} --libdir=${libdir} --includedir=${includedir} --oldincludedir=${oldincludedir} --infodir=${infodir} --mandir=${mandir}\1:' Makefile.PL |
| 37 | } |
| 38 | |
| 39 | inherit cpan |