blob: 0e1a43b502ba29d90a4ca1049600068c188a3b9c [file] [log] [blame]
Jackie Huang73acc912020-04-02 15:15:59 +08001SUMMARY = "Linux kernel Development Source"
2DESCRIPTION = "Development source linux kernel. When built, this recipe packages the \
3source of the preferred virtual/kernel provider and makes it available for full kernel \
4development or external module builds"
5
6SECTION = "kernel"
7
8LICENSE = "GPLv2"
9
10inherit linux-kernel-base
11
12# Whilst not a module, this ensures we don't get multilib extended (which would make no sense)
13inherit module-base
14
15# We need the kernel to be staged (unpacked, patched and configured) before
16# we can grab the source and make the source package. We also need the bits from
17# ${B} not to change while we install, so virtual/kernel must finish do_compile.
18do_install[depends] += "virtual/kernel:do_shared_workdir"
19# Need the source, not just the output of populate_sysroot
20do_install[depends] += "virtual/kernel:do_install"
21
22# There's nothing to do here, except install the source where we can package it
23do_fetch[noexec] = "1"
24do_unpack[noexec] = "1"
25do_patch[noexec] = "1"
26do_configure[noexec] = "1"
27do_compile[noexec] = "1"
28do_populate_sysroot[noexec] = "1"
29
30S = "${STAGING_KERNEL_DIR}"
31B = "${STAGING_KERNEL_BUILDDIR}"
32
33KERNEL_VERSION = "${@get_kernelversion_headers('${S}')}"
34
35PACKAGE_ARCH = "${MACHINE_ARCH}"
36
37do_install() {
38 kerneldir=${D}${KERNEL_SRC_PATH}
39 install -d $kerneldir
40
41 #
42 # Copy the staging dir source (and module build support) into the devsrc structure.
43 # We can keep this copy simple and take everything, since a we'll clean up any build
44 # artifacts afterwards, and the extra i/o is not significant
45 #
46 cd ${B}
47 find . -type d -name '.git*' -prune -o -path '.debug' -prune -o -type f -print0 | cpio --null -pdlu $kerneldir
48 cd ${S}
49 find . -type d -name '.git*' -prune -o -type d -name '.kernel-meta' -prune -o -type f -print0 | cpio --null -pdlu $kerneldir
50
51 # Explicitly set KBUILD_OUTPUT to ensure that the image directory is cleaned and not
52 # The main build artifacts. We clean the directory to avoid QA errors on mismatched
53 # architecture (since scripts and helpers are native format).
54 KBUILD_OUTPUT="$kerneldir"
55 oe_runmake -C $kerneldir CC="${KERNEL_CC}" LD="${KERNEL_LD}" clean _mrproper_scripts
56
57 # make clean generates an absolute path symlink called "source"
58 # in $kerneldir points to $kerneldir, which doesn't make any
59 # sense, so remove it.
60 if [ -L $kerneldir/source ]; then
61 bbnote "Removing $kerneldir/source symlink"
62 rm -f $kerneldir/source
63 fi
64
65 # As of Linux kernel version 3.0.1, the clean target removes
66 # arch/powerpc/lib/crtsavres.o which is present in
67 # KBUILD_LDFLAGS_MODULE, making it required to build external modules.
68 if [ ${ARCH} = "powerpc" ]; then
69 mkdir -p $kerneldir/arch/powerpc/lib/
70 cp ${B}/arch/powerpc/lib/crtsavres.o $kerneldir/arch/powerpc/lib/crtsavres.o
71 fi
72
73 # Remove fixdep/objtool as they won't be target binaries
74 for i in fixdep objtool; do
75 if [ -e $kerneldir/tools/objtool/$i ]; then
76 rm -rf $kerneldir/tools/objtool/$i
77 fi
78 done
79
80 chown -R root:root ${D}
81}
82# Ensure we don't race against "make scripts" during cpio
83do_install[lockfiles] = "${TMPDIR}/kernel-scripts.lock"
84
85PACKAGES = "kernel-devsrc"
86FILES_${PN} = "${KERNEL_SRC_PATH}"
87RDEPENDS_${PN} = "bc"
88
89INSANE_SKIP_${PN} = "arch"