Jackie Huang | e0634c6 | 2022-05-05 19:49:22 +0800 | [diff] [blame^] | 1 | DESCRIPTION = "TIS Platform Patching" |
| 2 | SUMMARY = "Patch alarm management" |
| 3 | |
| 4 | require update-common.inc |
| 5 | |
| 6 | SUBPATH0 = "patch-alarm/patch-alarm" |
| 7 | |
| 8 | LICENSE = "Apache-2.0" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 10 | |
| 11 | RDEPENDS_${PN}_append = " \ |
| 12 | bash \ |
| 13 | python \ |
| 14 | python-requests-toolbelt \ |
| 15 | " |
| 16 | |
| 17 | inherit setuptools |
| 18 | |
| 19 | do_unpack_append() { |
| 20 | bb.build.exec_func('do_restore_files', d) |
| 21 | } |
| 22 | |
| 23 | do_restore_files() { |
| 24 | cd ${S} |
| 25 | git reset ${SRCREV} patch-alarm/scripts |
| 26 | git checkout patch-alarm/scripts |
| 27 | } |
| 28 | |
| 29 | |
| 30 | do_install_append () { |
| 31 | |
| 32 | cd ${S}/patch-alarm/ |
| 33 | |
| 34 | install -m 755 -d ${D}/${bindir} |
| 35 | install -m 755 -d ${D}/${sysconfdir}/init.d |
| 36 | |
| 37 | install -m 700 scripts/bin/patch-alarm-manager ${D}/${bindir}/ |
| 38 | install -m 700 scripts/init.d/patch-alarm-manager ${D}/${sysconfdir}/init.d/ |
| 39 | } |