blob: 9de6d75ff28b7b039a251750831cb6599e804f70 [file] [log] [blame]
Jackie Huange0634c62022-05-05 19:49:22 +08001DESCRIPTION = "TIS Platform Patching"
2SUMMARY = "Patch alarm management"
3
4require update-common.inc
5
6SUBPATH0 = "patch-alarm/patch-alarm"
7
8LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
10
11RDEPENDS_${PN}_append = " \
12 bash \
13 python \
14 python-requests-toolbelt \
15 "
16
17inherit setuptools
18
19do_unpack_append() {
20 bb.build.exec_func('do_restore_files', d)
21}
22
23do_restore_files() {
24 cd ${S}
25 git reset ${SRCREV} patch-alarm/scripts
26 git checkout patch-alarm/scripts
27}
28
29
30do_install_append () {
31
32 cd ${S}/patch-alarm/
33
34 install -m 755 -d ${D}/${bindir}
35 install -m 755 -d ${D}/${sysconfdir}/init.d
36
37 install -m 700 scripts/bin/patch-alarm-manager ${D}/${bindir}/
38 install -m 700 scripts/init.d/patch-alarm-manager ${D}/${sysconfdir}/init.d/
39}