blob: 91604e27250beaa2b27820546d38b7548aa73b97 [file] [log] [blame]
Jackie Huang57fdea72020-04-23 11:29:15 +08001#
2# Copyright (C) 2019 Wind River Systems, Inc.
3#
4# Licensed under the Apache License, Version 2.0 (the "License");
5# you may not use this file except in compliance with the License.
6# You may obtain a copy of the License at
7#
8# http://www.apache.org/licenses/LICENSE-2.0
9#
10# Unless required by applicable law or agreed to in writing, software
11# distributed under the License is distributed on an "AS IS" BASIS,
12# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13# See the License for the specific language governing permissions and
14# limitations under the License.
15
16SUMMARY = " Lang - Python Language Constraints"
17DESCRIPTION = "\
18 Lang is a Python module that allows enforcing programming language constraints. Lang was \
19 built using a Java like mindset, so many of the constraints that are supported are mirrors \
20 of constraints in the Java programming language. \
21 "
22
23
24LICENSE = "Apache-2.0"
25LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
26
27SRCREV = "feb4c638ebc581d9913f440965e83558fd10018c"
28PROTOCOL = "https"
29BRANCH = "master"
30S = "${WORKDIR}/git/src"
31
32SRC_URI = "git://github.com/amitassaraf/lang.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
33
34
35DEPENDS += " python3 python3-setuptools-scm-native"
36inherit setuptools3 distutils3 pkgconfig