blob: 15f8eb6f8107a1c320b2246c6bfbf4e845887898 [file] [log] [blame]
Damjan Marion4d2f86a2019-01-18 13:28:22 +01001#!/usr/bin/make -f
2# See debhelper(7) (uncomment to enable)
3# output every command that modifies files on the build system.
4DH_VERBOSE = 1
5
6# see EXAMPLES in dpkg-buildflags(1) and read /usr/share/dpkg/*
7DPKG_EXPORT_BUILDFLAGS = 1
8include /usr/share/dpkg/default.mk
9
Ole Troane4a6d692019-03-13 18:08:42 +010010export PYBUILD_NAME = vpp-api
Damjan Marion4d2f86a2019-01-18 13:28:22 +010011export PYBUILD_DIR = @CMAKE_SOURCE_DIR@/vpp-api/python
Ole Troane4a6d692019-03-13 18:08:42 +010012export PYBUILD_DESTDIR_python3=debian/python3-vpp-api/
13export PYBUILD_DISABLE_python3=test
Damjan Marion4d2f86a2019-01-18 13:28:22 +010014export PYBUILD_SYSTEM=distutils
Damjan Mariona4164932020-05-12 12:22:18 +020015DH_WITH = systemd,python3
Damjan Mariona4164932020-05-12 12:22:18 +020016
Ole Troane4a6d692019-03-13 18:08:42 +010017build3vers := $(shell py3versions -sv)
18
Damjan Marion4d2f86a2019-01-18 13:28:22 +010019# main packaging script based on dh7 syntax
20%:
Damjan Mariona4164932020-05-12 12:22:18 +020021 dh $@ --with $(DH_WITH) --buildsystem=pybuild
Damjan Marion4d2f86a2019-01-18 13:28:22 +010022
Damjan Marion4d2f86a2019-01-18 13:28:22 +010023override_dh_strip:
24 dh_strip --dbg-package=vpp-dbg
25
26DEB_HOST_MULTIARCH = $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
27
28override_dh_install:
Damjan Marion4686d392019-01-22 10:28:29 +010029 @for c in @VPP_COMPONENTS@; do \
Damjan Marion4d2f86a2019-01-18 13:28:22 +010030 @CMAKE_COMMAND@ \
31 -D CMAKE_INSTALL_CONFIG_NAME=@CMAKE_BUILD_TYPE@ \
32 -D CMAKE_INSTALL_COMPONENT=$$c \
Damjan Marion88b2e362021-04-29 18:47:25 +020033 -D CMAKE_INSTALL_PREFIX=@VPP_BINARY_DIR@/debian/$$c \
Damjan Mariond734b8d2019-01-22 11:14:46 +010034 -P @CMAKE_BINARY_DIR@/cmake_install.cmake 2>&1 \
35 | grep -v 'Set runtime path of' ; \
Damjan Marion4d2f86a2019-01-18 13:28:22 +010036 if [ -d debian/$$c/lib ] ; then \
37 mv debian/$$c/lib debian/$$c/$(DEB_HOST_MULTIARCH) ; \
38 mkdir -p debian/$$c/usr/lib ; \
39 mv debian/$$c/$(DEB_HOST_MULTIARCH) debian/$$c/usr/lib ; \
40 fi ; \
Damjan Marion4686d392019-01-22 10:28:29 +010041 for d in bin include share ; do \
42 if [ -d debian/$$c/$$d ] ; then \
43 mkdir -p debian/$$c/usr ; \
44 mv debian/$$c/$$d debian/$$c/usr/$$d ; \
45 fi ; \
46 done ; \
47 if [ -d debian/$$c ] ; then \
48 @CMAKE_SOURCE_DIR@/scripts/remove-rpath debian/$$c ; \
Damjan Marion4d2f86a2019-01-18 13:28:22 +010049 fi ; \
Damjan Marion4d2f86a2019-01-18 13:28:22 +010050 done