blob: ceef46a297a1fb0cc7de106c7f0ee817d7e0e3e0 [file] [log] [blame]
Damjan Marion4d2f86a2019-01-18 13:28:22 +01001#!/usr/bin/make -f
2# See debhelper(7) (uncomment to enable)
3# output every command that modifies files on the build system.
4DH_VERBOSE = 1
5
6# see EXAMPLES in dpkg-buildflags(1) and read /usr/share/dpkg/*
7DPKG_EXPORT_BUILDFLAGS = 1
8include /usr/share/dpkg/default.mk
9
Ole Troane4a6d692019-03-13 18:08:42 +010010export PYBUILD_NAME = vpp-api
Damjan Marion4d2f86a2019-01-18 13:28:22 +010011export PYBUILD_DIR = @CMAKE_SOURCE_DIR@/vpp-api/python
12export PYBUILD_DESTDIR_python2=debian/vpp-api-python/
13export PYBUILD_DISABLE_python2=test
Ole Troane4a6d692019-03-13 18:08:42 +010014export PYBUILD_DESTDIR_python3=debian/python3-vpp-api/
15export PYBUILD_DISABLE_python3=test
Damjan Marion4d2f86a2019-01-18 13:28:22 +010016export PYBUILD_SYSTEM=distutils
17
Ole Troane4a6d692019-03-13 18:08:42 +010018buildvers := $(shell pyversions -sv)
19build3vers := $(shell py3versions -sv)
20
Damjan Marion4d2f86a2019-01-18 13:28:22 +010021# main packaging script based on dh7 syntax
22%:
Ole Troane4a6d692019-03-13 18:08:42 +010023 dh $@ --with systemd,python2,python3 --buildsystem=pybuild
Damjan Marion4d2f86a2019-01-18 13:28:22 +010024
Damjan Marion4d2f86a2019-01-18 13:28:22 +010025override_dh_strip:
26 dh_strip --dbg-package=vpp-dbg
27
28DEB_HOST_MULTIARCH = $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
29
30override_dh_install:
Damjan Marion4686d392019-01-22 10:28:29 +010031 @for c in @VPP_COMPONENTS@; do \
Damjan Marion4d2f86a2019-01-18 13:28:22 +010032 @CMAKE_COMMAND@ \
33 -D CMAKE_INSTALL_CONFIG_NAME=@CMAKE_BUILD_TYPE@ \
34 -D CMAKE_INSTALL_COMPONENT=$$c \
35 -D CMAKE_INSTALL_PREFIX=@CMAKE_BINARY_DIR@/debian/$$c \
Damjan Mariond734b8d2019-01-22 11:14:46 +010036 -P @CMAKE_BINARY_DIR@/cmake_install.cmake 2>&1 \
37 | grep -v 'Set runtime path of' ; \
Damjan Marion4d2f86a2019-01-18 13:28:22 +010038 if [ -d debian/$$c/lib ] ; then \
39 mv debian/$$c/lib debian/$$c/$(DEB_HOST_MULTIARCH) ; \
40 mkdir -p debian/$$c/usr/lib ; \
41 mv debian/$$c/$(DEB_HOST_MULTIARCH) debian/$$c/usr/lib ; \
42 fi ; \
Damjan Marion4686d392019-01-22 10:28:29 +010043 for d in bin include share ; do \
44 if [ -d debian/$$c/$$d ] ; then \
45 mkdir -p debian/$$c/usr ; \
46 mv debian/$$c/$$d debian/$$c/usr/$$d ; \
47 fi ; \
48 done ; \
49 if [ -d debian/$$c ] ; then \
50 @CMAKE_SOURCE_DIR@/scripts/remove-rpath debian/$$c ; \
Damjan Marion4d2f86a2019-01-18 13:28:22 +010051 fi ; \
Damjan Marion4d2f86a2019-01-18 13:28:22 +010052 done