Thomas F Herbert | 20a29c7 | 2016-10-13 18:36:50 -0400 | [diff] [blame] | 1 | %define _vpp_build_dir build-tool-native |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 2 | %define _unitdir /lib/systemd/system |
| 3 | %define _topdir %(pwd) |
| 4 | %define _builddir %{_topdir} |
Damjan Marion | c06eeb0 | 2017-04-18 15:26:39 +0200 | [diff] [blame] | 5 | %define _mu_build_dir %{_topdir}/%{name}-%{_version}/build-root |
| 6 | %define _vpp_install_dir install-vpp-native |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 7 | |
Ole Troan | 57c3d66 | 2016-09-12 22:00:32 +0200 | [diff] [blame] | 8 | # Failsafe backport of Python2-macros for RHEL <= 6 |
| 9 | %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")} |
| 10 | %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")} |
| 11 | %{!?python_version: %global python_version %(%{__python} -c "import sys; sys.stdout.write(sys.version[:3])")} |
| 12 | %{!?__python2: %global __python2 %{__python}} |
| 13 | %{!?python2_sitelib: %global python2_sitelib %{python_sitelib}} |
| 14 | %{!?python2_sitearch: %global python2_sitearch %{python_sitearch}} |
| 15 | %{!?python2_version: %global python2_version %{python_version}} |
| 16 | |
| 17 | %{!?python2_minor_version: %define python2_minor_version %(%{__python} -c "import sys ; print sys.version[2:3]")} |
| 18 | |
Peter Ginchev | dfa9c5b | 2016-10-11 15:34:24 +0300 | [diff] [blame] | 19 | %{?systemd_requires} |
| 20 | |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 21 | Name: vpp |
| 22 | Summary: Vector Packet Processing |
| 23 | License: MIT |
| 24 | Version: %{_version} |
| 25 | Release: %{_release} |
Padraig | b21b676 | 2016-09-21 14:59:02 +0100 | [diff] [blame] | 26 | Requires: vpp-lib = %{_version}-%{_release}, net-tools, pciutils, python |
Damjan Marion | a1bd023 | 2016-12-19 19:08:11 +0100 | [diff] [blame] | 27 | BuildRequires: systemd, chrpath |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 28 | |
Damjan Marion | c06eeb0 | 2017-04-18 15:26:39 +0200 | [diff] [blame] | 29 | # Source: %{name}-%{_version}-%{_release}.tar.xz |
| 30 | Source: vpp-latest.tar.xz |
Thomas F Herbert | 20a29c7 | 2016-10-13 18:36:50 -0400 | [diff] [blame] | 31 | |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 32 | %description |
Damjan Marion | 08ff7e0 | 2016-01-20 13:45:36 +0100 | [diff] [blame] | 33 | This package provides VPP executables: vpp, vpp_api_test, vpp_json_test |
| 34 | vpp - the vector packet engine |
| 35 | vpp_api_test - vector packet engine API test tool |
| 36 | vpp_json_test - vector packet engine JSON test tool |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 37 | |
| 38 | %package lib |
| 39 | Summary: VPP libraries |
| 40 | Group: System Environment/Libraries |
| 41 | |
| 42 | %description lib |
| 43 | This package contains the VPP shared libraries, including: |
| 44 | vppinfra - foundation library supporting vectors, hashes, bitmaps, pools, and string formatting. |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 45 | svm - vm library |
| 46 | vlib - vector processing library |
| 47 | vlib-api - binary API library |
| 48 | vnet - network stack library |
| 49 | |
| 50 | %package devel |
| 51 | Summary: VPP header files, static libraries |
| 52 | Group: Development/Libraries |
| 53 | Requires: vpp-lib |
| 54 | |
| 55 | %description devel |
Thomas F Herbert | 3977a21 | 2016-10-01 18:09:33 -0400 | [diff] [blame] | 56 | This package contains the header files for VPP. |
| 57 | Install this package if you want to write a |
| 58 | program for compilation and linking with vpp lib. |
| 59 | vlib |
| 60 | vlibmemory |
| 61 | vnet - devices, classify, dhcp, ethernet flow, gre, ip, etc. |
| 62 | vpp-api |
| 63 | vppinfra |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 64 | |
Ed Warnicke | f5a1436 | 2016-09-12 20:40:24 +0000 | [diff] [blame] | 65 | %package plugins |
| 66 | Summary: Vector Packet Processing--runtime plugins |
| 67 | Group: System Environment/Libraries |
| 68 | Requires: vpp = %{_version}-%{_release} |
| 69 | %description plugins |
| 70 | This package contains VPP plugins |
| 71 | |
Damjan Marion | cb034b9 | 2016-12-28 18:38:59 +0100 | [diff] [blame] | 72 | %package api-lua |
| 73 | Summary: VPP api lua bindings |
| 74 | Group: Development/Libraries |
| 75 | Requires: vpp = %{_version}-%{_release}, vpp-lib = %{_version}-%{_release} |
| 76 | |
| 77 | %description api-lua |
| 78 | This package contains the lua bindings for the vpp api |
| 79 | |
| 80 | %package api-java |
| 81 | Summary: VPP api java bindings |
| 82 | Group: Development/Libraries |
| 83 | Requires: vpp = %{_version}-%{_release}, vpp-lib = %{_version}-%{_release} |
| 84 | |
| 85 | %description api-java |
| 86 | This package contains the java bindings for the vpp api |
| 87 | |
| 88 | %package api-python |
Ole Troan | 57c3d66 | 2016-09-12 22:00:32 +0200 | [diff] [blame] | 89 | Summary: VPP api python bindings |
| 90 | Group: Development/Libraries |
Ole Troan | c60f557 | 2017-03-17 09:54:51 +0100 | [diff] [blame] | 91 | Requires: vpp = %{_version}-%{_release}, vpp-lib = %{_version}-%{_release}, python-setuptools libffi-devel |
Ole Troan | 57c3d66 | 2016-09-12 22:00:32 +0200 | [diff] [blame] | 92 | |
Damjan Marion | cb034b9 | 2016-12-28 18:38:59 +0100 | [diff] [blame] | 93 | %description api-python |
Ole Troan | 57c3d66 | 2016-09-12 22:00:32 +0200 | [diff] [blame] | 94 | This package contains the python bindings for the vpp api |
| 95 | |
Thomas F Herbert | 20a29c7 | 2016-10-13 18:36:50 -0400 | [diff] [blame] | 96 | %prep |
| 97 | %setup -q -n %{name}-%{_version} |
| 98 | |
Ed Warnicke | ec6290a | 2016-06-08 17:15:08 -0500 | [diff] [blame] | 99 | %pre |
| 100 | # Add the vpp group |
Ed Warnicke | b10427e | 2016-06-08 19:49:40 -0500 | [diff] [blame] | 101 | groupadd -f -r vpp |
Ed Warnicke | ec6290a | 2016-06-08 17:15:08 -0500 | [diff] [blame] | 102 | |
Ole Troan | c60f557 | 2017-03-17 09:54:51 +0100 | [diff] [blame] | 103 | %build |
Damjan Marion | c06eeb0 | 2017-04-18 15:26:39 +0200 | [diff] [blame] | 104 | make bootstrap |
| 105 | make -C build-root PLATFORM=vpp TAG=vpp install-packages |
Ole Troan | c60f557 | 2017-03-17 09:54:51 +0100 | [diff] [blame] | 106 | cd %{_mu_build_dir}/../src/vpp-api/python && %py2_build |
| 107 | |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 108 | %install |
| 109 | # |
| 110 | # binaries |
| 111 | # |
| 112 | mkdir -p -m755 %{buildroot}%{_bindir} |
| 113 | mkdir -p -m755 %{buildroot}%{_unitdir} |
Gabriel Ganne | 714968b | 2017-01-26 15:42:39 +0100 | [diff] [blame] | 114 | install -p -m 755 %{_mu_build_dir}/%{_vpp_install_dir}/vpp/bin/* %{buildroot}%{_bindir} |
Ole Troan | f14e3bf | 2016-12-01 21:49:03 +0100 | [diff] [blame] | 115 | |
Damjan Marion | 7cd468a | 2016-12-19 23:05:39 +0100 | [diff] [blame] | 116 | # api |
Ole Troan | f14e3bf | 2016-12-01 21:49:03 +0100 | [diff] [blame] | 117 | mkdir -p -m755 %{buildroot}/usr/share/vpp/api |
Ole Troan | f14e3bf | 2016-12-01 21:49:03 +0100 | [diff] [blame] | 118 | |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 119 | # |
| 120 | # configs |
| 121 | # |
| 122 | mkdir -p -m755 %{buildroot}/etc/vpp |
Miroslav Miklus | 8e08e74 | 2016-10-11 13:35:26 +0200 | [diff] [blame] | 123 | mkdir -p -m755 %{buildroot}/etc/sysctl.d |
Damjan Marion | c06eeb0 | 2017-04-18 15:26:39 +0200 | [diff] [blame] | 124 | install -p -m 644 %{_topdir}/vpp.service %{buildroot}%{_unitdir} |
Damjan Marion | d0f673e | 2017-01-31 17:29:33 +0100 | [diff] [blame] | 125 | install -p -m 644 %{_mu_build_dir}/../src/vpp/conf/startup.conf %{buildroot}/etc/vpp/startup.conf |
Damjan Marion | 7cd468a | 2016-12-19 23:05:39 +0100 | [diff] [blame] | 126 | install -p -m 644 %{_mu_build_dir}/../src/vpp/conf/80-vpp.conf %{buildroot}/etc/sysctl.d |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 127 | # |
| 128 | # libraries |
| 129 | # |
| 130 | mkdir -p -m755 %{buildroot}%{_libdir} |
Padraig Connolly | 69915cb | 2017-01-10 17:10:39 +0000 | [diff] [blame] | 131 | mkdir -p -m755 %{buildroot}/etc/bash_completion.d |
| 132 | mkdir -p -m755 %{buildroot}/usr/share/vpp |
Thomas F Herbert | 20a29c7 | 2016-10-13 18:36:50 -0400 | [diff] [blame] | 133 | for file in $(find %{_mu_build_dir}/%{_vpp_install_dir}/*/lib* -type f -name '*.so.*.*.*' -print ) |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 134 | do |
| 135 | install -p -m 755 $file %{buildroot}%{_libdir} |
| 136 | done |
| 137 | for file in $(cd %{buildroot}%{_libdir} && find . -type f -print | sed -e 's/^\.\///') |
| 138 | do |
| 139 | # make lib symlinks |
| 140 | ( cd %{buildroot}%{_libdir} && |
| 141 | ln -fs $file $(echo $file | sed -e 's/\(\.so\.[0-9]\+\).*/\1/') ) |
Ed Warnicke | f5a0e73 | 2016-09-07 17:12:52 +0000 | [diff] [blame] | 142 | ( cd %{buildroot}%{_libdir} && |
| 143 | ln -fs $file $(echo $file | sed -e 's/\(\.so\)\.[0-9]\+.*/\1/') ) |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 144 | done |
Damjan Marion | 7cd468a | 2016-12-19 23:05:39 +0100 | [diff] [blame] | 145 | for file in $(find %{_mu_build_dir}/%{_vpp_install_dir}/vpp/share/vpp/api -type f -name '*.api.json' -print ) |
Ole Troan | f14e3bf | 2016-12-01 21:49:03 +0100 | [diff] [blame] | 146 | do |
| 147 | install -p -m 644 $file %{buildroot}/usr/share/vpp/api |
| 148 | done |
Padraig Connolly | 69915cb | 2017-01-10 17:10:39 +0000 | [diff] [blame] | 149 | install -p -m 644 %{_mu_build_dir}/../src/scripts/vppctl_completion %{buildroot}/etc/bash_completion.d |
| 150 | install -p -m 644 %{_mu_build_dir}/../src/scripts/vppctl-cmd-list %{buildroot}/usr/share/vpp |
Ed Warnicke | 406ab9d | 2016-08-31 18:48:47 -0700 | [diff] [blame] | 151 | |
Damjan Marion | cb034b9 | 2016-12-28 18:38:59 +0100 | [diff] [blame] | 152 | # Lua bindings |
| 153 | mkdir -p -m755 %{buildroot}/usr/share/doc/vpp/examples/lua/examples/cli |
| 154 | mkdir -p -m755 %{buildroot}/usr/share/doc/vpp/examples/lua/examples/lute |
| 155 | for file in $(cd %{_mu_build_dir}/%{_vpp_install_dir}/../../src/vpp-api/lua && git ls-files .) |
| 156 | do |
| 157 | install -p -m 644 %{_mu_build_dir}/%{_vpp_install_dir}/../../src/vpp-api/lua/$file \ |
| 158 | %{buildroot}/usr/share/doc/vpp/examples/lua/$file |
| 159 | done |
| 160 | |
| 161 | # Java bindings |
| 162 | mkdir -p -m755 %{buildroot}/usr/share/java |
| 163 | for file in $(find %{_mu_build_dir}/%{_vpp_install_dir}/vpp/share/java -type f -name '*.jar' -print ) |
| 164 | do |
| 165 | install -p -m 644 $file %{buildroot}/usr/share/java |
| 166 | done |
| 167 | |
Ole Troan | 57c3d66 | 2016-09-12 22:00:32 +0200 | [diff] [blame] | 168 | # Python bindings |
Ole Troan | c60f557 | 2017-03-17 09:54:51 +0100 | [diff] [blame] | 169 | cd %{_mu_build_dir}/../src/vpp-api/python && %py2_install |
Ole Troan | 57c3d66 | 2016-09-12 22:00:32 +0200 | [diff] [blame] | 170 | |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 171 | # |
| 172 | # devel |
| 173 | # |
Thomas F Herbert | 20a29c7 | 2016-10-13 18:36:50 -0400 | [diff] [blame] | 174 | for dir in $(find %{_mu_build_dir}/%{_vpp_install_dir}/*/include/ -maxdepth 0 -type d -print | grep -v dpdk) |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 175 | do |
| 176 | for subdir in $(cd ${dir} && find . -type d -print) |
| 177 | do |
| 178 | mkdir -p -m755 %{buildroot}/usr/include/${subdir} |
| 179 | done |
| 180 | for file in $(cd ${dir} && find . -type f -print) |
| 181 | do |
| 182 | install -p -m 644 $dir/$file %{buildroot}%{_includedir}/$file |
| 183 | done |
| 184 | done |
Ed Warnicke | 406ab9d | 2016-08-31 18:48:47 -0700 | [diff] [blame] | 185 | |
| 186 | mkdir -p -m755 %{buildroot}%{python2_sitelib}/jvppgen |
Damjan Marion | cb034b9 | 2016-12-28 18:38:59 +0100 | [diff] [blame] | 187 | install -p -m755 %{_mu_build_dir}/../src/vpp-api/java/jvpp/gen/jvpp_gen.py %{buildroot}/usr/bin |
| 188 | for i in $(ls %{_mu_build_dir}/../src/vpp-api/java/jvpp/gen/jvppgen/*.py); do |
Ed Warnicke | 406ab9d | 2016-08-31 18:48:47 -0700 | [diff] [blame] | 189 | install -p -m666 ${i} %{buildroot}%{python2_sitelib}/jvppgen |
| 190 | done; |
| 191 | |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 192 | # sample plugin |
| 193 | mkdir -p -m755 %{buildroot}/usr/share/doc/vpp/examples/sample-plugin/sample |
Damjan Marion | cb034b9 | 2016-12-28 18:38:59 +0100 | [diff] [blame] | 194 | for file in $(cd %{_mu_build_dir}/%{_vpp_install_dir}/../../src/examples/sample-plugin && git ls-files .) |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 195 | do |
Damjan Marion | cb034b9 | 2016-12-28 18:38:59 +0100 | [diff] [blame] | 196 | install -p -m 644 %{_mu_build_dir}/%{_vpp_install_dir}/../../src/examples/sample-plugin/$file \ |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 197 | %{buildroot}/usr/share/doc/vpp/examples/sample-plugin/$file |
| 198 | done |
| 199 | |
Ed Warnicke | f5a1436 | 2016-09-12 20:40:24 +0000 | [diff] [blame] | 200 | |
| 201 | # |
| 202 | # vpp-plugins |
| 203 | # |
Ed Warnicke | e7637e7 | 2016-09-14 16:58:33 -0700 | [diff] [blame] | 204 | mkdir -p -m755 %{buildroot}/usr/lib/vpp_plugins |
| 205 | mkdir -p -m755 %{buildroot}/usr/lib/vpp_api_test_plugins |
Damjan Marion | 7cd468a | 2016-12-19 23:05:39 +0100 | [diff] [blame] | 206 | for file in $(cd %{_mu_build_dir}/%{_vpp_install_dir}/vpp/lib64/vpp_plugins && find -type f -print) |
| 207 | do |
| 208 | install -p -m 644 %{_mu_build_dir}/%{_vpp_install_dir}/vpp/lib64/vpp_plugins/$file \ |
| 209 | %{buildroot}/usr/lib/vpp_plugins/$file |
| 210 | done |
| 211 | |
Damjan Marion | 7cd468a | 2016-12-19 23:05:39 +0100 | [diff] [blame] | 212 | for file in $(cd %{_mu_build_dir}/%{_vpp_install_dir}/vpp/lib64/vpp_api_test_plugins && find -type f -print) |
| 213 | do |
| 214 | install -p -m 644 %{_mu_build_dir}/%{_vpp_install_dir}/vpp/lib64/vpp_api_test_plugins/$file \ |
| 215 | %{buildroot}/usr/lib/vpp_api_test_plugins/$file |
| 216 | done |
| 217 | |
Ole Troan | f14e3bf | 2016-12-01 21:49:03 +0100 | [diff] [blame] | 218 | for file in $(find %{_mu_build_dir}/%{_vpp_install_dir}/plugins -type f -name '*.api.json' -print ) |
| 219 | do |
| 220 | install -p -m 644 $file %{buildroot}/usr/share/vpp/api |
| 221 | done |
| 222 | |
Damjan Marion | a1bd023 | 2016-12-19 19:08:11 +0100 | [diff] [blame] | 223 | # |
| 224 | # remove RPATH from ELF binaries |
| 225 | # |
| 226 | %{_mu_build_dir}/scripts/remove-rpath %{buildroot} |
| 227 | |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 228 | %post |
| 229 | sysctl --system |
| 230 | %systemd_post vpp.service |
| 231 | |
Peter Ginchev | dfa9c5b | 2016-10-11 15:34:24 +0300 | [diff] [blame] | 232 | %preun |
| 233 | %systemd_preun vpp.service |
| 234 | |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 235 | %postun |
Peter Ginchev | dfa9c5b | 2016-10-11 15:34:24 +0300 | [diff] [blame] | 236 | %systemd_postun |
| 237 | |
| 238 | # Unbind user-mode PCI drivers |
| 239 | removed= |
| 240 | pci_dirs=`find /sys/bus/pci/drivers -type d -name igb_uio -o -name uio_pci_generic -o -name vfio-pci` |
| 241 | for d in $pci_dirs; do |
| 242 | for f in ${d}/*; do |
| 243 | [ -e "${f}/config" ] || continue |
Radu Nicolau | 02767e9 | 2017-02-23 14:28:49 +0000 | [diff] [blame] | 244 | echo ${f##*/} > ${d}/unbind |
Peter Ginchev | dfa9c5b | 2016-10-11 15:34:24 +0300 | [diff] [blame] | 245 | basename `dirname ${f}` | xargs echo -n "Removing driver"; echo " for PCI ID" `basename ${f}` |
| 246 | removed=y |
| 247 | done |
| 248 | done |
| 249 | if [ -n "${removed}" ]; then |
| 250 | echo "There are changes in PCI drivers, rescaning" |
| 251 | echo 1 > /sys/bus/pci/rescan |
| 252 | else |
| 253 | echo "There weren't PCI devices binded" |
| 254 | fi |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 255 | |
| 256 | %files |
| 257 | %defattr(-,bin,bin) |
| 258 | %{_unitdir}/vpp.service |
Damjan Marion | 08ff7e0 | 2016-01-20 13:45:36 +0100 | [diff] [blame] | 259 | /usr/bin/vpp* |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 260 | /usr/bin/svm* |
Dave Barach | 0e5e3c3 | 2016-01-25 08:28:22 -0500 | [diff] [blame] | 261 | /usr/bin/elftool |
Miroslav Miklus | 8e08e74 | 2016-10-11 13:35:26 +0200 | [diff] [blame] | 262 | %config /etc/sysctl.d/80-vpp.conf |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 263 | %config /etc/vpp/startup.conf |
Ole Troan | f14e3bf | 2016-12-01 21:49:03 +0100 | [diff] [blame] | 264 | /usr/share/vpp/api/* |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 265 | |
| 266 | %files lib |
| 267 | %defattr(-,bin,bin) |
Ed Warnicke | f5a1436 | 2016-09-12 20:40:24 +0000 | [diff] [blame] | 268 | %exclude %{_libdir}/vpp_plugins |
| 269 | %exclude %{_libdir}/vpp_api_test_plugins |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 270 | %{_libdir}/* |
Ole Troan | f14e3bf | 2016-12-01 21:49:03 +0100 | [diff] [blame] | 271 | /usr/share/vpp/api/* |
Padraig Connolly | 69915cb | 2017-01-10 17:10:39 +0000 | [diff] [blame] | 272 | /etc/bash_completion.d/vppctl_completion |
| 273 | /usr/share/vpp/vppctl-cmd-list |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 274 | |
Damjan Marion | cb034b9 | 2016-12-28 18:38:59 +0100 | [diff] [blame] | 275 | %files api-lua |
Gabriel Ganne | f3854e9 | 2017-01-17 10:00:54 +0100 | [diff] [blame] | 276 | %defattr(644,root,root,644) |
Damjan Marion | cb034b9 | 2016-12-28 18:38:59 +0100 | [diff] [blame] | 277 | /usr/share/doc/vpp/examples/lua |
| 278 | |
| 279 | %files api-java |
| 280 | %defattr(644,root,root) |
| 281 | /usr/share/java/* |
| 282 | |
| 283 | %files api-python |
Ole Troan | 57c3d66 | 2016-09-12 22:00:32 +0200 | [diff] [blame] | 284 | %defattr(644,root,root) |
Ole Troan | c60f557 | 2017-03-17 09:54:51 +0100 | [diff] [blame] | 285 | %{python2_sitelib}/vpp_papi* |
Ole Troan | 57c3d66 | 2016-09-12 22:00:32 +0200 | [diff] [blame] | 286 | |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 287 | %files devel |
| 288 | %defattr(-,bin,bin) |
| 289 | /usr/bin/vppapigen |
Ed Warnicke | 406ab9d | 2016-08-31 18:48:47 -0700 | [diff] [blame] | 290 | /usr/bin/jvpp_gen.py |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 291 | %{_includedir}/* |
Ed Warnicke | 406ab9d | 2016-08-31 18:48:47 -0700 | [diff] [blame] | 292 | %{python2_sitelib}/jvppgen/* |
Ed Warnicke | cb9cada | 2015-12-08 15:45:58 -0700 | [diff] [blame] | 293 | /usr/share/doc/vpp/examples/sample-plugin |
Ed Warnicke | 406ab9d | 2016-08-31 18:48:47 -0700 | [diff] [blame] | 294 | |
Ed Warnicke | f5a1436 | 2016-09-12 20:40:24 +0000 | [diff] [blame] | 295 | %files plugins |
| 296 | %defattr(-,bin,bin) |
Ed Warnicke | e7637e7 | 2016-09-14 16:58:33 -0700 | [diff] [blame] | 297 | /usr/lib/vpp_plugins/* |
| 298 | /usr/lib/vpp_api_test_plugins/* |
Ole Troan | f14e3bf | 2016-12-01 21:49:03 +0100 | [diff] [blame] | 299 | /usr/share/vpp/api/* |